• Install ISO (Minimal) does not work with ATI Radeon 2600

    I would like to use my old iMac Mid 2007 with antergos. I am running antergos on 3 other machines and this is the first one that gives me headaches. The install ISO does not work, because X fails to start. As far as I have understood other answers on the internet, the very old graphic card (ATI Radeon HD 2600 Pro) is causing the problem. Because I have no knowledge about the inner workings of current Linux distributions and the way X works, I am lost.

    I tried other Arch based distros, but they have the same problem. Only a Debian based distro (Mint) manages to start a live environment. I have no idea what Mint does different (using a plain old generic VGA driver without acceleration?), but it works right out of the box.

    Is there a way (maybe some magical boot parameters) to let antergos live cd (minimal or standard) start with at least a basic graphical environment that let me install the system?

  • @steffen.eichenberg isnt there some alternative graphic options on the boot screen? i havent used them but thought i saw some graphic options.

  • @megaman There are tree options that I see.

    1. boot to install
    2. boot without graphical interface (fallback)
    3. boot NVidia (fallback)

    these are not the exact phrases, but something along that line.

    I tried to boot with every option. Option 1) and 2) have the same effect: antergos tries to configure/start X and fails. I did not expect that, especially with option 2). I tried several times (sometimes you THINK you selected option 2, but … just to be sure :) ). Option 3) results in a black screen.

    In the meantime, I tried the full ISO. The logs in the console are different; I do not see any X specific details. Just a message about antergos trying to start the graphical interface and then it seems to hang.

  • Because I do not want to use a debian based distro, I tried other Arch based distros. One of them does run with my graphic card (at least as a live CD). It is Manjaro Linux (the XFCE edition). So at least it does not seem to be an issue with Arch, or at least an unsolvable issue. I booted using the default options.

  • Hi,

    Did you try to boot with the nomodeset or radeon.modeset=0 options?

  • @karasu Sorry for the delay. I have been ill. I will try that this evening and report the result.

  • I tried nomodeset and radeon.modeset=0 and radeon.modeset=1

    With nomodeset and radeon.modeset=0 the screen is always black. No text mode, no graphic mode.

    With radeon.modeset=1 I get to see the text terminal. Kernel starts, services are starting and then the X server fails with “Fatal server error: no screen found”. The Xorg.0.log file says something along the line:

    Chipset: “ATI Mobility Radeon HD 2600 XT”
    [drm] Failed to open DRM device for pci:0000:01:00.0: No such file or directory
    Kernel modesetting setup failed
    Unload module “radeon”
    Screen found, but none had a usable configuration

  • Just an idea: Manjaro is using the 4.4 LTS kernel while antergos is using a 4.7 kernel. Might there be a difference in the kernel modules provided?

  • there is a way to force a resolution with nomodeset, but i don’t remember and i can’t find it, maybe then it will work.
    Did you try “quiet splash nomodeset” and just “nomodeset”?

    The site beneath shows some options:

    Options for Video problems:

    [email protected]
    video=VGA-1:[email protected]

    To allow Nvidia hybrid machines to boot.

  • In the Xorg.0.log file of Manjaro, X Server is loading sub modules after stating

    Chipset: “ATI Mobility Radeon HD 2600 XT”

    The submodules are “fb”, “dri2” and “exa”. After that, it identifies my monitor correctly.

  • @fernandomaroto I tried “quiet splash nomodeset”, “nomodeset”, “quiet splash radeon.modeset=0”, “quiet splash radeon.modeset=1”, “radeon.modeset=0”, “radeon.modeset=1”, “grub_gfxmode=vesa”, “grub_gfxmode=1024x768x16”

    nomodeset and radeon.modeset=0 results in an all black screen from the time leaving Grub.
    radeon.modeset=1 lets me see at least the text terminal. I can log in, but the X server refuses to start (see previous post).

  • ok, i’m newbie, i have no more knowledge to help you about this, sorry and good luck.

iso83 radeon15 minimal10 ati8 Posts 12Views 2430
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.