• AMD Radeon R5 Graphics Card - Black Screen


    This is a follow up to my previous post, where I installed arch using antergos and the Cnchi installer.
    https://forum.antergos.com/topic/5245/dev-disk-by-label-antergos-device-did-not-show-up-after-30-seconds

    Now, my problem is the following:

    When I boot, I get a black screen with an arrow cursor.

    I can, however, press “Ctrl Alt F2” to get to the command prompt, and can log
    in using the username and password I defined during the installtion.

    I think what I need to do is: pass “nomodeset” to the kernel when booting.

    By googling, I found some information on what nomodeset does:
    http://askubuntu.com/questions/716957/what-do-the-nomodeset-quiet-and-splash-kernel-parameters-mean
    On some video cards you end up with a black screen. Adding the nomodeset parameter
    instructs the kernel to not load video drivers and use BIOS modes instead until
    X is loaded.

    “nomodeset” seemed to help when I was installing, so now I have arch installed,
    the question is, how to pass nomodeset when booting?

    I notice that on the command line, I can cd to “/boot/grub”. So, my newly
    installed antergos system uses Grub.

    Using the information here:
    https://wiki.archlinux.org/index.php/Kernel_parameters
    … I can work out how to pass the “nomodeset” parameter to grub.

    Edit /etc/default/grub and append your kernel options to the GRUB_CMDLINE_LINUX_DEFAULT line:

    sudo nano /etc/default/grub

    I removed “quiet” from the beginning of the GRUB_CMDLINE_LINUX_DEFAULT line.
    I appended “nomodeset” to the end of the GRUB_CMDLINE_LINUX_DEFAULT line.

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    reboot


    Unfortunately, I am still getting the black screen with the arrow cursor.


    Some more information about my system:

    $ lspci | grep VGA
    00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R5 Graphics]

    After reading the instructions here:
    https://wiki.archlinux.org/index.php/ATI#Selecting_the_right_driver
    … I have installed the following packages:
    xf86-video-ati
    mesa-libgl
    mesa-vdpau


    After reading:
    https://forum.antergos.com/topic/1335/how-to-include-system-logs-when-asking-for-help
    … I am attaching my logs.

    EDIT - when I try to upload my logs.tar file I get the following error:
    You do not have enough privileges for this action.

    [0_1477128585706_logs.tar](Uploading 100%)
    [0_1477128428342_logs.tar](Uploading 100%)
    [0_1477128461430_logs.tar](Uploading 100%)

    EDIT - This post looks promising, I will read it next:
    https://forum.antergos.com/topic/5227/black-screen-after-installing-ati-drivers

    Hmm. Not sure whether or not to follow the advice in the youtube video: https://www.youtube.com/watch?v=0P-mG8s8Deg

    • I don’t know if my graphics card:
      [AMD/ATI] Kaveri [Radeon R5 Graphics]
      … is one to which these instructions apply.

    • I read here: https://wiki.archlinux.org/index.php/ATI that, generally speaking, it is preferred to use the open source drivers over the proprietary ones.

    But basically, I’m at the end of my knowledge here, and I need to take a break from this for a few hours.

    If any of you reading this can provide me with any pointers, I would be most grateful.

  • ok, when GRUB shows you the boot options go unto the one you want and press E
    then confirm if nomodeset is there (almost at the botom to the right) or if is something like quiet, or quiet splash
    If is not there delete quiet splash and add nomodeset
    if nomodeset is already appearing there then maybe is another problem.

    I have AMD here, but i’m using the mesa driver wich now supports AMD.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Thank you for your reply @fernandomaroto .

    By pressing “e” at boot up time I am able to edit the GRUB settings.

    “nomodeset” is already there, at the end of the line that begins with “linux”.

    That line also contained the word “quiet” which I removed.

    I then press F10.

    It continues to boot, I get the encryption password prompt on the command line (I set up encryption in the Cnchi installation).

    Then I get very quickly a bunch of green and white text lines, then it gives me a black screen with an arrow cursor.

  • Solved!

    This gave me the correct clue:
    http://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it

    If your graphics card is ATI, follow these steps:

    1. In the GRUB menu at startup, press “e”; then
    2. Use the arrow keys to replace quiet splash with radeon.modeset=0.
    3. Then press the Ctrl+x key combination to boot.

    The key thing was to use:
    radeon.modeset=0
    instead of:
    nomodeset

    Thanks again @fernandomaroto for helping me get on the right track.

  • I’m happy you fixed, you’re welcome
    :+1:

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • To summarize:

    The final fix for this problem was as follows:

    Edit /etc/default/grub and append your kernel options to the GRUB_CMDLINE_LINUX_DEFAULT line:

    sudo nano /etc/default/grub

    I removed “quiet” from the beginning of the GRUB_CMDLINE_LINUX_DEFAULT line.
    I appended “radeon.modeset=0” to the end of the GRUB_CMDLINE_LINUX_DEFAULT line.

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    reboot

  • @behythoyg , thanks for sharing !
    Welcome aboard Antergos:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

black41 amd23 graphics14 radeon10 Posts 7Views 1053
Log in to reply