• KDM not save previous desktop used... always select openbox


    when start my xorg appear

    [url:wsztnlsh]https://dl.dropboxusercontent.com/u/1439791/IMG_20140225_201354.jpg[/url:wsztnlsh]

    y click in this and go to kdm and says the same…

    [url:wsztnlsh]https://dl.dropboxusercontent.com/u/1439791/IMG_20140225_200930.jpg[/url:wsztnlsh]
    (says: the session type openbox it’s not valid. Select a new type or the default will be used)

    how fix this?

    i can start kde withouth problems, but is message is disgusting

  • when start my xorg appear

    [url:wsztnlsh]https://dl.dropboxusercontent.com/u/1439791/IMG_20140225_201354.jpg[/url:wsztnlsh]

    y click in this and go to kdm and says the same…

    [url:wsztnlsh]https://dl.dropboxusercontent.com/u/1439791/IMG_20140225_200930.jpg[/url:wsztnlsh]
    (says: the session type openbox it’s not valid. Select a new type or the default will be used)

    how fix this?

    i can start kde withouth problems, but is message is disgusting

  • Hi,

    Check that you don’t have .xinitrc or .dmrc files in your home directory.

    Also check the kdm setup. The configuration file for KDM can be found at /usr/share/config/kdm/kdmrc.

    Cheers!

    P.S. Si lo prefieres, tienes un hilo donde se habla en castellano. Saludos!

  • @“karasu”:20mvlzbi said:

    Hi,

    Check that you don’t have .xinitrc or .dmrc files in your home directory.

    Also check the kdm setup. The configuration file for KDM can be found at /usr/share/config/kdm/kdmrc.

    Cheers!

    P.S. Si lo prefieres, tienes un hilo donde se habla en castellano. Saludos![/quote:20mvlzbi]

    i not have .drmc fille, but i have .xinitrc

    .xinitrc:

    !/bin/sh  
    > \#  
    > \# ~/.xinitrc  
    > \#  
    > \# Executed by startx (run your window manager from here)  
    >   
    > if [ -d /etc/X11/xinit/xinitrc.d ]; then  
    > for f in /etc/X11/xinit/xinitrc.d/\*; do  
    > [ -x "$f" ] && . "$f"  
    > done  
    > unset f  
    > fi  
    >   
    > \# exec gnome-session  
    > exec startkde  
    > \# exec startxfce4  
    > \# ...or the Window Manager of your choice
    

    kdmrc:

      
    > ConfigVersion=2.4  
    > ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6  
    > GreeterUID=kdm  
    > PidFile=/var/run/kdm.pid  
    > ReserveServers=:1,:2,:3  
    > ServerVTs=-7  
    > StaticServers=:0  
    >   
    > [Shutdown]  
    > BootManager=Grub2  
    > HaltCmd=/sbin/shutdown -h -P now  
    > RebootCmd=/sbin/shutdown -r now  
    >   
    > [X-\*-Core]  
    > AllowNullPasswd=false  
    > AllowRootLogin=false  
    > AllowShutdown=Root  
    > AutoReLogin=false  
    > ClientLogFile=.xsession-errors-%d  
    > Reset=/usr/share/config/kdm/Xreset  
    > Session=/usr/share/config/kdm/Xsession  
    > SessionsDirs=/usr/share/config/kdm/sessions,/usr/share/apps/kdm/sessions  
    > Setup=/usr/share/config/kdm/Xsetup  
    > Startup=/usr/share/config/kdm/Xstartup  
    >   
    > [X-\*-Greeter]  
    > AntiAliasing=true  
    > ColorScheme=  
    > FaceSource=AdminOnly  
    > FailFont=Sans Serif,10,-1,5,75,0,0,0,0,0  
    > ForgingSeed=1393195430  
    > GUIStyle=  
    > GreetFont=Serif,20,-1,5,50,0,0,0,0,0  
    > GreetString=Bienvenido a %s en %n  
    > GreeterPos=50,50  
    > HiddenUsers=  
    > Language=es  
    > LogoArea=Logo  
    > LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png  
    > MaxShowUID=65000  
    > MinShowUID=500  
    > Preloader=/usr/bin/preloadkde  
    > SelectedUsers=  
    > ShowUsers=NotHidden  
    > SortUsers=true  
    > StdFont=Sans Serif,10,-1,5,50,0,0,0,0,0  
    > Theme=/usr/share/apps/kdm/themes/elarun  
    > UseBackground=true  
    > UseTheme=true  
    > UserCompletion=false  
    > UserList=true  
    >   
    > [X-:\*-Core]  
    > AllowNullPasswd=true  
    > AllowShutdown=All  
    > NoPassEnable=false  
    > NoPassUsers=  
    > ServerArgsLocal=-nolisten tcp  
    > ServerCmd=/usr/bin/X -br -novtswitch -quiet  
    >   
    > [X-:\*-Greeter]  
    > AllowClose=false  
    > DefaultUser=darkmind  
    > FocusPasswd=true  
    > LoginMode=DefaultLocal  
    > PreselectUser=Default  
    >   
    > [X-:0-Core]  
    > AutoLoginEnable=true  
    > AutoLoginLocked=false  
    > AutoLoginUser=darkmind  
    > ClientLogFile=.xsession-errors  
    >   
    > [Xdmcp]  
    > Enable=false  
    > Willing=/usr/share/config/kdm/Xwilling  
    > 
    

    i don’t understand this…

    pd: se que hay foro en español pero me imagino que hay mas gente que habla inglés xD

  • Hi,

    Are you using kdm? .xinitrc is ok, and it’s used when you start Xorg using startx

    Somewhere you have setup openbox as default session… can’t you change this for your user in kdm welcome screen?

    How did you setup your system?

  • i never put openbox as default (where is a file for this?)

    i use kdm, if write other user not appear the message, but if i write “darkmind” (my user) appear this message related with openbox, openbox i used only one time (when download kde xD)

  • I install openbox again to try and kdm not save the last desktop used, always says Openbox (last session) y have to click in kde every time to login

  • I created a new user and now use this new user and everything works fine, I deleted the previous user
    thanks to all

  • Hi,

    I’m glad you found a workaround… but we’ll never know what was happening!

    Cheers!

Posts 9Views 1657
Log in to reply