• Black screen after installing ATI drivers


    Hallo together,

    after the installation from ATI drivers i become an black screen an booting into x. I cant do anything, strg+alt+F1 (or an other F button) brings me not to the console.

    I think my problem is, i have forget to activadet systemctl (atieventsd and catalyst-hook).

    Can i activated in an configfile? (I have an Windows driver to read/write my ext4 partition)

    Greetings

  • Good news, after I put this try this in kernel line before boot.

    video=vesa:off vga=normal

    I become an black screen with mouse curser and I can switch between ttys.

    I hope anyone have an idea how I can fix it.

    For information, catalyst-hook cannot installed because the dependencys

  • Hello, if possible watch this video on youtube. It’s pretty self-explanatory.
    https://www.youtube.com/watch?v=0P-mG8s8Deg
    Links for the driver download are outdated simply replace it with the new links

    If it’s not possible to watch this video, what AMD Card do you own? I ask because of the new amdgpu-pro driver…

  • @dante42 said in Black screen after installing ATI drivers:

    Hello, if possible watch this video on youtube. It’s pretty self-explanatory.
    https://www.youtube.com/watch?v=0P-mG8s8Deg
    Links for the driver download are outdated simply replace it with the new links

    If it’s not possible to watch this video, what AMD Card do you own? I ask because of the new amdgpu-pro driver…

    Hallo dante42,

    i make all the steps from the video.

    catalyst-hook have the wrong dependencies and i cannot install it.

    I have an AMD Radeon HD 6900 Series.

    Greetings

  • Hi Uriel, about what dependencies pacman is complaining? Wrong xorg or some mesa-stuff for example?

  • @dante42 said in Black screen after installing ATI drivers:

    Hi Uriel, about what dependencies pacman is complaining? Wrong xorg or some mesa-stuff for example?

    I Thinks (Now i am on windows) ist was catalyst-hook: requires linux<4.8

    Greetings

  • You must downgrade your kernel to 4.7.x or wait till the maintainer Vi0L0 updates catalyst-hook. Be sure to use this mirror for pacman.conf.
    http://mirror.hactar.xyz/Vi0L0/
    Also consider to use amdgpu-driver instead: https://wiki.archlinux.org/index.php/AMDGPU
    The catalyst drivers will no longer be further developed. Last one is from last year.
    I have two AMD R9 270X in my computer and I use the amdgpu-driver, because the amdgpu-pro driver don’t support these cards at the moment.
    When Catalyst gives me 100% the amdgpu-driver reaches 90%, BUT is actively refined…

  • Hello,
    1 ) add this to your pacman.conf, on top of all other repos.

    [xorg117]
    Server = http://catalyst.wirephire.com/repo/xorg117/$arch
    ## Mirrors, if the primary server does not work or is too slow:
    #Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch
    
    [catalyst]
    Server = http://catalyst.wirephire.com/repo/catalyst/$arch
    #Server = http://mirror.hactar.bz/Vi0L0/catalyst/$arch
    

    Maybe you need to add the repo key

    sudo pacman-key -r 653C3094
    sudo pacman-key --lsign-key 653C3094
    

    Now

    yaourt -Syyuu
    

    This will downgrade xorg and also (important) cogl.

    Then

    yaourt -S catalyst-test
    

    (if yaourt complains about a dependency issue, you may have to remove opencl-mesa) and

    sudo aticonfig --initial
    

    Finally add nomodeset to the kernel parameters in /etc/default/grub, then update grub and you can reboot.

    By the way, it works also for the 4.8 kernel, I’m running these drivers with kernel 4.8.2 at the moment.
    Hope that will help.

  • @papa33 said in Black screen after installing ATI drivers:

    Hello,
    1 ) add this to your pacman.conf, on top of all other repos.

    [xorg117]
    Server = http://catalyst.wirephire.com/repo/xorg117/$arch
    ## Mirrors, if the primary server does not work or is too slow:
    #Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch
    
    

    Ahhhhhh, many many Thanks. It Works :+1:

    Greetings

  • Great. In the mean time, I noticed that I cannot get lightdm (at least with the webkit2 antergos greeter) to work along with catalyst, but for example, mdm has no issue at all. May I ask what DM you are using?

  • @papa33 said in Black screen after installing ATI drivers:

    Great. In the mean time, I noticed that I cannot get lightdm (at least with the webkit2 antergos greeter) to work along with catalyst, but for example, mdm has no issue at all. May I ask what DM you are using?

    I dont no, i work with the default installation from Antergos with KDE Option.

    Greetings

  • @papa33 Unfortunately this doesn’t work for me, I still get black screen. Am I missing something?

  • @Irakli said in Black screen after installing ATI drivers:

    @papa33 Unfortunately this doesn’t work for me, I still get black screen. Am I missing something?

    What desktop (and what Display Manager) do you use? I use Cinnamon (mdm as DM) and for me it works, but with the same configuration I get a black screen with gnome-shell (did not try gdm but it might well result in a total black screen).
    Personnally I’m running right now the free radeon drivers, because anyway I don’t play games. Only issue : tooltip corruption in chromium/google-chrome.

  • @papa33 I use gnome, when I downgrade all my packages to 3 weeks ago it works just fine. So there might be a package that’s breaking it.

  • @Irakli said in Black screen after installing ATI drivers:

    @papa33 I use gnome, when I downgrade all my packages to 3 weeks ago it works just fine. So there might be a package that’s breaking it.

    Probably. I don’t know how I can help you, nevertheless as I wrote above I had to downgrade the cogl package in order to make Cinnamon work, but it might be breaking gnome. Maybe you could try to install the regular cogl package from extra. But I can’t tell if this will work…

  • @papa33 Well, I just tried GNOME on Xorg and unfortunately that didn’t work either. :(

black45 drivers33 installing66 ati8 Posts 16Views 1754
Log in to reply