• Keymap is changed everytime I logout


    Hi,
    Since I had Antergos installed in my laptop keymap doesn’t stay stable anytime. At first I solved this problem by calling a script everytime the system started which contains:

    #!/bin/bash
    setxkbmap es
    

    Nowadays I use Antergos more often and everytime I logout/login the keymap is changed to default, which is not spanish. How can I fix this issue?

    Thanks for the help

    Note: I have an acer laptop with dual boot Windows 8 + Antergos (GNOME).

    EDIT: This is shown with the wrong configuration of the keyboard:

    $ setxkbmap -print -verbose 10
    Setting verbose level to 10
    locale is C
    Trying to load rules file ./rules/evdev...
    Trying to load rules file /usr/share/X11/xkb/rules/evdev...
    Success.
    Applied rules from evdev:
    rules:      evdev
    model:      pc105
    layout:     us,es
    variant:    ,
    Trying to build keymap using the following components:
    keycodes:   evdev+aliases(qwerty)
    types:      complete
    compat:     complete
    symbols:    pc+us+es:2+inet(evdev)
    geometry:   pc(pc105)
    xkb_keymap {
    	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
    	xkb_types     { include "complete"	};
    	xkb_compat    { include "complete"	};
    	xkb_symbols   { include "pc+us+es:2+inet(evdev)"	};
    	xkb_geometry  { include "pc(pc105)"	};
    };
    

    And this with the right one:

    $ setxkbmap -print -verbose 10
    Setting verbose level to 10
    locale is C
    Trying to load rules file ./rules/evdev...
    Trying to load rules file /usr/share/X11/xkb/rules/evdev...
    Success.
    Applied rules from evdev:
    rules:      evdev
    model:      pc105
    layout:     es
    Trying to build keymap using the following components:
    keycodes:   evdev+aliases(qwerty)
    types:      complete
    compat:     complete
    symbols:    pc+es+inet(evdev)
    geometry:   pc(pc105)
    xkb_keymap {
    	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
    	xkb_types     { include "complete"	};
    	xkb_compat    { include "complete"	};
    	xkb_symbols   { include "pc+es+inet(evdev)"	};
    	xkb_geometry  { include "pc(pc105)"	};
    };
    
  • the key map can be configured at /etc/vconsole.conf
    i don’t use spanish keyboard, but maybe KEYMAP=es would be enough for you.
    Let’s wait for someone else to help you.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Keymap is changed everytime I logout:

    the key map can be configured at /etc/vconsole.conf
    i don’t use spanish keyboard, but maybe KEYMAP=es would be enough for you.
    Let’s wait for someone else to help you.

    That was already configured. Still having the same issues.

  • I finally fixed it. It was just as simple as going into “Configuration > Region and Language” and selecting correctly a Input Source. I was just adding Spanish to the list but not having it selected.

  • Nice to have it fixed by yourself. Please, remember to me ntion which DE (Desktop Environment) you are using. Different DEs have got different Settings Center.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

dual-boot11 fix4 keymap2 Posts 5Views 746
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.