• How to restore windows option at boot screen?


    I’m running a dual boot setup with windows 10 (Antergos being my primary OS) and I have a problem with actually getting into Windows. At the boot screen, I only have Antergos as an option for boot, not Windows. How can I restore the WIndows option?

    Thanks in advance

  • Anybody? … well, this is rather displeasing. 😞

  • First check that package os-prober is installed.

    Then check the file /etc/default/grub
    Important is a line with following content GRUB_DISABLE_OS_PROBER=. This should be false.

    If this isn’t the case, edit the file as root and change the line to true. After this you can run grub-mkconfig (as root too) to test your settings in /etc/default/grub. If they fit to your purposes you can run grub-mkconfig -o /boot/grub/grub.cfg

    For more informations concerning grub, visit the Arch Linux WIki

  • You can also install grub-customizer which will help you to setup the boot options in your computer.

  • Okay, I’m going to explain it more clearly now (since I’ve been trying to work on it and have sort of gotten somewhere).

    Before I installed Antergos I had KDE 5 and I was able to dual boot successfully as well as on other distros. I’m not sure if I made a misstep while installing Antergos, but whatever I did/didn’t do, that lead to Windows not being seen at all at boot (albeit I could mount the partition that Windows is installed on)… as if Antergos was the only OS on the hard drive.

    So, while looking for solutions I read about os-prober - which did not detect Windows. Updating grub did nothing as well. Then I saw about adding menu entries to a custom file that will direct grub to a bootmgfw.efi file which is supposed to be the Windows bootloader. So I did that and lo and behold a Windows option surface on the boot menu… but didn’t work.

    I saw an error about an invalid EFI file path and when I checked I did see bootmgfw.efi… but it was a file folder, not a file (why that is I don’t know!). In the folder it had a grubx64.efi file. So I didn’t know where to get the bootmgfw.efi file, but was reminded that the Windows partition should have the file in it’s own boot folder. So I copied and pasted the file into the /boot/efi/EFI/Microsoft/Boot/ directory and deleted the other folder.

    I should note in between doing that I installed rEFInd which I thought would detect Windows but that didn’t work either. So with the file in place, I rebooted and Windows shows up. I click it and a new error shows up this time but it’s from within the Windows boot manager, not grub that says:

    Windows Boot Manager  
    
    Windows failed to start. A recent hardware or software change might be the cause.  
    To fix the problem:
    
      1. Insert your Windows installation disc and restart your computer. 
      2. Choose your language settings, and then click "Next."
      3. Click "repair your computer." ...
    

    So this is where I am currently at. The menu entry I have is

    menuentry "Windows 10" {
        insmod part_gpt
        insmod chain
        set root='(hd0,gpt2)'
        chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    }
    

    Hopefully that makes some sense.

  • This post is deleted!
boot271 grub111 dual boot23 Posts 6Views 1968
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.