• Resolution problem after install


    Greetings. I am a new user to Arch and Antergos from a few days ago. I come from the world of dpkg, namely Debian, Ubuntu, Mint, etc. I got Antergos to install the first time using Cinnamon without a problem. Then 2 days later I began having repeated errors with messed of resolution so that I can’t see the desktop applets and menu bar at the top of the screen. Then soon the crashes came and Cinnamon began going into fallback mode. I checked a live install of Xubuntu and it had the same resolution problems so that you couldn’t “see” the menu bar or applets. Debian graphical install mode wouldn’t even work, also.

    I put in the USB and went into live mode of Antergos with Gnome 3. Perfect resolution there. But after reinstalling with Gnome 3 and now Cinnamon again, the resolution is wrong. I’ve checked my TV settings. It’s a 1920 x 1080p TV, no errors in settings. I’ve checked my Windows 7 on the other half of my SSD. Perfect resolution and no errors there. Checked my display settings…1920 x 1080 there. Checked ./config/monitors.xml and it shows 1920 x 1080.

    I’m using open source ati default driver mesa 10.? provided by the repos. I’m not sure if my gpu has something wrong with it. I don’t have a specific etc/X11/xorg.conf file. Please bear with me if I ask seemingly elementary questions, as Ubuntu typically handed things pre-installed on a silver platter after a new install.

    lspci | grep -i vga
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850]

    As least if I click “off screen” I can sort of see and get to the main menu bar options. I just hope it’s not my gpu going bad. This problem extends across multiple distros and it’s a problem I’ve never experienced before.

  • Greetings. I am a new user to Arch and Antergos from a few days ago. I come from the world of dpkg, namely Debian, Ubuntu, Mint, etc. I got Antergos to install the first time using Cinnamon without a problem. Then 2 days later I began having repeated errors with messed of resolution so that I can’t see the desktop applets and menu bar at the top of the screen. Then soon the crashes came and Cinnamon began going into fallback mode. I checked a live install of Xubuntu and it had the same resolution problems so that you couldn’t “see” the menu bar or applets. Debian graphical install mode wouldn’t even work, also.

    I put in the USB and went into live mode of Antergos with Gnome 3. Perfect resolution there. But after reinstalling with Gnome 3 and now Cinnamon again, the resolution is wrong. I’ve checked my TV settings. It’s a 1920 x 1080p TV, no errors in settings. I’ve checked my Windows 7 on the other half of my SSD. Perfect resolution and no errors there. Checked my display settings…1920 x 1080 there. Checked ./config/monitors.xml and it shows 1920 x 1080.

    I’m using open source ati default driver mesa 10.? provided by the repos. I’m not sure if my gpu has something wrong with it. I don’t have a specific etc/X11/xorg.conf file. Please bear with me if I ask seemingly elementary questions, as Ubuntu typically handed things pre-installed on a silver platter after a new install.

    lspci | grep -i vga
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850]

    As least if I click “off screen” I can sort of see and get to the main menu bar options. I just hope it’s not my gpu going bad. This problem extends across multiple distros and it’s a problem I’ve never experienced before.

  • Have I stumped everybody regarding my problem?

  • Hi,

    I’m terribly sorry but I have no experience with ATI/AMD cards. Normally the opensource driver works ok, though.

    If you’re experiencing this in different distros I think that you must rule out two things:

    • A driver update has been made (so it will affect all distros)
    • A faulty hardware

    Have you tried the closed driver?

    [url:iobbzg25]https://wiki.archlinux.org/index.php/AMD_Catalyst[/url:iobbzg25]

    You can also try to downgrade the opensource driver:

    [url:iobbzg25]https://wiki.archlinux.org/index.php/Downgrading_Packages[/url:iobbzg25]

    Not of much help, I know. If it’s not distro specific you should try google it, in case somebody has the same problem as yours.

    Cheers!

  • As an update, I installed the Catalyst driver 14.2 beta from AMD site. I tried using the Violo package but pacman wouldn’t connect to the repo.

    So, the resolution problem is fixed. Everything is where is should be. It’s just too bad the open source driver sudenly was the cause of this problem. I have to now accept decreased compatability for increased performance.

  • As a further update, I found out I had something called an overscan. My switch to Nvidia card has caused the same issue. I have never seen this problem before till now. I manually changed to a custom resolution in Nvidia control panel. I don’t feel like the screen looks as nice as before, but I am content with this result. Overall, I love this distro. In the repos I have all my emulators available, saving me tons of work with compiling!

Posts 6Views 990
Log in to reply