• How to remove gnome keyring completely?


    I removed gnome keyring using sudo pacman -Rs gnome-keyring but it still pops up occasionally asking me for a password. I don’t mind that but I’m having issues with Chromium and the last time I solved it was by removing this somehow. Every time I restart it and go to facebook I need to re-send the verification code to my phone. Same goes for Youtube.

    Chrome version: Version 53.0.2785.143 (64-bit)
    Gnome: v3.22.1

    Trying to remove libgnome-keyring gives this:

    [[email protected] milan]# pacman -Rs libgnome-keyring
    checking dependencies...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: apm: removing libgnome-keyring breaks dependency 'libgnome-keyring'
    :: libgnomeui: removing libgnome-keyring breaks dependency 'libgnome-keyring'
    :: telepathy-mission-control: removing libgnome-keyring breaks dependency 'libgnome-keyring'
    
  • If the real problem is Chromium asking for password every time the browser starts up, then it is usually workarounded by installing seahorse and entering a <void> login password, not by uninstalling gnome-keyring with its dependencies.

    I’m not a Facebook user, and used YouTube only twice in my life, so can’t help with these services.

  • @just The facebook and youtube problem is probably not with those services but with Chromium itself.

    Installed seahorse, opened ‘passwords and keys’ and created a new password keyring, named it void and gave it a password ‘<void>’. Is that it?

  • @TheKardinals said in How to remove gnome keyring completely?:

    …Is that it?

    No, it is not.

    1. Start seahorse (Password and Keys), right-click Login option in the left pane, select Change Password from popup menu:

      0_1477541375147_seahorse-01-start.png
      fig-01

    2. Enter you current password for login keyring:

      0_1477541416619_seahorse-02-loginpsw.png
      fig-02

    3. It is possible to enter a new password now:

      0_1477541475023_seahorse-03-emptypsw.png
      fig-03

      Leave it blank. Void. Empty. Do not type in anything. You’re about to create a <void> password. A dirty and risky workaround, but it eliminates Chromium’s password request forever.

    4. Finally, confirm that you want to store your <empty> password unencrypted:

      0_1477541569912_seahorse-04-confirm.png
      fig-04

    5. Done.

      On startup, Chromium will never ask for password anymore.

  • @just ok thanks. This should work then.

    EDIT: unfortunately this hasn’t worked for me. This did:

    1. Open your Home Folder(Places>>Home Folder )
    2. Press Ctrl+H to view hidden files.
    3. Open .gnome2 folder and then keyrings folder and delete login.keyring file. (i deleted the entire keyrings folder)
    4. Reboot the system.

    http://askubuntu.com/questions/17353/remove-keyring-popup-on-startup

  • have had the annoying keyring problem whenever Chrome started (running Gnome)
    this has worked for me so far, i.e. nothing appears to be broken yet:

    sudo mv /usr/bin/gnome-keyring-daemon /usr/bin/gnome-keyring-daemon-old
    sudo killall gnome-keyring-daemon

  • @egmus solved mine with the solution above. Thanks for adding the comment still. 🙂

gnome306 remove21 keyring6 completely4 Posts 7Views 4316
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.