• Latest updates broke my OS again...


    I am using the catalyst-test drivers, when I log in I just see a black background and my mouse with some white dots on the screen.
    Yesterday I installed a lot of packages, so I don’t know which package causes it. If anyone has an idea how to fix this, that would be great.

  • Well I managed to partially fix it by using https://wiki.archlinux.org/index.php/Arch_Linux_Archive
    and roll back to 2016/10/10

    using the command

    sudo pacman -Syyuu --force
    
  • Could it be that you were loading Gnome 3.22 using wayland instead of X?

  • @karasu I wasn’t using wayland.

  • @Irakli said

    I wasn’t using wayland

    Yes, but Wayland is now used by default by Gnome. I didn t quite Understood if you logged in as usually and THEN was presented with that frozen screen or you got it (the screen) directly. So, in the first case, you have to go to the login options of the login screen and change it from “GNOME” to “GNOME on Xorg”.
    At least, this is what I had to do since I was using Wayland since 3.18 and now I get just a gray screen with a frozen cusrsor.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Thanks I will try it out

  • @anarch I saw the option “Gnome on Xorg” I clicked that, but unfortunately still the same problem.

  • Well, few weeks later and I still can’t figure it out…

  • @Irakli said

    I installed a lot of packages, so I don’t know which package causes it

    Assuming it s not a gnome upgrade issue but some other update/upgrade, which kernel are you using? I thought of using the lts kernel in case you only got the current one…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch It’s a gnome upgrade issue

  • You mean you also tried the lts lernel and still failed? (though both kernels got upgraded recently). Have looked upsteam to see? Arch Forum maybe?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I am using KDE now and it works fine :)

  • @Irakli , cool:+1:
    Though, not really soved, will you please mark it as “SOLVED”, then?
    Thanks

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I’m still interested in how to solve it for gnome, maybe it will help others in the future.

  • The only think I could find on the web to fix this issue is to use the free catalyst drivers.
    https://forum.manjaro.org/t/solved-gnome-broken-with-black-screen-after-stable-update-2016-10-23-manjaro-16-10-final-release/11483/13

  • @Irakli I just tried it out and I can confirm that this fixed the issue

  • Isn’t catalyst dead with xorg 1.18 anyway?
    J.

  • @Jeannie____ Yep, that’s why I used xorg 1.16 for a long time

updates32 again2 broke12 Posts 18Views 1728
Log in to reply