• Input password doesn't works in login screen


    I have same problem that other, after update gnome and suspend it, when i try to login in my session the input password doesn’t works.

    So, i want ask you, when will be solved this problem with ligthdm?

    No, i won’t install GDM for solve this error because isn’t mine, GDM is very ugly, haven’t custom background wall papers.

    This issue has a solution now: https://forum.antergos.com/topic/5180/login-issue-with-lightdm-webkit-greeter-not-accepting-user-input
    – Michael Tunnell

  • I have the same issue after updating yesterday.

    EDIT: Workaround with GDM

    In Loginscreen (LightDM) press:

    STRG + ALT + F2
    

    login with your credetials

    this will install gdm

    sudo pacman -S gdm
    

    enter root password

    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    
    reboot
    

    But yeah this is NOT LightDM!

  • Or to pass on autologin, yet will not correct.

    Russian fan club of Antergos

  • Or you could change the greeter in lightdm

    https://wiki.archlinux.org/index.php/LightDM#Greeter

    I changed from webkit2 to the kde greeter, and I’ll change back as soon as the problem is fixed

    First press in the loginscreen

    STRG + ALT + F2
    

    then install the new greeter

    yaourt -S lightdm-kde-greeter 
    

    and active the greeter for lightdm

    sudo nano /etc/lightdm/lightdm.conf
    

    to do this - change following line

    greeter-session=lightdm-webkit2-greeter
    

    to

    greeter-session=lightdm-kde-greeter
    # greeter-session=lightdm-webkit2-greeter
    

    (I just put the old on as a comment, so it’s easier to go back
    Save and exit

    Now restart lightdm

    sudo systemctl restart lightdm.service
    

    🎉

  • @tuxnot said in Input password doesn't works in login screen:

    Or to pass on autologin, yet will not correct.

    What do you mean?

  • @alaguna Disable the password query, enable autologin in the system settings.

    Russian fan club of Antergos

  • The dirtiest of work around, no cli required:

    Drag the burger button (blue button, top right of your screen) in the password field.You will (magically?) gain focus and be able to type your password.

    I have to do it twice to make it work, my collegue only has to do it once.

gnome316 lightdm125 session21 Posts 8Views 2720
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.