• Login Issue


    This morning I performed a system upgrade, after which I ran into the following problem:

    When I rebooted my laptop, the password input box turned grey, and I could input nothing using my keyboard. I switched to tty to login my account and restored a previous snapshot.

    Any idea why this was happening? Your help is much appreciated.

    This issue has a solution now: https://forum.antergos.com/topic/5180/login-issue-with-lightdm-webkit-greeter-not-accepting-user-input
    – Michael Tunnell

  • I’ve got the same problem, after the latest updates.
    The Lightdm login screen doesn’t accept keyboard input (mouse works fine).

    Thought at first it was my wireless keyboard, so connected a PS/2 one, and that didn’t work either, but CTRL-ALT-F2 works to get to a terminal where I can log in. However “startx” just brings up errors, so I can’t get to the desktop.

    ETA: I see someone in the Newbie section seems to be having the same problem.

  • https://forum.antergos.com/topic/5164/keyboard-input-doesn-t-work-on-lightdm-after-gnome-3-22-update

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Same issue here. I had to manually configure autologin in lightdm. If you need to do the same, you can follow the instructions on the Arch Wiki. (FYI, the commands to add the autologin group and add the user to that group must be run as root.)

    I did this on two separate computers in the last 15 minutes.

  • @derklempner Is there any form to disable autoligin in case of Antergos Team solve this problem?

  • @Dingo1213 I have the same issue. I saw that another user found a miraculous workaround that I simplified (at least on my box).

    1. At the login screen, scroll to the right and select a wallpaper.
    2. Drag the wallpaper onto the password login entry
    3. Doubleclick the password (to highlight)
    4. Enter password
  • @alaguna Yes, you can simply undo the few changes to lightdm.conf and remove the autologin group as well (if you feel it’s necessary). If you read the ArchWiki you’ll see it’s literally changing five lines in lightdm.conf and then creating and adding yourself to a new user group. The last step is simply rebooting.

  • This is getting annoying, don’t the devs test it before they deploy it?
    Now I can’t use my antergos installation, I was able to login though by using the gtk greeter. But now, for some reason
    when I log in I see white dots and a black screen, I suppose it has to do with my GPU (catalyst-test).

  • I’m also getting this issue.

    I can get around it by switching to another virtual console, logging in there, stopping the lightdm service, and then running startxfce4, but it’s extremely annoying.

login77 Posts 10Views 1202
Log in to reply