• Like 0

    My system doesn't boot up


    I had to reinstall my system on my laptop Lenovo G510. The installation was successful. Suddenly, after the reboot and removed pendrive shows up “No bootable device - insert boot disk and press any key”. When I press any key, my computer restarts and shows up the same message. In BIOS I changed Boot Mode and Boot Priority on Legacy. What’s up??

    alt text

  • Like 0

    I think that moderators will help. I always establish in legacy mode and have made formatting a disk in msdos. If you established in Uefi mode include it once again and look that will be.

    Russian fan club of Antergos

  • Like 0

    When I set UEFI it starts Windows 8.1. I have a disk convert in GPT, because otherwise Windows didn’t want to install and also I use it.

  • Like 0

    @marcello947 said

    I had to reinstall my system on my laptop Lenovo G510.

    I can understand you re an inexperienced user. So, let s start with the simple things first because it could be a number of reasons.
    If it was working before it should also work now. So, did it work before? If YES, did you follow EXACTLY THE SAME STEPS to reinstall it?
    You mention Windows 8.1. Was your previous system dual booting? Could you boot in either OSs (Antergos/Windows)?

    after the reboot and removed pendrive shows up “No bootable device - insert boot disk and press any key”

    You mean you booted with the pendrive on and THEN you removed it? Maybe it booted from the pendrive and when you removed it it could not find it?
    Also, are you sure you did not install the GRUB in the pendrive? Did you check where the GRUB was installed?

    Take a look at all the above possibilities for now and let s hope for the best.

    You mean

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    If I switch in BIOS on UEFI, start only Windows. When I switch on Legacy, then shows this command “no bootable disk …” I made the same steps in the preparation of the pendrive (Rufus https://www.vanstechelman.eu/sites/default/files/node 287 rufus usage for uefi linux boot usb stick.png) and installation Antergos.

    During, the installation writes, that the bootloader is installed correctly. Previously, I created a partition /boot/efi. How do I find out where to install GRUB?

  • Like 0

    well, if you use the EFI methode (boot/efi) you also need to change the settings to UEFI.

    since it looks like you would like to let your system to dual boot, you could use something like rEFInd, which makes it easier to handle the whole EFI things, with nvram and stuff…
    https://wiki.archlinux.org/index.php/rEFInd

    otherwise you could change the boot priority, or press something like F12 for the boot device (in UEFI , the os will be listed there) - in case antergos is not listed there (but windows is …) you have to add antergos to the nvram of your system (but as I sad, rEFInd is a lot easier to handle those kinds of things)

  • Like 0

    If you want to work in UEFI mode (as you have Windows 10) why do you install Antergos in legacy mode?

    Does Antergos in UEFI mode not work for you?

  • Like 0

    @karasu My mistake, I have Windows 8.1. None GNU/linux doesn’t work under my UEFI, only Legacy. Anyway, always in tutorials from network people so they advised. I tried this advice https://apricityos.com/docs/entry/dual-booting-windows-and-apricity-os–uefi-gpt- but it didn’t work, because I wrote “not found root-image”. Maybe the contents of my grub file will help? http://pastebin.com/yjsKDX6H

  • Like 0

    None GNU/linux doesn’t work under my UEFI, only Legacy

    That’s odd. What do you see when you try to boot Antergos in an USB in UEFI mode?

    A menu should appear. Try all UEFI options (even the CD/DVD one). None of them work?

    Anyway, if you want to stay in Legacy mode, you’re right that Grub should work. If you manage to enter your Antergos installation in legacy mode (boot USB, chroot, …) then what do you get when you try to re-install grub? (grub-install /dev/sda) And if you run os-prober? Does it find your Windows installation?

  • Like 1

    @karasu said in My system doesn't boot up:

    Try all UEFI options (even the CD/DVD one). None of them work?

    I tried out various options in UEFI and I did it! System installed there. yuppi! I installed the driver wifi :) Only a lot of contriving is to switch the UEFI to turn on Windows. Do you to add a GRUB entry from Windows?

  • Like 0
    • Power on your computer and tap “F2” button to enter your PC BIOS interface.

    • Select “BIOS Setup Utility” option to choose “Advanced BIOS Features”.

    • Highlight “Hard Disk Boot Priority” and check or reset your bootable hard disk as the first in the boot device list.

    • Press “Esc” to get back and restart your computer to have a try.

    • Generally, your computer will set up and run well as you expect when this computer no boot device available error problem really happens due to setting wrong boot device.
      Check complete details at Lenovo G510 Laptop Manual.

system42 boot122 Posts 11Views 724
Log in to reply