• Help with Libpng12


    I have a program that I need to get working in Arch. However, it requires Libpng12 to function properly. The program developer warned me, and he was right, that the program would suffer from freezing or crashing without libpng12 installed. Jutoh (an ebook making program) does freeze when I open it, forcing me to kill the program.

    I cannot find libpng12 in the AUR and I cannot find it in pacman.

    Does anyone have a suggestion for installing libpng12?

    Thank you

  • $ yaourt libpng12
    1 community/libpng12 1.2.56-4
        A collection of routines used to create PNG format graphics files
    2 multilib/lib32-libpng12 1.2.56-4
        A collection of routines used to create PNG format graphics files
    ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
    ==> -------------------------------------------------------

    Install by entering 1 (or 2, or both) or with

    yaourt -S libpng12

    Or with

    sudo pacman -S libpng12
  • @just Sorry for the late reply. I was so frustrated by my failures that I went to Apricity OS to see if it was any better. My program works on Apricity, but it still periodically freezes. On Antergos, it freezes the moment I open the program.

    Im running both side-by-side now, in hopes of getting to the bottom of it. Im running a fresh install of Antergos. I followed your instructions above and I was able to install Libpng12. The program still freezes immediately upon opening. I did some research and learned that if there is a conflict between libpng12 and libpng16, it can cause freezing. I have seen references to libpng 1.2 and 1.6. So, I don’t even know if I am installing the right files.

    I believe libpng 1.2 or 12 (if that is the same) is what I need.
    I also wonder if something else is conflicting with libpng12.

    The program is called jutoh and I installed it from the AUR using yaourt -S jutoh.

    Thanks again for your help and patience. I appreciate it.


  • I didn’t suspect about jutoh existence before reading your post. So I know nothing about it.

    Yes, it is explicitely pointed out that the program depends on libpng12 - in AUR page and in the PKGBUILD .

    libpng16 is not mentioned, nowhere. It makes think that it is not required by jutoh.

    If it is not required by other programs, that might be installed on your side, I’d try to remove it, with

    yaourt -Rc libpng16

    Beware, the command might want to remove some packages that you’re using. Read carefully what it is about to remove.

    If it goes to remove the useful stuff, you may abbreviate the command down to

    yaourt -R libpng16

    It will remove the indicated package only, leaving others intact. And eventually orphaned.

    Repeat, I never used jutoh, so these are only hypotetical suggestions.

  • @just So I get Error: target not found: libpng16.

    I guess libpng16 is not installed.

    Should I look in pacman on Apricity and see what is installed on that OS that isn’t installed on Antergos? If so, do you have an idea what I should look for?

    To reiterate: Jutoh freezes immediately upon opening, and I forgot to mention, each time I open it Jutoh thinks it is the very first time and asks me to register it.

    On Apricity it just works.

    Thanks again for your help.

  • @just So, I noticed in pacman that the proper name for Libpng16 is actually just Libpng.

    When I tried yaourt -R libpng I get:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: cairo: removing libpng breaks dependency 'libpng'
    :: ffmpegthumbnailer: removing libpng breaks dependency 'libpng'
    :: freetype2: removing libpng breaks dependency 'libpng'
    :: gdk-pixbuf2: removing libpng breaks dependency 'libpng'
    :: ghostscript: removing libpng breaks dependency 'libpng'
    :: gstreamer0.10-good-plugins: removing libpng breaks dependency 'libpng'
    :: imlib2: removing libpng breaks dependency 'libpng'
    :: jbig2dec: removing libpng breaks dependency 'libpng'
    :: libcups: removing libpng breaks dependency 'libpng>=1.5.7'
    :: libwebp: removing libpng breaks dependency 'libpng'
    :: mjpegtools: removing libpng breaks dependency 'libpng'
    :: openjpeg2: removing libpng breaks dependency 'libpng'
    :: xorg-xcursorgen: removing libpng breaks dependency 'libpng'

    I then ran: yaourt -Rc libpng

    I got the following: 
    checking dependencies...
    :: alsa-plugins optionally requires ffmpeg: libavcodec resampling plugin, a52 plugin
    :: avahi optionally requires gtk3: avahi-discover-standalone, bshell, bssh, bvnc
    :: avahi optionally requires gtk2: gtk2 bindings
    :: farstream optionally requires gst-plugins-good
    :: farstream optionally requires gst-plugins-bad
    :: gegl optionally requires ffmpeg: ffmpeg plugin
    :: gegl optionally requires librsvg: svg plugin
    :: git optionally requires gnome-keyring: GNOME keyring credential helper
    :: grub optionally requires freetype2: For grub-mkfont usage
    :: gssdp optionally requires gtk3: gssdp-device-sniffer
    :: libgnome-keyring optionally requires gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
    :: libproxy optionally requires webkitgtk: PAC proxy support - Webkit based pacrunner
    :: libsecret optionally requires gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
    :: libxcursor optionally requires gnome-themes-standard: fallback icon theme
    :: openjpeg optionally requires libpng: j2k_to_image and image_to_j2k programs
    :: pinentry optionally requires gtk2: gtk2 backend
    :: pinentry optionally requires gcr: gnome3 backend
    :: python-gobject optionally requires cairo: Cairo bindings
    :: python2-gobject optionally requires cairo: Cairo bindings
    :: xdg-utils optionally requires libgnome: for GNOME support in xdg-open
    warning: dependency cycle detected:
    warning: harfbuzz will be removed after its freetype2 dependency
    Packages (178) adwaita-icon-theme-3.22.0-1  antergos-mirrorlist-20160821-1
                   antergos-repo-priority-1.0.4-2  antergos-welcome-0.0.2-2
                   baobab-3.22.0+3+g423a1a1-1  brasero-3.12.1-2  cairo-1.14.6-2
                   cairomm-1.12.0-2  cantarell-fonts-1:0.0.25-2
                   caribou-0.4.21+0+g36e3d0f-1  cheese-3.22.1-1
                   chromaprint-1.3.2-1  chromium-53.0.2785.143-1
                   clutter-1.26.0+24+g79da526-1  clutter-gst-3.0.20-1
                   clutter-gtk-1.8.2-1  cogl-1.22.2-1  colord-gtk-0.1.26-2
                   cups-2.2.1-1  cups-filters-1.11.4-1  cups-pk-helper-0.2.6-1
                   eog-3.20.5-1  evince-3.22.1-1
                   evolution-data-server-3.22.1+5+g45951fc-1  ffmpeg-1:3.1.4-2
                   ffmpegthumbnailer-2.1.1-1  file-roller-3.22.1-1
                   firefox-49.0.1-1  flashplugin-  folks-0.11.3-2
                   fontconfig-2.12.1-3  foomatic-db-engine-4:4.0.12-2
                   freetype2-2.7-2  gcr-3.20.0-2  gdk-pixbuf2-2.36.0+2+ga7c869a-1
                   gedit-3.22.0+4+g2c70ccb-1  gfbgraph-0.2.3-1  ghostscript-9.20-2
                   gjs-1.46.0-1  gnome-autoar-0.1.1+1+g8d75c44-1
                   gnome-bluetooth-3.20.0+6+g3bac4f9-1  gnome-calculator-3.22.1-1
                   gnome-calendar-3.22.1-1  gnome-color-manager-3.22.1-1
                   gnome-control-center-3.22.1-1  gnome-desktop-1:3.22.1-1
                   gnome-logs-3.22.0+1+g9479eb0-1  gnome-maps-3.22.1-1
                   gnome-music-3.22.1-1  gnome-online-accounts-3.22.1-1
                   gnome-online-miners-3.22.0-1  gnome-photos-3.22.1-1
                   gnome-screenshot-3.22.0+1+g7568f0e-1  gnome-session-3.22.1-1
                   gnome-settings-daemon-3.22.1-1  gnome-shell-3.22.1+2+g5a08886-1
                   gnome-shell-extensions-3.22.1-1  gnome-sound-recorder-3.20.2-1
                   gnome-tweak-tool-3.22.0+3+g2f9d966-1  gnome-vfs-2.24.4-10
                   gnome-weather-3.20.2-1  grilo-0.3.2+8+g6ffe445-1
                   grilo-plugins-0.3.3+7+gab5596b-1  gsfonts-20160531-3
                   gspell-1.2.0+2+g124a69f-1  gst-libav-1.9.90+2+g108b08c-1
                   gtk-update-icon-cache-3.22.1+8+ge11df6c-2  gtk2-2.24.31-1
                   gtk3-print-backends-3.22.1+8+ge11df6c-2  gtkmm3-3.22.0-1
                   gtksourceview3-3.22.0+4+g87c38b3-1  gtkspell-2.0.16-3
                   gvfs-1.30.1-2  gvfs-mtp-1.30.1-2  harfbuzz-1.3.2-1
                   harfbuzz-icu-1.3.2-1  hplip-3.16.9-1  imagemagick-
                   imlib2-1.4.9-1  jbig2dec-0.13-1  jutoh-2.48-1  libass-0.13.4-1
                   libbluray-0.9.2-2  libbonoboui-2.24.5-3  libcaca-0.99.beta19-1
                   libchamplain-0.12.14+2+ge1f6e59-1  libcups-2.2.1-1
                   libdmapsharing-2.9.36+1+g6b3d20e-1  libgdata-0.17.6-1
                   libgepub-0.4+1+gba0bde3-1  libglade-2.6.4-5  libgnome-2.32.1-6
                   libgnomecanvas-2.30.3-3  libgnomekbd-
                   libgnomeui-2.24.5-2  libgsf-1.14.40-1
                   libgweather-3.20.3+20+gb9a6ef3-1  libgxps-0.2.4+12+g4709da9-1
                   libmediaart-1.9.0+8+g52eb649-1  libnautilus-extension-3.22.1-1
                   libnotify-0.7.7-1  libpeas-1.20.0-1  libreoffice-fresh-5.2.2-2
                   librsvg-2:2.40.16-1  libspectre-0.2.8-1  libwebp-0.5.1-1
                   libwnck3-3.20.1-1  libxfont-1.5.2-1  libxft-2.3.2-1
                   libzapojit-0.0.3+11+g840627d-1  light-locker-1.6.0-3
                   light-locker-settings-1.5.2-3  lightdm-webkit2-greeter-2.1.5-1
                   mjpegtools-2.1.0-3  mutter-3.22.1-1  nautilus-3.22.1-1
                   network-manager-applet-1.4.2-1  nm-connection-editor-1.4.2-1
                   numix-frost-themes-3.6.4-1  numix-icon-theme-0.1887-1
                   numix-icon-theme-square-1:0.r82.bb9313e-2  openjpeg2-2.1.2-1
                   orca-3.22.1-1  pamac-4.1.5-1.1  pango-1.40.3-1  pangomm-2.40.1-1
                   pavucontrol-3.0-4  pidgin-2.11.0-1  poppler-0.47.0-1
                   poppler-glib-0.47.0-1  python-cairo-1.10.0-6
                   python-pycups-1.9.73-2  seahorse-3.20.0+44+ga1474bb-1
                   smbclient-4.5.0-2  splix-2.0.0-13  system-config-printer-1.5.7-2
                   totem-3.22.0+5+ge0bf46e-1  tracker-1.10.1-1
                   transmission-gtk-2.92-5  ttf-bitstream-vera-1.10-10
                   ttf-dejavu-2.35-1  ttf-freefont-20120503-4
                   ttf-google-fonts-20160408.r423-1  ttf-liberation-2.00.1-6
                   vte3-0.46.0+5+g398a3f8-1  webkit2gtk-2.14.1-1
                   webkitgtk-2.4.11-1  xdg-user-dirs-gtk-0.10-2
                   xorg-bdftopcf-1.0.5-1  xorg-font-utils-7.6-4
                   xorg-fonts-misc-1.0.3-4  xorg-mkfontdir-1.0.7-2
                   xorg-mkfontscale-1.1.2-1  xorg-server-1.18.4-1
                   xorg-server-common-1.18.4-1  xorg-x11perf-1.6.0-1
                   xorg-xcursorgen-1.0.6-1  xscreensaver-5.36-1
                   zenity-3.22.0+1+gcd1647c-1  libpng-1.6.25-1

    I did not follow through with this command because it looked like way too much stuff was going to be removed. I’m not going to check Apricity and see what it shows with regard to Libpng.

  • @just

    WOOT! I think I solved it! I sooooo appreciate your help. I can’t believe I didn’t try this sooner. But I would not have thought to do this without your help.

    Here’s what I did:
    Jutoh worked on Apricity, and I knew the problem had something to do with Libpng, so I looked in Apricity’s pacman and recorded all the installed packages relating to libpng. I compared that against what Antergos had installed.





    On Antergos, I removed Lib32-libpng12 and added Lib32-libpng so that Antergos matched Apricity.

    Then I started Jutoh, followed the initial setup, and it opened without freezing!! I closed it and opened it a few times and it opened and closed as it should, remembering changes too.

    I hope that this procedure will help someone else.

  • Uhg. The program worked flawlessly for several days. Just moments ago, it froze when I used it to open a saved file. I had to force-quit. I rebooted and tried again. Now it freezes immediately upon opening the program, and I have to force-quit every time.

    I cannot understand what’s happening here. Addressing Libpng in Antergos to match Apricity instantly fixed the freezing…unless it was a bizarre coincidence.

    If anyone has an idea of a command I can run to figure out what’s going on, I would appreciate it. Thankfully, I still have Apricity running on another partition and I can pick up where I left off while figuring out Antergos. There has to be a reason why it works on Apricity…

  • This may be a stupid question, but you have checked to make sure Lib32-libpng12 hasn’t been re-installed with an update?

  • What puzzles me is what could be different between Antergos & Apricity. They re supposed to point to the same Arch official and unofficial repos, aren t they?.
    Since both distros come with pamac, maybe it is more convenient to see their differences in necessary and optional dependencies from there?

  • @GrayW Not a stupid question. I often forget the simple things. In this case, it has not changed.

  • @anarch Yes, good thought. Is there a command or something i can run to help compare?

  • @tfbielawski said

    Is there a command or something i can run to help compare?

    Well, fire up pamac (software manager) in either distro, type in the name of the programm in the search field & double click on the name (this will open up more info about it. Among other options, you ll find a “dependencies” one.
    But I really can t figure out what could be differsnt in a repo which both distros “look”.

    • Gould it be different kernel versions (eg Apricity using LTS while Antergos the current one?
libpng121 Posts 13Views 2064
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.