• Input Devices are Unstable

    Hey guys,

    I have a Lenovo IdeaPad Y700-15ISK with an ElanTech touchpad.
    It sometimes work and sometimes not. When it does work, it can go unstable after a few minutes or remain stable for a while (unrelated to idle time). When it does work xinput shows ETPS/2 Elantech Touchpad and when it doesn’t, the touchpad is detected as anything from PS/2 Generic Mouse to PS/2 Logitech Wheel Mouse or even PS/2 Elantech Touchpad (read: not ETPS/2).
    Also, when that happens, the text cursor tends to jump on many key presses and the computer becomes more or less unusable.

    I experienced the same behavior with other Linux distros (e…g, Ubuntu, etc…) and already tried:

    Nothing worked so far.
    I’d really appreciate your help!

    Thank you,

    Log Files

  • Ok, seems like I found a solution to this problem:
    I had to downgrade the linux-firmware package to version 1.149 (downloaded from here and installed manually).
    After rebooting, everything became stable again :)

touchpad55 input15 unstable3 devices3 Posts 2Views 628
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.