• Blinking Cursor on fresh install


    I’ve just installed Antergos on my Dell Laptop, when I tried to boot for the first time I got a black screen with a blinking cursor. I tried booting on my windows partition and downgrade my NVIDIA drivers and it didn’t work, when I try to nomodeset, it gave me something about psmouse serio1: elantech: synaptics_send_cmd query 0x01 failed. How can I fix this?

    Thanks for helping.

  • Please, run the command

    lspci -vnn | grep '\''[030[02]]'
    

    and post back here the command itself, as it was entered in terminal, and its output.

  • The command you give me doesn’t seems to work, I am getting syntax errors and I’m pretty sure I’ve double checked the command.

  • It works. Example:

    $ lspci -vnn | grep '\''[030[02]]'
    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
    01:00.0 3D controller [0302]: NVIDIA Corporation GK107M [GeForce GT 750M] [10de:0fe4] (rev a1)
    $
    

    Yes, it’s difficult to type it in by hand - if possible, use copy-paste to enter it.

  • The command should be used on terminal right? It seems you’re using in grub>

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto I’d use a terminal… If I can boot. Ever since I installed Antergos, I’ve never been able to be in the OS. Always at the blinking cursor at the boot. The only thing I can do is boot options and grub that’s all.

  • @Drakota Terminal is available in different ways. For example:

    • boot the installed Antergos without GUI, without DE, into pure bash shell. Do this by adding systemd.unit=multi-user.target to the boot line. Once in bash, run the command.

    • boot into the “blinking cursor” session. Hit Ctrl+Alt+F1…7 to switch to another VT. You’re in terminal, in bash session. Run the command.

    • boot into any other existing Linux, if any. The command is identical and returns the same result(s) in any Linux you may have.

    • boot into live session from any LiveUSB/DVD. Again, it may be any Linux, not Antergos only. Open the terminal, run the command.

    And yes, @fernandomaroto is right. On the photo you’re in grub shell session, not in bash shell. Grub has its own commands set and doesn’t recognize any bash command.

  • @just Thanks, It worked !
    0_1476203865341_14647387_10210543911577889_1306101918_o.jpg

  • @Drakota O-oh, finally :) . Very well.

    Now to the main question.

    How did you install Antergos? Were Propietary Graphic Drivers enabled or disabled during installation?

  • @just I enabled Proprietary Graphic Drivers

  • @Drakota said in Blinking Cursor on fresh install:

    @just I enabled Proprietary Graphic Drivers

    That was terribly wrong. It’s not your fault. It’s a feature yet missing in Cnchi.

    I suspected it from the start, but wanted to be sure about the graphical card you have.

    Proprietary Graphic Drivers must be disabled during Antergos installation on Nvidia Optimus computers. They are installed correctly on non-Optimus NVIDIA computers only.

    Read more about it in Antergos Wiki here. Though the site is not reachable right now. The article is called “Bumblebee for NVIDIA Optimus”.

    The best solution is - reinstall.

    Good luck

  • Yup, reinstall with no proprietary drivers and It worked fine, thanks @just :)

  • @Drakota said in Blinking Cursor on fresh install:

    Yup, reinstall with no proprietary drivers and It worked fine…

    Very well. Glad you’ve did it.

    When Antergos Wiki will become reachable again, read the suggested article. It explains how to install proprietary drivers for NVIDIA Optimus.

    Thanks for marking the topic as [Solved].

cursor11 fresh21 blinking5 Posts 14Views 1375
Log in to reply