• Grub very laggy and buggy on a fresh install

    Hi Guys,

    I just installed Antergos on a new machine and I’m having this really stange issue with grub that I’ve never seen before. If I don’t touch anything and let it load the default option (antergos), everything boots just fine. As soon as I start using my keyboard, thing get really stange. First 5 strokes are ok, next few start to lag a couple of seconds, the next will lag entire minutes or the grub loader will outright crash. The os prober Windows entry works only half the time.

    Everything else on that drive works perfectly: the antergos install and both Windows, so it’s not a failing drive issue.

    I re-installed grub and used grub-mkconfig to regen grub.cfg. Same deal.
    I tried uninstall Antergos grub theme, no luck.

    My hooks in mkinitcpio.conf:
    HOOKS=“base udev autodetect modconf block keyboard keymap encrypt filesystems fsck” <- keyboard hook is there

    Modules: MODULES=“dm_mod dm_crypt ext4 aes_x86_64 sha256 sha512”

    I tried swapping out keyboards, issue persists.

    I tried changing the resolution from 1080p to 680x480 but the problem still persists.

    The grub on the live cd works without a hitch.
    The SSD is mbr and the filesystems on it are:

    Primaries: ntfs (1 system, 2 windows partitions: 10/7)
    /boot (ext4)
    / (luks / ext4)
    2 ntfs for storage

    Machine is an Asus Gene VIII z170m motherboard with a i7 6700k, 32GB RAM. I’m running it with just the intel gpu for now. I had made fresh installs of both Windows 7 and Windows 10 on the SSD before installing Antegos.

    What do you guys think I should try next?

  • @Fadi-R
    I had a problem with the swap some days ago, installing more than one distro. Formating the swap change the swap’s UUID and the first installed distro stands 1:30 minutes trying to boot… I’m not sure if is the same problem but i simply edited the fstab with the right (new) swap’s UUID.
    good luck

  • Thanks for the suggestion Fernando. If I just let grub autoboot, the boot take less than 15 seconds, so I don’t think we have the same problem. My prob is within grub itself and I also didn’t put a swap on this system seeing how I had 32GB of RAM.

    This bug is really strange, I’ve been seeing reports of it going back to 2010. I could probably do a full reinstall of antergos but I can’t be bothered. I’ll just get around the problem by reinstalling the Windows loader and using EasyBCD to chainload into grub and straight into Antergos.

  • This post is deleted!
  • Ok, so this is how I worked around this bug, this bane of my existance for the last few days. Maybe if someone has the same issue in the future, the work around might help them.

    Although I am very satisfied with my situation, this workaround is not a solution to the bug but a way of avoiding it. I urge the moderator not to mark this issue as solved until the bug is actually resolved.

    The work around:

    Grub is running instensly buggy but autoboot works flawelessly. The only thing stopping me from having grub load antergos immediately was that it had supplanted the Windows loader during installation and I needed it to get into windows (which incedentally it was doing horribly, it was only getting me into one of my windows and only half the time).

    I got around this by booting with a windows 10 usb in UEFI mode and installing a UEFI loader for windows. I left grub on the Bios (my mobo can load either for each drive). I set the mobo to boot my ssd in UEFI mode (aka Winloader UEFI) at first with the Bios mode (aka Grub bios) being next in the boot order. This has the effect of booting my UEFI windows loader first and if I press escape when I’m at the loader, the mobo interprets that as me wanting to go to my next entry in the boot order (which would be grub in bios mode). Since I only need grub for antergos, I changed my grub timeout to 0 so that I don’t have to deal with it’s existencial crisis.

    The esc trick is probably a feature of my mobo, if you don’t have this, you can always set your favorite loader as default and hit F8 during post to bring up the Bios’s boot selection to chose the other loader.

    Stay awesome, Peeps!

boot320 grub127 boot loader8 laggy4 Posts 5Views 1327
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.