• \[SOLVED\]Radeon HD3200 HDMI audio and Dual monitor setup


    Hello! 4 days ago I became Antergos user
    This is firs time for me tu using Arch
    Installation went without any problems, to mention that I chose Gnome 3 desktop environment.
    I am still learning Arch because its first time for me to use it.
    I set-up almost everything without any problems except HDMI audio on my Radeon HD3200 graphic card that is integrated on my MB and I have problem with my dual monitor set-up,

    1. HDMI audio on Radeon HD3200
      HDMI audio is detected on sound devices in settings but when I chose HDMI audio there is no sound.
      In Ubuntu 13.10 for HDMI audio to work I have to enable HDMI audio in /etc/default/grub ading "radeon.audio=1 " , sudo update-grub and add ppa with daily opensorce radeon driver.

    I folowed instructions on Arch wiki how to eneble HDMI audio and is same procedure like in Ubuntu. I added “radeon.audio=1” in /etc/default/grub and saved, sudo update-grub command dont work in Arch however I restarted my PC and HDMI audio still don’t work it is detected in sound devices but still no sound same as before editing /etc/default/grub.

    Here is my /etc/default/grub:

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Arch"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=“radeon.audio=1”

    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo’
    GRUB_GFXMODE=auto

    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep

    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true

    # Uncomment and set to the desired menu colors. Used by normal and wallpaper
    # modes only. Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    #GRUB_THEME="/path/to/gfxtheme"

    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE=“480 440 1”

    #GRUB_SAVEDEFAULT=“true”

    1. My second problem is dual monitor set up.
      Like I sad I have Radeon HD3200 integreted in my MB and I use D-SUB for 22" Samsung monitor and HDMI for 42 "LG 3D HD TV.
      When HDMI and D-sub is connected picture is fine on login screen ( normal size, without artefact etc.) but when I log in picture is some kind magnified, Gnome Top bar is huge, windows and fonts are huge.
      I checked resolution settings and it says it is correct resolution but everything is so big on bot screens, top bar windows, fonts etc.
      When I disconnect HDMI and restart PC picture on Samsung monitor is normal, normal size top bar, fonts and windows and if I plugin HDMI while PC still works picture extends on LG TV and picture on both monitors are normal until reboot then picture is huge on TV and Monitor. I don’t know if this is driver bug or Gnome bug?

    If someone know solution for this two problems I be grateful

  • Hello! 4 days ago I became Antergos user
    This is firs time for me tu using Arch
    Installation went without any problems, to mention that I chose Gnome 3 desktop environment.
    I am still learning Arch because its first time for me to use it.
    I set-up almost everything without any problems except HDMI audio on my Radeon HD3200 graphic card that is integrated on my MB and I have problem with my dual monitor set-up,

    1. HDMI audio on Radeon HD3200
      HDMI audio is detected on sound devices in settings but when I chose HDMI audio there is no sound.
      In Ubuntu 13.10 for HDMI audio to work I have to enable HDMI audio in /etc/default/grub ading "radeon.audio=1 " , sudo update-grub and add ppa with daily opensorce radeon driver.

    I folowed instructions on Arch wiki how to eneble HDMI audio and is same procedure like in Ubuntu. I added “radeon.audio=1” in /etc/default/grub and saved, sudo update-grub command dont work in Arch however I restarted my PC and HDMI audio still don’t work it is detected in sound devices but still no sound same as before editing /etc/default/grub.

    Here is my /etc/default/grub:

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Arch"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=“radeon.audio=1”

    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo’
    GRUB_GFXMODE=auto

    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep

    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true

    # Uncomment and set to the desired menu colors. Used by normal and wallpaper
    # modes only. Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    #GRUB_THEME="/path/to/gfxtheme"

    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE=“480 440 1”

    #GRUB_SAVEDEFAULT=“true”

    1. My second problem is dual monitor set up.
      Like I sad I have Radeon HD3200 integreted in my MB and I use D-SUB for 22" Samsung monitor and HDMI for 42 "LG 3D HD TV.
      When HDMI and D-sub is connected picture is fine on login screen ( normal size, without artefact etc.) but when I log in picture is some kind magnified, Gnome Top bar is huge, windows and fonts are huge.
      I checked resolution settings and it says it is correct resolution but everything is so big on bot screens, top bar windows, fonts etc.
      When I disconnect HDMI and restart PC picture on Samsung monitor is normal, normal size top bar, fonts and windows and if I plugin HDMI while PC still works picture extends on LG TV and picture on both monitors are normal until reboot then picture is huge on TV and Monitor. I don’t know if this is driver bug or Gnome bug?

    If someone know solution for this two problems I be grateful

  • Hi. Welcome to Antergos!

    @“rale_ts”:2vvootcf said:

    sudo update-grub command dont work in Arch[/quote:2vvootcf]You’ll need to run this instead:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    @“rale_ts”:2vvootcf said:

    1. My second problem is dual monitor set up.[/quote:2vvootcf]Try this from the Arch Wiki:>Gnome 3.10 UI elements scale incorrectly

    With 3.10 Gnome introduced HDPI support. If your displays EDID info does not contain the correct screen size, but the resolution is right, this can lead to incorrectly scaled UI elements. As a workaround you can open dconf-editor and find the key scaling-factor in org.gnome.desktop.interface. Set it to 1 to get the standard scale.

    Cheers!

  • Thanks
    Now everything work as it should
    Cheers!

  • Glad you got everything working!

    Cheers!

Posts 5Views 1715
Log in to reply