• Antergos asking for sudo password before install


    Hello,

    I am trying to get Antergos working on either an old windows 7 PC, or on a virtual machine on my current windows 7 laptop. In both cases, I get the same issues.

    First when trying to booth from a bootable USB containing the Antergos ISO:

    • I entered boot order menu and selected boot from USB
    • Antergos bootup menu comes up and the useful options are “Start Antergos Live” and “Non-graphical boot”.
    • I selected “Start Antergos Live”

    The OS boots up, and I see the home screen, I can launch the terminal and do things. However, as soon as I click Cnichi or Install Antergos, I’m asked for a root password, and I don’t know what to enter here because I haven’t even set anything up yet. I have tried blank as well as the host machine’s Windows password. I have also tried re-creating the bootable USB by running the tool as administrator. Neither has helped. When the OS is booting up, not each task is shown as [OK]. There are a couple of tasks that show [FAILED], but I do still get to a functional screen, albeit with some issues, like the shutdown/sleep menu missing from top right corner, in addition to being asked for root password.

    Next, I tried the same as a virtual machine on my current working windows 7 laptop, using virtual box, and i get the exact same error prompt.

    Has anyone faced this issue before? Any tips would be appreciated. I really want to try Antergos out.

  • Run the installer as administrator: sudo -E /usr/share/cnchi/bin/cnchi -dv

    Russian fan club of Antergos

  • @tuxnot

    Thank you! This fixed it, and I was able to proceed with installing Antergos. I will mark this as SOLVED, but if you don’t mind, I would still like to understand why I faced this issue. I have asked a few others who have installed Antergos on their machines and have not encountered this problem. What factors would force the “Try It” mode to ask for sudo permissions?

password20 sudo11 asking3 Posts 3Views 1245
Log in to reply