• Lenovo E460 -- Touchpad suddenly not working


    Hey all,
    Okay so as the title states my touchpad has suddenly just stopped working. Updated a few packages (Can’t remember exactly which one - is there a way to check?) and it was all working fine. Rebooted and the touchpad and the red-pointer (in between G and H) won’t respond. Left, Middle and Right click don’t either. I’ve tried rebooting a few times and still won’t work. I’m running GNOME as my Desktop Environment and Synaptics as my touchpad driver.
    Here are the results of xinput list:

    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ Logitech USB Optical Mouse              	id=9	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
        ↳ Integrated Camera                       	id=10	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
        ↳ ThinkPad Extra Buttons                  	id=12	[slave  keyboard (3)]
    

    Output for lspci:

    00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
    00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Device 9d12 (rev f1)
    00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
    00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-V (rev 21)
    01:00.0 Network controller: Intel Corporation Intel Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)
    02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
    

    Unsure if the lsusb output is helpful too:

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 5986:0708 Acer, Inc 
    Bus 001 Device 003: ID 8087:0a2a Intel Corp. 
    Bus 001 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    Unfortunately for me the M105 Optical Mouse is an external mouse and not the touchpad :(

    Contents of /var/log/Xorg.0.log:

    [   501.654] (--) Log file renamed from "/var/log/Xorg.pid-4377.log" to "/var/log/Xorg.0.log"
    [   501.656] 
    X.Org X Server 1.18.4
    Release Date: 2016-07-19
    [   501.656] X Protocol Version 11, Revision 0
    [   501.656] Build Operating System: Linux 4.5.4-1-ARCH x86_64 
    [   501.656] Current Operating System: Linux Crucial 4.7.1-1-ARCH #1 SMP PREEMPT Wed Aug 17 08:13:35 CEST 2016 x86_64
    [   501.656] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=a8db176a-e9f8-4a10-ae0d-239b71e2e0db rw cryptdevice=/dev/disk/by-uuid/c127a9ca-865d-4191-9cd6-0e5e90d5247e:cryptAntergos quiet resume=UUID=da90300c-0e8f-472f-a64a-6c8aa4b9be76
    [   501.656] Build Date: 19 July 2016  05:54:24PM
    [   501.656]  
    [   501.656] Current version of pixman: 0.34.0
    [   501.657] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [   501.657] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   501.657] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 20 20:39:44 2016
    [   501.657] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [   501.657] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   501.658] (==) No Layout section.  Using the first Screen section.
    [   501.658] (==) No screen section available. Using defaults.
    [   501.658] (**) |-->Screen "Default Screen Section" (0)
    [   501.658] (**) |   |-->Monitor "<default monitor>"
    [   501.659] (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    [   501.659] (**) Option "DontZap" "false"
    [   501.659] (==) Automatically adding devices
    [   501.659] (==) Automatically enabling devices
    [   501.659] (==) Automatically adding GPU devices
    [   501.659] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [   501.659] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [   501.659] 	Entry deleted from font path.
    [   501.659] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
    [   501.659] 	Entry deleted from font path.
    [   501.659] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
    [   501.659] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
    [   501.659] 	Entry deleted from font path.
    [   501.659] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
    [   501.659] (==) FontPath set to:
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/,
    	/usr/share/fonts/OTF/
    [   501.659] (==) ModulePath set to "/usr/lib/xorg/modules"
    [   501.659] (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    [   501.659] (II) Loader magic: 0x821d40
    [   501.659] (II) Module ABI versions:
    [   501.659] 	X.Org ANSI C Emulation: 0.4
    [   501.659] 	X.Org Video Driver: 20.0
    [   501.659] 	X.Org XInput driver : 22.1
    [   501.659] 	X.Org Server Extension : 9.0
    [   501.660] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.NoServer (Failed to connect to socket /run/dbus/system_bus_socket: Connection refused)
    [   501.660] (++) using VT number 1
    
    [   501.660] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [   501.661] (II) xfree86: Adding drm device (/dev/dri/card0)
    [   501.665] (--) PCI:*(0:0:2:0) 8086:1916:17aa:5048 rev 7, Mem @ 0xf0000000/16777216, 0xe0000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
    [   501.665] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [   501.665] (II) LoadModule: "glx"
    [   501.666] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   501.671] (II) Module glx: vendor="X.Org Foundation"
    [   501.671] 	compiled for 1.18.4, module version = 1.0.0
    [   501.671] 	ABI class: X.Org Server Extension, version 9.0
    [   501.671] (==) AIGLX enabled
    [   501.671] (==) Matched intel as autoconfigured driver 0
    [   501.671] (==) Matched intel as autoconfigured driver 1
    [   501.671] (==) Matched modesetting as autoconfigured driver 2
    [   501.671] (==) Matched fbdev as autoconfigured driver 3
    [   501.671] (==) Matched vesa as autoconfigured driver 4
    [   501.672] (==) Assigned the driver to the xf86ConfigLayout
    [   501.672] (II) LoadModule: "intel"
    [   501.672] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [   501.673] (II) Module intel: vendor="X.Org Foundation"
    [   501.673] 	compiled for 1.18.4, module version = 2.99.917
    [   501.673] 	Module class: X.Org Video Driver
    [   501.673] 	ABI class: X.Org Video Driver, version 20.0
    [   501.673] (II) LoadModule: "modesetting"
    [   501.673] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [   501.674] (II) Module modesetting: vendor="X.Org Foundation"
    [   501.674] 	compiled for 1.18.4, module version = 1.18.4
    [   501.674] 	Module class: X.Org Video Driver
    [   501.674] 	ABI class: X.Org Video Driver, version 20.0
    [   501.674] (II) LoadModule: "fbdev"
    [   501.674] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [   501.674] (II) Module fbdev: vendor="X.Org Foundation"
    [   501.674] 	compiled for 1.18.0, module version = 0.4.4
    [   501.674] 	Module class: X.Org Video Driver
    [   501.674] 	ABI class: X.Org Video Driver, version 20.0
    [   501.674] (II) LoadModule: "vesa"
    [   501.674] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [   501.674] (II) Module vesa: vendor="X.Org Foundation"
    [   501.674] 	compiled for 1.18.0, module version = 2.3.4
    [   501.675] 	Module class: X.Org Video Driver
    [   501.675] 	ABI class: X.Org Video Driver, version 20.0
    [   501.675] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
    [   501.675] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
    [   501.675] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
    [   501.675] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
    [   501.675] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [   501.675] (II) FBDEV: driver for framebuffer: fbdev
    [   501.675] (II) VESA: driver for VESA chipsets: vesa
    [   501.676] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160425
    [   501.676] (II) intel(0): SNA compiled from 2.99.917-691-ga77397a
    [   501.676] (WW) Falling back to old probe method for modesetting
    [   501.677] (WW) Falling back to old probe method for fbdev
    [   501.677] (II) Loading sub module "fbdevhw"
    [   501.677] (II) LoadModule: "fbdevhw"
    [   501.677] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [   501.677] (II) Module fbdevhw: vendor="X.Org Foundation"
    [   501.677] 	compiled for 1.18.4, module version = 0.0.2
    [   501.677] 	ABI class: X.Org Video Driver, version 20.0
    [   501.677] (WW) Falling back to old probe method for vesa
    [   501.678] (--) intel(0): gen9 engineering sample
    [   501.678] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
    [   501.678] (II) intel(0): Creating default Display subsection in Screen section
    	"Default Screen Section" for depth/fbbpp 24/32
    [   501.678] (==) intel(0): Depth 24, (--) framebuffer bpp 32
    [   501.678] (==) intel(0): RGB weight 888
    [   501.678] (==) intel(0): Default visual is TrueColor
    [   501.679] (II) intel(0): Output eDP1 has no monitor section
    [   501.696] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
    [   501.696] (II) intel(0): Enabled output eDP1
    [   501.696] (II) intel(0): Output DP1 has no monitor section
    [   501.697] (II) intel(0): Enabled output DP1
    [   501.697] (II) intel(0): Output HDMI1 has no monitor section
    [   501.697] (II) intel(0): Enabled output HDMI1
    [   501.697] (II) intel(0): Output DP2 has no monitor section
    [   501.697] (II) intel(0): Enabled output DP2
    [   501.697] (II) intel(0): Output HDMI2 has no monitor section
    [   501.697] (II) intel(0): Enabled output HDMI2
    [   501.697] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
    [   501.697] (II) intel(0): Output VIRTUAL1 has no monitor section
    [   501.697] (II) intel(0): Enabled output VIRTUAL1
    [   501.697] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
    [   501.698] (==) intel(0): TearFree disabled
    [   501.698] (==) intel(0): DPI set to (96, 96)
    [   501.698] (II) Loading sub module "dri3"
    [   501.698] (II) LoadModule: "dri3"
    [   501.698] (II) Module "dri3" already built-in
    [   501.698] (II) Loading sub module "dri2"
    [   501.698] (II) LoadModule: "dri2"
    [   501.698] (II) Module "dri2" already built-in
    [   501.698] (II) Loading sub module "present"
    [   501.698] (II) LoadModule: "present"
    [   501.698] (II) Module "present" already built-in
    [   501.698] (II) UnloadModule: "modesetting"
    [   501.698] (II) Unloading modesetting
    [   501.698] (II) UnloadModule: "fbdev"
    [   501.699] (II) Unloading fbdev
    [   501.699] (II) UnloadSubModule: "fbdevhw"
    [   501.699] (II) Unloading fbdevhw
    [   501.699] (II) UnloadModule: "vesa"
    [   501.699] (II) Unloading vesa
    [   501.699] (==) Depth 24 pixmap format is 32 bpp
    [   501.700] (II) intel(0): SNA initialized with Skylake (gen9) backend
    [   501.700] (==) intel(0): Backing store enabled
    [   501.700] (==) intel(0): Silken mouse enabled
    [   501.700] (II) intel(0): HW Cursor enabled
    [   501.700] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    [   501.701] (==) intel(0): DPMS enabled
    [   501.701] (==) intel(0): Display hotplug detection enabled
    [   501.701] (II) intel(0): [DRI2] Setup complete
    [   501.701] (II) intel(0): [DRI2]   DRI driver: i965
    [   501.701] (II) intel(0): [DRI2]   VDPAU driver: va_gl
    [   501.701] (II) intel(0): direct rendering: DRI2 DRI3 enabled
    [   501.701] (II) intel(0): hardware support for Present enabled
    [   501.701] (--) RandR disabled
    [   501.763] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    [   501.763] (II) AIGLX: enabled GLX_ARB_create_context
    [   501.763] (II) AIGLX: enabled GLX_ARB_create_context_profile
    [   501.763] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
    [   501.763] (II) AIGLX: enabled GLX_INTEL_swap_event
    [   501.763] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    [   501.763] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
    [   501.763] (II) AIGLX: enabled GLX_ARB_fbconfig_float
    [   501.763] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
    [   501.763] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    [   501.764] (II) AIGLX: enabled GLX_ARB_create_context_robustness
    [   501.764] (II) AIGLX: Loaded and initialized i965
    [   501.764] (II) GLX: Initialized DRI2 GL provider for screen 0
    [   501.774] (II) intel(0): switch to mode [email protected] on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
    [   501.774] (II) intel(0): Setting screen physical size to 508 x 285
    [   501.831] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [   501.831] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [   501.831] (**) Power Button: Applying InputClass "system-keyboard"
    [   501.831] (**) Power Button: Applying InputClass "Keyboard Defaults"
    [   501.831] (II) LoadModule: "evdev"
    [   501.831] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [   501.831] (II) Module evdev: vendor="X.Org Foundation"
    [   501.831] 	compiled for 1.18.3, module version = 2.10.3
    [   501.831] 	Module class: X.Org XInput Driver
    [   501.831] 	ABI class: X.Org XInput driver, version 22.1
    [   501.831] (II) Using input driver 'evdev' for 'Power Button'
    [   501.831] (**) Power Button: always reports core events
    [   501.831] (**) evdev: Power Button: Device: "/dev/input/event3"
    [   501.831] (--) evdev: Power Button: Vendor 0 Product 0x1
    [   501.831] (--) evdev: Power Button: Found keys
    [   501.831] (II) evdev: Power Button: Configuring as keyboard
    [   501.831] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event3"
    [   501.831] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
    [   501.831] (**) Option "xkb_rules" "evdev"
    [   501.831] (**) Option "xkb_layout" "gb"
    [   501.831] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   501.845] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
    [   501.845] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
    [   501.845] (**) Video Bus: Applying InputClass "system-keyboard"
    [   501.845] (**) Video Bus: Applying InputClass "Keyboard Defaults"
    [   501.845] (II) Using input driver 'evdev' for 'Video Bus'
    [   501.845] (**) Video Bus: always reports core events
    [   501.845] (**) evdev: Video Bus: Device: "/dev/input/event7"
    [   501.845] (--) evdev: Video Bus: Vendor 0 Product 0x6
    [   501.845] (--) evdev: Video Bus: Found keys
    [   501.845] (II) evdev: Video Bus: Configuring as keyboard
    [   501.845] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input9/event7"
    [   501.845] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
    [   501.845] (**) Option "xkb_rules" "evdev"
    [   501.845] (**) Option "xkb_layout" "gb"
    [   501.845] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   501.845] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
    [   501.845] (II) No input driver specified, ignoring this device.
    [   501.845] (II) This device may have been added with another device file.
    [   501.845] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
    [   501.845] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
    [   501.845] (**) Sleep Button: Applying InputClass "system-keyboard"
    [   501.845] (**) Sleep Button: Applying InputClass "Keyboard Defaults"
    [   501.845] (II) Using input driver 'evdev' for 'Sleep Button'
    [   501.845] (**) Sleep Button: always reports core events
    [   501.845] (**) evdev: Sleep Button: Device: "/dev/input/event2"
    [   501.845] (--) evdev: Sleep Button: Vendor 0 Product 0x3
    [   501.845] (--) evdev: Sleep Button: Found keys
    [   501.845] (II) evdev: Sleep Button: Configuring as keyboard
    [   501.845] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input3/event2"
    [   501.845] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
    [   501.845] (**) Option "xkb_rules" "evdev"
    [   501.845] (**) Option "xkb_layout" "gb"
    [   501.845] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   501.846] (II) config/udev: Adding input device Integrated Camera (/dev/input/event5)
    [   501.846] (**) Integrated Camera: Applying InputClass "evdev keyboard catchall"
    [   501.846] (**) Integrated Camera: Applying InputClass "system-keyboard"
    [   501.846] (**) Integrated Camera: Applying InputClass "Keyboard Defaults"
    [   501.846] (II) Using input driver 'evdev' for 'Integrated Camera'
    [   501.846] (**) Integrated Camera: always reports core events
    [   501.846] (**) evdev: Integrated Camera: Device: "/dev/input/event5"
    [   501.846] (--) evdev: Integrated Camera: Vendor 0x5986 Product 0x708
    [   501.846] (--) evdev: Integrated Camera: Found keys
    [   501.846] (II) evdev: Integrated Camera: Configuring as keyboard
    [   501.846] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0/input/input8/event5"
    [   501.846] (II) XINPUT: Adding extended input device "Integrated Camera" (type: KEYBOARD, id 9)
    [   501.846] (**) Option "xkb_rules" "evdev"
    [   501.846] (**) Option "xkb_layout" "gb"
    [   501.846] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   501.846] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event10)
    [   501.846] (II) No input driver specified, ignoring this device.
    [   501.846] (II) This device may have been added with another device file.
    [   501.846] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event11)
    [   501.846] (II) No input driver specified, ignoring this device.
    [   501.846] (II) This device may have been added with another device file.
    [   501.847] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event12)
    [   501.847] (II) No input driver specified, ignoring this device.
    [   501.847] (II) This device may have been added with another device file.
    [   501.847] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event13)
    [   501.847] (II) No input driver specified, ignoring this device.
    [   501.847] (II) This device may have been added with another device file.
    [   501.847] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=7 (/dev/input/event14)
    [   501.847] (II) No input driver specified, ignoring this device.
    [   501.847] (II) This device may have been added with another device file.
    [   501.847] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=8 (/dev/input/event15)
    [   501.847] (II) No input driver specified, ignoring this device.
    [   501.847] (II) This device may have been added with another device file.
    [   501.847] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    [   501.847] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    [   501.847] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
    [   501.847] (**) AT Translated Set 2 keyboard: Applying InputClass "Keyboard Defaults"
    [   501.847] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
    [   501.847] (**) AT Translated Set 2 keyboard: always reports core events
    [   501.847] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
    [   501.847] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
    [   501.847] (--) evdev: AT Translated Set 2 keyboard: Found keys
    [   501.847] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
    [   501.847] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
    [   501.847] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
    [   501.847] (**) Option "xkb_rules" "evdev"
    [   501.847] (**) Option "xkb_layout" "gb"
    [   501.847] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   501.848] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint Stick (/dev/input/event8)
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: Applying InputClass "evdev pointer catchall"
    [   501.848] (II) Using input driver 'evdev' for 'AlpsPS/2 ALPS DualPoint Stick'
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: always reports core events
    [   501.848] (**) evdev: AlpsPS/2 ALPS DualPoint Stick: Device: "/dev/input/event8"
    [   501.848] (--) evdev: AlpsPS/2 ALPS DualPoint Stick: Vendor 0x2 Product 0x8
    [   501.848] (--) evdev: AlpsPS/2 ALPS DualPoint Stick: Found 3 mouse buttons
    [   501.848] (--) evdev: AlpsPS/2 ALPS DualPoint Stick: Found relative axes
    [   501.848] (--) evdev: AlpsPS/2 ALPS DualPoint Stick: Found x and y relative axes
    [   501.848] (II) evdev: AlpsPS/2 ALPS DualPoint Stick: Configuring as mouse
    [   501.848] (**) evdev: AlpsPS/2 ALPS DualPoint Stick: YAxisMapping: buttons 4 and 5
    [   501.848] (**) evdev: AlpsPS/2 ALPS DualPoint Stick: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [   501.848] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input10/event8"
    [   501.848] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint Stick" (type: MOUSE, id 11)
    [   501.848] (II) evdev: AlpsPS/2 ALPS DualPoint Stick: initialized for relative axes.
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) keeping acceleration scheme 1
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) acceleration profile 0
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) acceleration factor: 2.000
    [   501.848] (**) AlpsPS/2 ALPS DualPoint Stick: (accel) acceleration threshold: 4
    [   501.848] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint Stick (/dev/input/mouse0)
    [   501.848] (II) No input driver specified, ignoring this device.
    [   501.848] (II) This device may have been added with another device file.
    [   501.848] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/event9)
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "evdev touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
    [   501.848] (II) LoadModule: "synaptics"
    [   501.848] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
    [   501.848] (II) Module synaptics: vendor="X.Org Foundation"
    [   501.848] 	compiled for 1.18.3, module version = 1.8.99
    [   501.848] 	Module class: X.Org XInput Driver
    [   501.848] 	ABI class: X.Org XInput driver, version 22.1
    [   501.848] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS DualPoint TouchPad'
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
    [   501.849] (**) Option "Device" "/dev/input/event9"
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: found clickpad property
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: x-axis range 0 - 4095 (res 42)
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: y-axis range 0 - 2047 (res 38)
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report pressure, will use touch data.
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report finger width.
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: buttons: left double triple
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: Vendor 0x2 Product 0x8
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid pressure range.  defaulting to 0 - 255
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid finger width range.  defaulting to 0 - 15
    [   501.880] (**) Option "TapButton1" "1"
    [   501.880] (**) Option "TapButton2" "2"
    [   501.880] (**) Option "TapButton3" "3"
    [   501.880] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
    [   501.880] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
    [   501.907] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event9"
    [   501.907] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD, id 12)
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MinSpeed is now constant deceleration 2.5
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MaxSpeed is now 1.75
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) AccelFactor is now 0.044
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 1
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
    [   501.907] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
    [   501.908] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
    [   501.908] (**) AlpsPS/2 ALPS DualPoint TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
    [   501.909] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
    [   501.909] (II) No input driver specified, ignoring this device.
    [   501.909] (II) This device may have been added with another device file.
    [   501.911] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event6)
    [   501.911] (**) ThinkPad Extra Buttons: Applying InputClass "evdev keyboard catchall"
    [   501.911] (**) ThinkPad Extra Buttons: Applying InputClass "system-keyboard"
    [   501.911] (**) ThinkPad Extra Buttons: Applying InputClass "Keyboard Defaults"
    [   501.911] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'
    [   501.911] (**) ThinkPad Extra Buttons: always reports core events
    [   501.911] (**) evdev: ThinkPad Extra Buttons: Device: "/dev/input/event6"
    [   501.911] (--) evdev: ThinkPad Extra Buttons: Vendor 0x17aa Product 0x5054
    [   501.911] (--) evdev: ThinkPad Extra Buttons: Found keys
    [   501.911] (II) evdev: ThinkPad Extra Buttons: Configuring as keyboard
    [   501.911] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input5/event6"
    [   501.911] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 13)
    [   501.912] (**) Option "xkb_rules" "evdev"
    [   501.912] (**) Option "xkb_layout" "gb"
    [   501.912] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [   502.169] (II) evdev: ThinkPad Extra Buttons: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.169] (II) UnloadModule: "synaptics"
    [   502.169] (II) evdev: AlpsPS/2 ALPS DualPoint Stick: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.169] (II) evdev: AT Translated Set 2 keyboard: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.169] (II) evdev: Integrated Camera: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.169] (II) evdev: Sleep Button: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.169] (II) evdev: Video Bus: Close
    [   502.169] (II) UnloadModule: "evdev"
    [   502.170] (II) evdev: Power Button: Close
    [   502.170] (II) UnloadModule: "evdev"
    [   502.268] (II) Server terminated successfully (0). Closing log file.
    

    I’m still sort of new to Antergos and Linux as a whole so if I’m sort of clueless :S

    Apologies if I’m missing some output I should be putting here too! D:
    Thanks!
    (Edit: Apologies if all the logs are unnecessary, I’m really confused and just showing the logs which other people have shown who have had issues with trackpads)

  • @Sirex Just a shot in a dark - try to install xf86-input-libinput:

    sudo pacman -Syyu xf86-input-libinput
    

    If it doesn’t help, it is always possible to inunstall it:

    sudo pacman -R xf86-input-libinput
    
  • @just Thanks for the suggestion :) Still not working though.
    The installation of xf86-input-libinput unfortunately didn’t fix the problem.
    However I checked over the /var/log/Xorg.0.log log and found this:

    [   501.848] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/event9)
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "evdev touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "touchpad catchall"
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: Applying InputClass "Default clickpad buttons"
    [   501.848] (II) LoadModule: "synaptics"
    [   501.848] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
    [   501.848] (II) Module synaptics: vendor="X.Org Foundation"
    [   501.848] 	compiled for 1.18.3, module version = 1.8.99
    [   501.848] 	Module class: X.Org XInput Driver
    [   501.848] 	ABI class: X.Org XInput driver, version 22.1
    [   501.848] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS DualPoint TouchPad'
    [   501.848] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
    [   501.849] (**) Option "Device" "/dev/input/event9"
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: found clickpad property
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: x-axis range 0 - 4095 (res 42)
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: y-axis range 0 - 2047 (res 38)
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report pressure, will use touch data.
    [   501.880] (II) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: device does not report finger width.
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: buttons: left double triple
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: Vendor 0x2 Product 0x8
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid pressure range.  defaulting to 0 - 255
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: invalid finger width range.  defaulting to 0 - 15
    [   501.880] (**) Option "TapButton1" "1"
    [   501.880] (**) Option "TapButton2" "2"
    [   501.880] (**) Option "TapButton3" "3"
    [   501.880] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    [   501.880] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
    [   501.880] (**) AlpsPS/2 ALPS DualPoint TouchPad: always reports core events
    [   501.907] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event9"
    [   501.907] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS DualPoint TouchPad" (type: TOUCHPAD, id 12)
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MinSpeed is now constant deceleration 2.5
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) MaxSpeed is now 1.75
    [   501.907] (**) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: (accel) AccelFactor is now 0.044
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) keeping acceleration scheme 1
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration profile 1
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration factor: 2.000
    [   501.907] (**) AlpsPS/2 ALPS DualPoint TouchPad: (accel) acceleration threshold: 4
    [   501.907] (--) synaptics: AlpsPS/2 ALPS DualPoint TouchPad: touchpad found
    [   501.908] (II) config/udev: Adding input device AlpsPS/2 ALPS DualPoint TouchPad (/dev/input/mouse1)
    [   501.908] (**) AlpsPS/2 ALPS DualPoint TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
    [   501.909] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
    [   501.909] (II) No input driver specified, ignoring this device.
    [   501.909] (II) This device may have been added with another device file.
    

    Sorry about all the logs :/ But could the issue possibly be related to this line?

    [   501.909] (II) No input driver specified, ignoring this device.
    

    So I’m taking the touchpad drivers aren’t there anymore or they aren’t being recognized?
    Sorry about all the questions :/

  • Just a quick update, the touchpad seems to be working now. Unsure what caused the issue though. Really weird, it just started working on its own again :/

  • Many laptops have a keyboard combo, usually Fn+<something>, to switch the touchpad off and on. On some Acer it is Fn+F7, for example.

    The same goes for Wi-Fi, which can be switched off and on from the keyboard. Usually Fn+F2 on Dell, Fn+F3 on Acer. For external monitors, sound cards.

    It sometimes happens to hit those combos, without noticing it.

  • That has happened a few times with my laptop. Once with LinuxMint, once with Manjaro and once with Antergos I believe. It always stops working during a reboot and then the first time it started working again randomly when playing with the liveCD. The second and third time the liveCDs would not work either, but I popped in a Windows7 install CD and it started working again. I have no explanation.

  • @just said in Lenovo E460 -- Touchpad suddenly not working:

    Many laptops have a keyboard combo, usually Fn+<something>, to switch the touchpad off and on. On some Acer it is Fn+F7, for example.

    The same goes for Wi-Fi, which can be switched off and on from the keyboard. Usually Fn+F2 on Dell, Fn+F3 on Acer. For external monitors, sound cards.

    It sometimes happens to hit those combos, without noticing it.

    Oh could of been actually, unsure but I did try some of the Fn combos. Thanks though, didn’t know about the WiFi one or the trackpad on Acer :)
    Thanks!

  • @Shryp said in Lenovo E460 -- Touchpad suddenly not working:

    That has happened a few times with my laptop. Once with LinuxMint, once with Manjaro and once with Antergos I believe. It always stops working during a reboot and then the first time it started working again randomly when playing with the liveCD. The second and third time the liveCDs would not work either, but I popped in a Windows7 install CD and it started working again. I have no explanation.

    Yeah, it’s kind weird :? Glad it’s working again for you though! :D Hopefully won’t happen again, probably something to do driver although I have no clue either.

  • @Sirex said in Lenovo E460 -- Touchpad suddenly not working:

    @Shryp said in Lenovo E460 -- Touchpad suddenly not working:

    That has happened a few times with my laptop. Once with LinuxMint, once with Manjaro and once with Antergos I believe. It always stops working during a reboot and then the first time it started working again randomly when playing with the liveCD. The second and third time the liveCDs would not work either, but I popped in a Windows7 install CD and it started working again. I have no explanation.

    Yeah, it’s kind weird :? Glad it’s working again for you though! :D Hopefully won’t happen again, probably something to do driver although I have no clue either.

    I thought driver too, but I have no explanation as to why various live CD / USB combinations that worked fine before suddenly didn’t.

    The first time it happened I took my laptop apart thinking something broke with the touchpad. I think it was a couple days after I took it apart to clean it so I thought maybe a wire came loose or something.

not working3 lenovo12 touchpad32 Posts 9Views 1293
Log in to reply