• Gnome-user-share


    I am trying to get gnome inter-computer file sharing facility to work, but I am getting very odd results:
    I have set the public directory share properties. The directory can be seen and data moved to and from it across the local area network, but unlike all my fedora machines, the directory still has a big blue sign across the top telling me to set the share options on the folder. This normally disappears once, the setting have been set.

    On the gnome setting panel for sharing, there should be for options: Personal File sharing, Screen sharing, media sharing, remote login. On antergos, Media and Screen sharing are missing. Media sharing is the option everyone else is using.

    Whilst others can interact with my public directory, I am unable to access anyone else’s public directory even though they appear in the ‘other locations’ of the file manager. Selecting these leads to ‘error resolving [xxxxxxxxxx]. Name or service not known’.

    I have never had a problem with these facilities before. Everything just worked. Presumably there is something different about the default set up for sharing on antergos from fedora, but I don’t know where to start looking.

    Any help appreciated.

  • I was just about to create a thread about this. I can’t get antergos to access my Windows shared files no matter what I do. I spent a lot of time googling and I feel like I’ve tried everything.

  • @un4tt3nd3d I don’t have any windows machines. I am just trying to access an already working linux-to-linux set-up.
    Windows sharing requires samba, I think, which is even more confusing.

  • @ddd Oh I thought you needed samba too. Honestly it’s almost funny how nautilus and other file explorers come with that “Other locations” tab as if sharing was something that works out of the box. I spent hours entering commands and editing the samb.conf file and still can’t get it to work. Probably one of the least user friendly experiences I’ve had on linux, and that’s saying a lot.

  • @un4tt3nd3d I think the file sharing protocol is as in dav://user.domain/path, unless you need windows access, then its samba.

  • There is a specific page for samba on the wiki
    but whenever I insert it into this reply, the reply is not accepted - Error recognised as spam!!!
    If anyone knows how to put links into this system, I will post it!

  • Some further findings:
    To get media sharing to appear in the settings panel, you need to install rygel
    To get screen sharing to appear in the settings panel, you need to install vino
    This doesn’t fix anything, but at least it solves one mystery.

    The ‘official’ tutorial for setting up samba on the wiki is full of typos
    e.g. There is not ‘is-enables’ command, its ‘is-enabled’

    The ‘official’ tutorial for setting up samba on the wiki is out of date
    The current default .conf file does not contain the ‘include’ line which you are instructed to uncomment.

    ufw is a pig and basically locked me out of all local sharing…
    I had to temporarily remove the package in order to get access back again.

    The samba connection appears to work, but

    1. it continues to provide access to public directories even when access has been switched off.
    2. It kills access to the existing webdav shares…

    Meanwhile, 5 other (fedora) machines continue to share with each other without any set up or maintenance.
    This has not been a good day!

    If anyone knows how to get this stuff to actually work, I would love to know!

  • @ddd Yep, I followed that so called “tutorial” long ago and had to fix the typos myself. I also still can’t get it to work. Something is seriously wrong with samba on antergos. Good on you for figuring some things out by yourself though :+1:

Posts 8Views 937
Log in to reply