• Login manager & pacman -Syu


    Hello,

    i have two problems that are very important for me. Today I had the idea to play with the different desktop environments, but now I have trouble with my system. I have a system that runs XFCE. That was fine but of course I was curious and I tried GNOME. After that I removed it with sudo pacman -Rcn gnome. After that everything went wrong.

    I had to install xfce4 and the xfce4-goodies again because everything was removed. Since then my keyboard keys do not work anymore (like sound and brightness). The brightness change all the time. And when I reboot I am not able to log-in using lightdm, but using the terminal and then start xfce with exec startxfce4.

    I would like that my system works like it should. Another problem is that when I do a system update (sudo pacman -syu) all the output stays at 0%.

    When I try to reinstall lightdm it gives the error that the files are already in the filesystem.

    When I try systemctl enable lightdm.service it says it is masked and even after unmasking it it says it is still masked.

    Can somebody help me so my system is the same as yesterday when everything worked?

    Thank you for your help and time!

  • Have you checked if you have gdm enabled? I would think you can’t enable lightdm if gdm is enabled.

    Here’s the list of that the different DE choices installs:
    https://github.com/Antergos/Cnchi/blob/master/data/packages.xml

    Too tired to think right now but maybe it helps.

  • Hello,

    First thanks for your response, but it did not solved my problem.

    If I install GDM and run systemctl restart gdm.service I get the gnome log-in manager. I would like to use lightdm because there it is possible to switch between different desktop environments.

    When I try systemctl restart lightdm.service this is what I get back:
    Failed to restart lightdm.service: Unit lightdm.service is masked.

    Then I thought I will manually install all packages list in the cnchi installer for the xfce4 desktop. When I try to install light-locker the I get for example this response:
    lightdm: /usr/share/locale/af/LC_MESSAGES/lightdm.mo exists in filesystem
    some errors are other, but the idea is the same, it exists in the filesystem.

    After each installation of a new package I get this warning:
    ldconfig: File /usr/lib/liblightdm-gobject-1.so.0 is empty, not checked. ldconfig: File /usr/lib/liblightdm-gobject-1.so.0.0.0 is empty, not checked. ldconfig: File /usr/lib/liblightdm-gobject-1.so is empty, not checked.

    I hope that this extra information gives a better idea about what is going on on my system.

  • @pepijntje02 said

    I would like to use lightdm because there it is possible to switch between different desktop environments.

    Cannot help you with lightDM, but if you don t mind, you can also switch desktops with GDM. Just click the gear icon next to the CONNECT button to show them before typing your password.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Besides lightdm do you have a greeter installed? Without a greeter theme lightdm probably does not work. The lightdm-gtk-greeter would do fine. Make sure you also install the light-gtk-greeter-settings package. Eventually add light-locker.

    First disable any DM currently running:
    sudo systemctl disable (current dm)

    Enable lightdm: sudo systemctl enable lightdm
    Eventually add: -f to force activation.

    For the system update did you try: sudo pacman -Syyu ?
    Hope this works.

    Never to old to learn.

  • You can try that too:

    sudo systemctl stop gdm
    sudo systemctl disable gdm
    sudo systemctl enable lightdm.service
    sudo systemctl start lightdm

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @pepijntje02 said in Login manager & pacman -Syu:

    After that I removed it with sudo pacman -Rcn gnome.

    When removing, always check which packages pacman will remove (even more if you’re using the -c cascade option!).

    I had to install xfce4 and the xfce4-goodies again because everything was removed.

    Yep, you told pacman to remove them ;)

    The easiest way to restore xfce is to install it full:
    sudo pacman -S xfce4

    Another problem is that when I do a system update (sudo pacman -syu) all the output stays at 0%.

    I suppose you mean sudo pacman -Syu
    if that’s the case, you should check your /etc/pacman.d/mirrorlist file. Check that you have a mirror uncommented (and one that is near your location).

    When I try to reinstall lightdm it gives the error that the files are already in the filesystem.

    That’s odd, too. Did you install lightdm from AUR or from source? If not, you can force pacman to install it with sudo pacman -S lightdm --force

    When I try systemctl enable lightdm.service it says it is masked and even after unmasking it it says it is still masked.

    That could be because you removed lightdm in a bad way ¿?
    Install it again and then enable it:
    sudo systemctl enable lightdm

    Can somebody help me so my system is the same as yesterday when everything worked?

    It’s difficult to know what went wrong. You have the pacman log in /var/log that should help you track what exactly happened.

    Thank you for your help and time!

    You’re welcome!

  • Hello,

    The last post from karasu helped a lot. I have installed lightdm now and it start by default, but it is not able to start.

    I get those two erros:
    failed to start Light display manager

    and when I go to “ctrl -alt-f2” then I get this error:
    session_init() can't open display

    I have got two other problems with the xfce4 install. My keyboard buttons for sound and brightness do not seem to work. And after I changed it one time then it the sound goes louder and softer over time without touching the system. The same happens with the brightness. I have installed xfce4-volumed so I do not understand where this problem come from since it worked before.

    I hope you can help me further, but your previous answer helped a lot! Thanks!

  • Hi,

    I’m glad it helped. Let’s see…

    failed to start Light display manager

    Check that you have a lightdm greeter installed:
    sudo pacman -S lightdm-webkit2-greeter

    Also, check that you have it configured in
    /etc/lightdm/lightdm.conf
    In the [Seat:*] section, check that you have uncommented:
    greeter-session=lightdm-webkit2-greeter

    If it still does not work, you’ll have to check the logs, check the files in the /var/log/lightdm folder (put them here if you want us to check them).

    Cheers!

    P.S. Instead of lightdm-webkit2-greeter, you can test the lightdm-gtk-greeter (uglier but more stable in my tests).

  • Hello,

    Thank you very much, now it all of it work more or less. I am switched from xfce to cinnamon because all the keyboard stuff work there better. Now I have no problem with my sound and brightness anymore.

    When I have time I would like to play more with the system and try an arch installation, but at the moment I am using the laptop for my study so I can not take the risk that the system do not work well.

    Thank for your help, now I do not need a new installation and I can still use my old programs.

    I wil try to change this topic to solved, thank you very much!

syu6 login72 manager42 pacman77 Posts 10Views 1180
Log in to reply