• Internal Webcam issue


    Hi,

    Dell Vostro 3350:

    # uname -a
    Linux vostro-3350 4.7.5-1-ARCH #1 SMP PREEMPT Sat Sep 24 13:04:22 CEST 2016 x86_64 
    GNU/Linux
    # lsusb
    Bus 004 Device 004: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller
    Bus 004 Device 003: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader
    Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    **Bus 001 Device 004: ID 0c45:642c Microdia** 
    Bus 001 Device 003: ID 8086:0189 Intel Corp. 
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    $ dmesg |grep uvc
    [   10.442332] uvcvideo: Found UVC 1.00 device Laptop_Integrated_Webcam_HD (0c45:642c)
    [   10.658312] uvcvideo 1-1.5:1.0: Entity type for entity Extension 5 was not initialized!
    [   10.658324] uvcvideo 1-1.5:1.0: Entity type for entity Extension 4 was not initialized!
    [   10.658330] uvcvideo 1-1.5:1.0: Entity type for entity Processing 3 was not initialized!
    [   10.658336] uvcvideo 1-1.5:1.0: Entity type for entity Camera 1 was not initialized!
    [   10.658821] usbcore: registered new interface driver uvcvideo
    

    Under Ubuntu 14.04 camera has worked.

    Please help to solve problem.

    brg,
    Serhiy.

  • Okay, it was zbarcam’s problem.
    Solved with library preloading:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so zbarcam

  • Thanks for sharing your answer, is really appreciated.

    Cheers!

webcam9 Posts 3Views 1793
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.