• Error on Update-Manager - solved!


    I have Updates (Dropbox app) but i can’t install it.

    Error

    ThinkPad x200 with Antergos

  • Not everyone speaks German. The output in English could get more attention:

    export LANG=C && sudo pacman -Syyu
    
    1. Foto:

    Error 2

    ThinkPad x200 with Antergos

  • @just said in Error on Update-Manager:

    Not everyone speaks German. The output in English could get more attention:

    export LANG=C && sudo pacman -Syyu
    

    Foto3:
    Erroro 3

    ThinkPad x200 with Antergos

  • Try to apply this sequence of commands:

    sudo pacman -Scc  <-- reply with explicit y to the first question
    sudo pacman -Syy
    sudo pacman -S haveged  <-- if it fails, ignore
    sudo haveged -w 1024  <-- if above fails, ignore
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos 
    sudo pkill haveged  <-- if it fails, ignore
    sudo pacman -S archlinux-keyring antergos-keyring
    sudo pacman -Syu
    
  • [[email protected] ~]$ sudo pacman -Scc
    [sudo] Passwort für kate: 
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    
    Puffer-Verzeichnis: /var/cache/pacman/pkg/
    :: Möchten Sie ALLE Dateien aus dem Puffer entfernen? [j/N] j
    Entferne alle Dateien aus dem Puffer...
    
    Datenbank-Verzeichnis: /var/lib/pacman/
    :: Möchten Sie ungenutzte Repositorien entfernen? [J/n] j
    Entferne unbenutzte Sync-Repositorien...
    [[email protected] ~]$ sudo pacman -Syy
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    :: Synchronisiere Paketdatenbanken...
     antergos                           127,3 KiB   872K/s 00:00 [################################] 100%
     core                                 6,6 KiB  33,4K/s 00:00 [################################] 100%
     core.sig                             6,6 KiB   940K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte core nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     extra                                6,6 KiB  0,00B/s 00:00 [################################] 100%
     extra.sig                            6,6 KiB  2,14M/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte extra nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     community                            6,6 KiB  2,14M/s 00:00 [################################] 100%
     community.sig                        6,6 KiB   659K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte community nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     pipelight                          150,5 KiB   851K/s 00:00 [################################] 100%
     pipelight.sig                      543,0   B  0,00B/s 00:00 [################################] 100%
     multilib                             6,6 KiB  1646K/s 00:00 [################################] 100%
     multilib.sig                         6,6 KiB   941K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte multilib nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'core' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'extra' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'community' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'multilib' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    [[email protected] ~]$ sudo pacman -S haveged
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: Datenbank 'core' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'extra' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'community' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'multilib' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    [[email protected] ~]$ sudo haveged -w 1024
    [[email protected] ~]$ sudo pacman-key --init
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    ==> Füge Schlüssel aus archlinux.gpg hinzu...
    ==> Füge Schlüssel aus antergos.gpg hinzu...
    ==> Signiere die vertrauenswürdigen Schlüssel im Schlüsselbund lokal...
      -> Signiere Schlüssel 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 lokal...
      -> Signiere Schlüssel 684148BB25B49E986A4944C55184252D824B18E8 lokal...
      -> Signiere Schlüssel 24B445614FAC071891EDCE49CDBD406AA1AA7A1D lokal...
      -> Signiere Schlüssel D95436A2E18DA94A72B1A5E2AEA529BF122902E5 lokal...
      -> Signiere Schlüssel 91FFE0700E80619CEB73235CA88E23E377514E00 lokal...
      -> Signiere Schlüssel EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 lokal...
      -> Signiere Schlüssel 44D4A033AC140143927397D47EFD567D4C7EA887 lokal...
      -> Signiere Schlüssel 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 lokal...
      -> Signiere Schlüssel AB19265E5D7D20687D303246BA1DFB64FFF979E7 lokal...
    ==> Importiere die Vertrauenswerte des Benutzers...
    ==> Mache widerrufene Schlüssel im Schlüsselbund unbrauchbar...
      -> Mache Schlüssel F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6 unbrauchbar...
      -> Mache Schlüssel 7FA647CD89891DEDC060287BB9113D1ED21E1A55 unbrauchbar...
      -> Mache Schlüssel D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50 unbrauchbar...
      -> Mache Schlüssel BC1FBE4D2826A0B51E47ED62E2539214C6C11350 unbrauchbar...
      -> Mache Schlüssel 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5 unbrauchbar...
      -> Mache Schlüssel 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2 unbrauchbar...
      -> Mache Schlüssel 63F395DE2D6398BBE458F281F2DBB4931985A992 unbrauchbar...
      -> Mache Schlüssel 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196 unbrauchbar...
      -> Mache Schlüssel 8F76BEEA0289F9E1D3E229C05F946DED983D4366 unbrauchbar...
      -> Mache Schlüssel 66BD74A036D522F51DD70A3C7F2A16726521E06D unbrauchbar...
      -> Mache Schlüssel 81D7F8241DB38BC759C80FCE3A726C6170E80477 unbrauchbar...
      -> Mache Schlüssel E7210A59715F6940CF9A4E36A001876699AD6E84 unbrauchbar...
    ==> Aktualisiere Trust-Datenbank...
    gpg: nächste "Trust-DB"-Pflichtüberprüfung am 2016-10-19
    [[email protected] ~]$ sudo pkill haveged
    [[email protected] ~]$ sudo pacman -S archlinux-keyring antergos-keyring
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: Datenbank 'core' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'extra' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'community' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'multilib' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    [[email protected] ~]$ sudo pacman -Syu
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    Fehler: GPGME error: Keine Daten
    :: Synchronisiere Paketdatenbanken...
     antergos ist aktuell
     core                                 6,6 KiB  2,14M/s 00:00 [################################] 100%
     core.sig                             6,6 KiB   940K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte core nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     extra                                6,6 KiB  2,14M/s 00:00 [################################] 100%
     extra.sig                            6,6 KiB   940K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte extra nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     community                            6,6 KiB  1647K/s 00:00 [################################] 100%
     community.sig                        6,6 KiB  2,15M/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte community nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
     pipelight ist aktuell
     multilib                             6,6 KiB  2,14M/s 00:00 [################################] 100%
     multilib.sig                         6,6 KiB  1098K/s 00:00 [################################] 100%
    Fehler: GPGME error: Keine Daten
    Fehler: Konnte multilib nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'core' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'extra' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'community' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    Fehler: Datenbank 'multilib' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))
    [[email protected] ~]$ 
    

    No Luck…

    ThinkPad x200 with Antergos

  • And now?

    This is the last installed update:

    last install

    ThinkPad x200 with Antergos

  • @Danica_Talos said in Error on Update-Manager:

    And now?

    This isn’t a way neither to expose a problem nor to ask for a help.

    Final attempt. Which GPG signatures are present in the system? Seems like one is missing. If you don’t know the answer, run the command

    export LANG=C && ls /usr/share/pacman/keyrings -lha
    

    Please, instead of screenshots, reply with simple text. Put the lines with three backticks ``` chars before and after the terminal output. It’s easier to read a text rather than screenshots.

  • @just

    [[email protected] ~]$ export LANG=C && ls /usr/share/pacman/keyrings -lha
    total 840K
    drwxr-xr-x 2 root root 4.0K Aug 27 15:06 .
    drwxr-xr-x 3 root root 4.0K Aug 27 15:00 ..
    -rw-r--r-- 1 root root  17K Aug  6  2015 antergos.gpg
    -rw-r--r-- 1 root root    0 Aug  6  2015 antergos-revoked
    -rw-r--r-- 1 root root  132 Aug  6  2015 antergos-trusted
    -rw-r--r-- 1 root root 800K Aug 12 07:42 archlinux.gpg
    -rw-r--r-- 1 root root  492 Aug 12 07:42 archlinux-revoked
    -rw-r--r-- 1 root root  264 Aug 12 07:42 archlinux-trusted
    [[email protected] ~]$
    

    ThinkPad x200 with Antergos

  • @Danica_Talos This is OK. Both keyrings are signed with GPG.

    I’m running out of ideas. Do you still get errors when run

    export LANG=C && sudo pacman -Syyu
    

    ?

  • @just said in Error on Update-Manager:

    Try to apply this sequence of commands:

    sudo pacman -Scc  <-- reply with explicit y to the first question
    ...
    sudo pacman -Syu
    

    Thanks so much, @just, I was having the exact same issue on a fresh install and your suggestion resolved it.

  • @just said in Error on Update-Manager:

    export LANG=C && sudo pacman -Syyu

    [[email protected] ~]$ export LANG=C && sudo pacman -Syyu
    [sudo] password for kate: 
    error: GPGME error: No data
    error: GPGME error: No data
    error: GPGME error: No data
    error: GPGME error: No data
    :: Synchronizing package databases...
     antergos                           127.3 KiB   471K/s 00:00 [################################] 100%
     core                                 6.3 KiB  30.9K/s 00:00 [################################] 100%
     core.sig                             6.3 KiB  0.00B/s 00:00 [################################] 100%
    error: GPGME error: No data
    error: failed to update core (invalid or corrupted database (PGP signature))
     extra                                6.3 KiB  2.05M/s 00:00 [################################] 100%
     extra.sig                            6.3 KiB  1578K/s 00:00 [################################] 100%
    error: GPGME error: No data
    error: failed to update extra (invalid or corrupted database (PGP signature))
     community                            6.3 KiB  0.00B/s 00:00 [################################] 100%
     community.sig                        6.3 KiB  2.06M/s 00:00 [################################] 100%
    error: GPGME error: No data
    error: failed to update community (invalid or corrupted database (PGP signature))
     pipelight                          150.5 KiB   855K/s 00:00 [################################] 100%
     pipelight.sig                      543.0   B  0.00B/s 00:00 [################################] 100%
     multilib                             6.3 KiB  0.00B/s 00:00 [################################] 100%
     multilib.sig                         6.3 KiB  2.06M/s 00:00 [################################] 100%
    error: GPGME error: No data
    error: failed to update multilib (invalid or corrupted database (PGP signature))
    error: database 'core' is not valid (invalid or corrupted database (PGP signature))
    error: database 'extra' is not valid (invalid or corrupted database (PGP signature))
    error: database 'community' is not valid (invalid or corrupted database (PGP signature))
    error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))
    
    

    ThinkPad x200 with Antergos

  • As a temporary workaround you could just set your SigLevel option to Never in your pacman.conf

    SigLevel    = Never
    

    This isn’t really nice, but it worked for me.

  • @frahm.charly

    Not for me…

    ThinkPad x200 with Antergos

  • I’m the Greatest!

    I have solved my problem!!!

    I have edit the serverlist. The bad url is:

    Server = http://mirror.hactar.bz/$repo/os/$arch
    

    With other serveradress i can install apps and updates without problems.

    ThinkPad x200 with Antergos

  • @Danica_Talos , marked as solved. You ll find this option on the bottom RH corner, inside TOPIC TOOLS.
    Keep smiling!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

update-manager1 error186 Posts 16Views 2314
Log in to reply