• Switching from lightdm to gdm - No lock screen


    Hello Antergos community,
    first post here, long time Arch user. I’m trying to switch from lightdm to gdm. I did:

    sudo pacman -S gdm
    sudo systemctl disable lightdm && sudo systemctl enable gdm
    

    but now the lock screen button does nothing. Did I miss something?
    I am using Gnome of course and I have rebooted.

    Thank you.

  • I always replace lightdm with gdm after a fresh Antergos install, and never had a problem with it or with gnome’s screensaver. Here’s how I do it (as ROOT):

    systemctl disable lightdm.service
    
    pacman -Rs lightdm-webkit2-greeter light-locker-settings light-locker lightdm
    
    rm -rf /etc/lightdm
    
    pacman -S gdm
    pacman -S gtk-engines
    
    systemctl enable gdm.service
    
    pacman -Rs xscreensaver
    
    pacman -S gnome-screensaver
lightdm123 gdm42 lock28 switching11 Posts 2Views 2252
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.