• Need Authentication for Installation


    I installed the 2016.09.03 version without authentication, now when I try to install the 2016.09.25 version it requires authentication. am I missing something here?

  • @johnk46

    That’s odd. Open gnome-terminal and run:
    sudo -E /usr/bin/cnchi

    What do you get?

  • this is what I got -

    [[email protected] ~]$ sudo -E /usr/bin/cnchi
    Unable to init server: Could not connect: Connection refused
    Unable to init server: Could not connect: Connection refused
    2016-09-26 02:44:54 [INFO] cnchi.py(225) setup_logging(): Sending Cnchi log messages to bugsnag server (using python-bugsnag).
    2016-09-26 02:44:54 [INFO] cnchi.py(283) check_gtk_version(): Using GTK v3.20.9
    2016-09-26 02:44:54 [INFO] cnchi.py(295) check_pyalpm_version(): Using pyalpm v0.8 as interface to libalpm v10.0.1
    2016-09-26 02:44:54 [DEBUG] cnchi.py(322) check_iso_version(): Running from ISO version 16.9
    Unable to init server: Could not connect: Connection refused
    
    (cnchi.py:1596): Gtk-WARNING **: cannot open display:
    
  • Hi,

    It seems you have found a bug. Try this:

    sudo -E /usr/share/cnchi/bin/cnchi -dv

    Something is wrong with pkexec.

  • For another data point I received the same authentication error with the 2016.09.25 version installer, even got the same output johnk46 got from running sudo -E /usr/bin/conch but was able to run the installer with no problems as far as I can tell when I ran your second command. Thanks.

  • [email protected]
    sudo -E /usr/share/cnchi/bin/cnchi -dv
    this worked for me.

    thanks

  • Hi all,

    Just to clarify this, we switched to pkexec because GTK+ does not allow to run the installer with uid 0 (root) anymore (and the installer needs system privileges, of course).

    If you still use sudo, you won’t be able to see the slide images while installing, but this is harmless.

    We’re working on it.

    Cheers!

  • @karasu said in Need Authentication for Installation:

    Hi,

    It seems you have found a bug. Try this:

    sudo -E /usr/share/cnchi/bin/cnchi -dv

    Something is wrong with pkexec.

    @karasu It also worked for me :thumbsup:

authentication9 installation214 Posts 8Views 2484
Log in to reply