MATE 1.16 packages are now available in antergos-staging. If anyone has time to test them it would be much appreciated. To test them all you have to do is add the staging repo before all other repos in your pacman.conf and then perform a system update like normal. Please let me know if you notice any issues. Thanks!

  • Test is completed. Mate 1.14.1 upgraded to 1.16.0. The main result is - nothing breaks. Everything continues to work.

    Repos order for the test:

    $ sudo pacman -Syy
    [sudo] password for just: *********
    :: Synchronizing package databases...
     antergos-staging          30.3 KiB  2.11M/s 00:00 [----------------------] 100%
     antergos                 127.4 KiB  3.36M/s 00:00 [----------------------] 100%
     core                     120.1 KiB  1381K/s 00:00 [----------------------] 100%
     extra                   1755.8 KiB  1929K/s 00:01 [----------------------] 100%
     community                  3.6 MiB  2.69M/s 00:01 [----------------------] 100%
     multilib                 172.6 KiB  2.41M/s 00:00 [----------------------] 100%
     netrunner                 14.0 KiB   259K/s 00:00 [----------------------] 100%
     apricity-core             13.9 KiB  0.00B/s 00:00 [----------------------] 100%
     apricity-core.sig        287.0   B  0.00B/s 00:00 [----------------------] 100%
     bluestar                  40.1 KiB   636K/s 00:00 [----------------------] 100%
     bluestar-plasma          829.0   B  0.00B/s 00:00 [----------------------] 100%

    The upgrade is smooth as silk:

    $ sudo pacman -Syyu
    :: Synchronizing package databases...
     antergos-staging      30.3 KiB  2.27M/s 00:00 [------------] 100%
     antergos             127.4 KiB  2.65M/s 00:00 [------------] 100%
     core                 120.1 KiB  1123K/s 00:00 [------------] 100%
     extra               1755.8 KiB  2.51M/s 00:01 [------------] 100%
     community              3.6 MiB  2.71M/s 00:01 [------------] 100%
     multilib             172.6 KiB  2.41M/s 00:00 [------------] 100%
     netrunner             14.0 KiB   264K/s 00:00 [------------] 100%
     apricity-core         13.9 KiB  0.00B/s 00:00 [------------] 100%
     apricity-core.sig    287.0   B  0.00B/s 00:00 [------------] 100%
     bluestar              40.1 KiB   598K/s 00:00 [------------] 100%
     bluestar-plasma      829.0   B  0.00B/s 00:00 [------------] 100%
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    warning: insufficient columns available for table display
    Packages (32) atril-1.16.0-1  caja-1.16.0-1  caja-extensions-common-1.16.0-1
                  caja-gksu-1.16.0-1  caja-open-terminal-1.16.0-1
                  engrampa-1.16.0-1  eom-1.16.0-1  libcups-2.2.0-3
                  libmatekbd-1.15.0-1  libmateweather-1.16.0-1  marco-1.16.0-1
                  mate-applets-1.16.0-1  mate-backgrounds-1.16.0-1
                  mate-control-center-1.16.0-1  mate-desktop-1.16.0-1
                  mate-icon-theme-1.16.0-1  mate-media-1.16.0-1
                  mate-menus-1.16.0-1  mate-notification-daemon-1.16.0-1
                  mate-panel-1.15.0-1  mate-polkit-1.16.0-1
                  mate-power-manager-1.16.0-1  mate-screensaver-1.16.0-1
                  mate-session-manager-1.16.0-1  mate-settings-daemon-1.16.0-1
                  mate-system-monitor-1.16.0-1  mate-terminal-1.16.0-1
                  mate-user-guide-1.16.0-1  mate-utils-1.16.0-1  mozo-1.16.0-1
                  webkit2gtk-2.14.0-1  xproto-7.0.31-1
    Total Download Size:   109.51 MiB
    Total Installed Size:  332.82 MiB
    Net Upgrade Size:        5.84 MiB
    :: Proceed with installation? [Y/n] Y
    :: Retrieving packages...
     atril-1.16.0-1-x86_64   1251.9 KiB  2.73M/s 00:00 [----------] 100%
     mate-desktop-1.16.0...   538.5 KiB  1022K/s 00:01 [----------] 100%
     caja-1.16.0-1-x86_64       2.9 MiB  2.29M/s 00:01 [----------] 100%
     caja-extensions-com...    91.4 KiB  1944K/s 00:00 [----------] 100%
     caja-gksu-1.16.0-1-...     8.2 KiB  0.00B/s 00:00 [----------] 100%
     caja-open-terminal-...    11.1 KiB  3.62M/s 00:00 [----------] 100%
     engrampa-1.16.0-1-x...  1044.2 KiB  2.45M/s 00:00 [----------] 100%
     eom-1.16.0-1-x86_64     1802.4 KiB  2.42M/s 00:01 [----------] 100%
     libmatekbd-1.15.0-1...   120.8 KiB  5.13M/s 00:00 [----------] 100%
     libmateweather-1.16...    13.9 MiB  2.35M/s 00:06 [----------] 100%
     webkit2gtk-2.14.0-1...    22.8 MiB  2.22M/s 00:10 [----------] 100%
     marco-1.16.0-1-x86_64    855.3 KiB  1511K/s 00:01 [----------] 100%
     mate-menus-1.16.0-1...   125.8 KiB   298K/s 00:00 [----------] 100%
     mate-panel-1.15.0-1...  1530.0 KiB  2.16M/s 00:01 [----------] 100%
     mate-applets-1.16.0...     6.4 MiB  2.20M/s 00:03 [----------] 100%
     mate-backgrounds-1....    19.9 MiB  2.19M/s 00:09 [----------] 100%
     mate-icon-theme-1.1...    11.1 MiB  2.55M/s 00:04 [----------] 100%
     mate-settings-daemo...   459.8 KiB  2.54M/s 00:00 [----------] 100%
     mate-control-center...  1102.3 KiB  2.41M/s 00:00 [----------] 100%
     mate-media-1.16.0-1...   217.7 KiB  2.66M/s 00:00 [----------] 100%
     mate-notification-d...    93.4 KiB  2.12M/s 00:00 [----------] 100%
     mate-polkit-1.16.0-...    80.9 KiB  2.93M/s 00:00 [----------] 100%
     mate-power-manager-...     2.7 MiB  2.21M/s 00:01 [----------] 100%
     mate-session-manage...   285.2 KiB  2.53M/s 00:00 [----------] 100%
     mate-screensaver-1....     4.4 MiB  2.41M/s 00:02 [----------] 100%
     mate-system-monitor...  1816.6 KiB  1566K/s 00:01 [----------] 100%
     mate-terminal-1.16....   938.4 KiB  2.12M/s 00:00 [----------] 100%
     mate-user-guide-1.1...     7.0 MiB  2.45M/s 00:03 [----------] 100%
     mate-utils-1.16.0-1...     5.7 MiB  2.36M/s 00:02 [----------] 100%
     mozo-1.16.0-1-any         97.5 KiB   365K/s 00:00 [----------] 100%
     libcups-2.2.0-3-x86_64   310.1 KiB  1574K/s 00:00 [----------] 100%
     xproto-7.0.31-1-any      143.5 KiB  2.80M/s 00:00 [----------] 100%
    (32/32) checking keys in keyring                   [----------] 100%
    (32/32) checking package integrity                 [----------] 100%
    (32/32) loading package files                      [----------] 100%
    (32/32) checking for file conflicts                [----------] 100%
    (32/32) checking available disk space              [----------] 100%
    :: Processing package changes...
    ( 1/32) upgrading libcups                          [----------] 100%
    ( 2/32) upgrading xproto                           [----------] 100%
    ( 3/32) upgrading atril                            [----------] 100%
    ( 4/32) upgrading mate-desktop                     [----------] 100%
    ( 5/32) upgrading caja                             [----------] 100%
    ( 6/32) upgrading caja-extensions-common           [----------] 100%
    ( 7/32) upgrading caja-gksu                        [----------] 100%
    ( 8/32) upgrading caja-open-terminal               [----------] 100%
    ( 9/32) upgrading engrampa                         [----------] 100%
    (10/32) upgrading eom                              [----------] 100%
    (11/32) upgrading libmatekbd                       [----------] 100%
    (12/32) upgrading libmateweather                   [----------] 100%
    (13/32) upgrading webkit2gtk                       [----------] 100%
    (14/32) upgrading marco                            [----------] 100%
    (15/32) upgrading mate-menus                       [----------] 100%
    (16/32) upgrading mate-panel                       [----------] 100%
    (17/32) upgrading mate-applets                     [----------] 100%
    (18/32) upgrading mate-backgrounds                 [----------] 100%
    (19/32) upgrading mate-icon-theme                  [----------] 100%
    (20/32) upgrading mate-settings-daemon             [----------] 100%
    (21/32) upgrading mate-control-center              [----------] 100%
    (22/32) upgrading mate-media                       [----------] 100%
    (23/32) upgrading mate-notification-daemon         [----------] 100%
    (24/32) upgrading mate-polkit                      [----------] 100%
    (25/32) upgrading mate-power-manager               [----------] 100%
    (26/32) upgrading mate-session-manager             [----------] 100%
    (27/32) upgrading mate-screensaver                 [----------] 100%
    (28/32) upgrading mate-system-monitor              [----------] 100%
    (29/32) upgrading mate-terminal                    [----------] 100%
    (30/32) upgrading mate-user-guide                  [----------] 100%
    (31/32) upgrading mate-utils                       [----------] 100%
    (32/32) upgrading mozo                             [----------] 100%
    :: Running post-transaction hooks...
    (1/4) Compiling GSettings XML schema files...
    (2/4) Updating icon theme caches...
    (3/4) Updating the desktop file MIME type cache...
    (4/4) Updating the MIME type database...

    Mate is upgraded to 1.16:

    $ mate-session --version
    mate-session 1.16.0

    Main problems, typical for Mate-1.14-Gtk3, remain:

    • mate-mint-menu is not visible and is not usable in the panel
    • window list applet is hidden in the panel until the first window is opened
    • graphically Mate-1.16-Gtk3 is as ugly as Mate-1.14-Gtk3, alien-oriented desktop:
      alt text

    Fortunately, with repos in Arch-style order ([antergos-staging] and [antergos] are below main Arch repos) the upgrade to 1.16 in Antergos will not break the existing Mate-1.14-Gtk2, even when 1.16 packages will arrive to the main, stable [antergos] repo:

    $ sudo pacman -Syyu
    :: Synchronizing package databases...
     core               120.1 KiB  1381K/s 00:00 [---------] 100%
     extra             1755.8 KiB  2.03M/s 00:01 [---------] 100%
     community            3.6 MiB  2.31M/s 00:02 [---------] 100%
     multilib           172.6 KiB  3.18M/s 00:00 [---------] 100%
     antergos-staging    30.3 KiB  2.11M/s 00:00 [---------] 100%
     antergos           127.4 KiB  3.36M/s 00:00 [---------] 100%
     netrunner           14.0 KiB   279K/s 00:00 [---------] 100%
     apricity-core       13.9 KiB  0.00B/s 00:00 [---------] 100%
     apricity-core.sig  287.0   B  0.00B/s 00:00 [---------] 100%
     bluestar            40.1 KiB   703K/s 00:00 [---------] 100%
     bluestar-plasma    829.0   B  0.00B/s 00:00 [---------] 100%
    :: Starting full system upgrade...
     there is nothing to do

    Mate-1.14-Gtk2 still keeps some sanity:

    • mate-mint-menu works
    • window list applet is always visible, even without opened windows
    • graphically it remains to be a regular, human-oriented desktop:
      alt text

    These are only first impressions about Mate-1.16.0-Gtk3 from [antergos-staging]. Will keep it for few days, ready to run any other, more specific tests, if they will be needed or requested.


  • hi, i just installed MATE 1.16 and now i can’t login anymore, it seems the login screen doesn’t recognize the keyboard. I can’t login gnome, awsome, mate etc, i mean i can’t write anything. I installed Antergos with Mate Standard desktop. How can i fix it now? Can i install gdm through the live cd?

    I’m writing from Debian

    OBS: I fixed following some internet tutorial (these commands were new to me)
    If you have the same problem, use your live cd, open terminal, tap “su”
    mount your partition (in my case is sda6) with this commands:

    sudo mkdir /mnt/linux
    sudo mount -t ext4 /dev/sda6 /mnt/linux

    To install on your partition through live cd:

    sudo chroot /mnt/linux

    Install gnome login interface:
    sudo pacman -S gdm
    sudo systemctl -f enable gdm

    restar your pc and is ready

  • @fernandomaroto said in TESTERS NEEDED: MATE 1.16:

    hi, i just installed MATE 1.16 and now i can’t login anymore, it seems the login screen doesn’t recognize the keyboard. I can’t login gnome, awsome, mate etc, i mean i can’t write anything…

    Confirm that. I always use autologin, so didn’t discover immediately this issue. Found a workaround for it. Without installing GDM.

    Doing countless logouts-logins while searching for a workaround, I encountered another issue. “Notification Area” applet sometimes loads in the panel, sometimes not. If not, the user needs to click “Reload” button in the Error window to get it loaded for the current and subsequent sessions. For this issue didn’t find a workaround.

    Two issues found:

    1. LightDM doesn’t accept user input by default
    2. Notification Area applet is not always loaded automatically in the panel

    The workaround for LightDM.

    I’m not able to get a screenshot of the login screen. Will try to draw it in text mode:

    [password] [enter] [v]
                       [debug log]


    Initially the Login screen presents the clock. Once it is clicked, it gets substituted with the [user]. Once the [user] is clicked, the [password] field opens below it. This field has two blue buttons on the right: [enter] and [down arrow, v].

    The [down arrow, v] opens the submenu with three options:
    [debug log]

    Finally, in the top right corner of the login screen there’s the [backgrounds] icon, with three horizontal lines. It allows to choose a backgrounds for the login screen.


    Login window presents for the 1st time.

    There’s the clock in it. The clock is clicked, the [user] presents. The [user] is clicked, the [password] [enter] [v] field appears below the [user]. The [password] field doesn’t accept user’s input.

    I’m about to say the things that will sound crazy. But they work. Try to believe. I’m not crazy. At least, yet :) .

    With the mouse drag and drop any graphical object (icon) you see on the screen onto the [password] editbox. For example, drag and drop onto it the [backgrounds] icon from the top right corner on the login screen.

    The [password] field will be filled in with asterisks. They will be all selected.

    There’s no way to cancel them with Delete or Backspace keys. The only way to eliminate them is;

    1. click on the [down arrow, v] icon on the right of the [password] field
    2. dropdown menu opens
    3. select the second, the [reset] option from it

    The whole login screen will be reset.

    Login window presents for the 2nd time.

    Repeat the login sequence. Click the clock. Click the [user]. The [password] [enter] [v] field appears below the [user]. The [password] field still doesn’t accept any input.

    Again, drag and drop into the [password] field the [backgrounds] icon…

    The miracle! It is now possible to delete all asterisks that fills in the [password] with the keyboard! The [password] field accepts keyboard’s input now.

    Type in your password, hit Enter, and you’ll be logged into Mate-1.16-Gtk3.


    This is a LightDM issue. Doubt it is related to Mate 1.16 - with autologin this problem is not present. But it will be present if the user will need to restart X without rebooting the computer.

    No need to install GDM. But LightDM needs to be fixed.

    Enough for today. G’night all.

  • hahaha, thanks for your efforts.
    Yes, i want to add something not related directly with Mate 1.16:

    I i just wanted to help the development, and i think somehow i did it :p

  • Ouch! Mate just got an upgrade to 1.16 in Arch. Fortunately, they don’t force people to use Gtk3. So right now there’s still usable Mate-1.16.0-Gtk2 in Antergos-Mate with [antergos] at the bottom of repos list.

    mate-mint-menu works, window list and notification area applets work, logout-login works, there are no huge emblems on items in caja, everything looks dandy.

  • Just upgraded this morning, and have been fiddling with the DE the whole day. As I was using Mate 1.14 GTK3 already, Mate has been upgraded to the 1.16 GTK3 version. Everything looks and works perfect. Unfortunately, not all applications are GTK3 ready (yet).

  • Even though Mate (Martin Wimpress?) ports the whole DE to Gtk3, Arch keeps in [community] both Gtk2 and Gtk3 versions. At least, for now. Wise decision. The users of each branch may go ahead and avoid radical changes.

    I wonder, for how long Arch will maintain Mate-Gtk2 once Mate will be fully migrated to Gtk3? Not for too long, I guess.

  • how can i switch the mate from staging to the GTK3 from repository?

  • @fernandomaroto If you use the default Antergos repos order, with [antergos] at highest priority, you already have Mate-Gtk3. Moreover, Mate 1.16 has been moved from [antergos-staging] to [antergos]. You may comment out (disable) [antergos-staging] and run a regular upgrade. You’ll get default Antergos Mate-1.16-Gtk3.

  • @just well, I tried today uninstall the current and install the gtk3 but i was getting signature errors, at the end even the gtk2 was getting errors for reinstall… Now i managed to reinstall mate 1.16 and the gtk3 are not installed acordding to add/remove packages look:

    I thought there was an easy way to switch, i’ll have to unistall mate again and reinstall gtk3?

  • Finally managed to reinstall, i had to remove all the mate verisions i had (1.14 and 1.16 gtk2) from the pacman cache.
    Then removing the mate with package manager and reinstall through terminal… jajaja (i don’t know why there was signature problems, some conflict between all the versions maybe)
    I’m sorry i’m posting too much on forums, i’ll stop doing that.

  • @fernandomaroto said in TESTERS NEEDED: MATE 1.16:

    …I’m sorry i’m posting too much on forums, i’ll stop doing that.

    There’s no any limit to number of posts in the forum. Post as much as you need.

    Just follow the thread’s subject, as strictly as possible.

    This topic was about helping devs to test a new Mate version. Not about helping you to switch to another version.

    If a question you’re interested in is not being discussed yet, simply start a new topic.

    And please, be more specific describing a problem. Post the commands you’ve entered in teminal, along with the output. A generic statement “I tried this and that but it doesn’t work” doesn’t help us to help you :) .

  • Mate 1.16 upgraded two days ago, no mess, pure pleasure.

  • Nice! I like the extra layer of security. Now anyone who logs into my computer also needs to know the secret drag and drop sequence to get in! 😆

  • Hi, well the volume bar changed from 1.14 to 1.16, it’s darker now, wich is a little harder to see the contrast between the actual volume against the total bar. (this is available using a keyboard shortcut) It’s a little detail but the old one was better.

  • @fernandomaroto
    jajaja means kiss my prolonged back in my native language, just fyi

  • I didn’t understand very well because of my poor english :)
    But if you mean kiss: keep it simple silly i agree with you. jajajaja
    But the old volume bar was better indeed, the new one is darker and harder to see.

  • No, let me explain this using spanish words, “JaJaJa” in german means " ¡Que te den por culo! ".
    It might not be a good idea to use this in an international community where german speaking people participate.

  • @Jeannie
    Jajaja is not an official word in German. Maybe some slang, but surely does not have the same meaning as the Spanish translation you gave. Ja means yes, so jajaja would translate to yeah/yea/yeah, or used when being annoyed: ‘Get off my back’ or ‘leave me alone’.
    Jajaja expresses laughter in Spanish since the J is pronounced closely to h in English… But the whole is off topic anyways. :p

mate69 needed12 testers6 1.162 Posts 22Views 8812
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.