• AMD Catalyst GPU with 0% load


    I’ve recently installed Antergos on my laptop.

    I’ve installed Vi0L0’s AMD Catalyst drivers by following the Arch Wiki, but I think my gpu isn’t running at all.

    When I run fgl_glxgears -info, i get the following output:

    Using GLX_SGIX_pbuffer
    GL_RENDERER   = AMD Radeon R9 M200X Series 
    GL_VERSION    = 4.5.13399 Compatibility Profile Context 15.201.1151
    GL_VENDOR     = ATI Technologies Inc.

    (full fgl_glxgears log here)

    But even when I’m running steam games, the framerate is low and my GPU load is 0% on aticonfig --od-getclocks:

    Default Adapter - AMD Radeon R9 M200X Series 
                                Core (MHz)    Memory (MHz)
               Current Clocks :    775           1125
                 Current Peak :    775           1125
      Configurable Peak Range : [775-850]     [1125-1250]
                     GPU load :    0%

    Can anyone help me figure out what is missing? This is my xorg.conf file after running aticonfig --initial=dual-head --screen-layout=left.

    Addtional info:
    1 - My video card is an AMD 8770M, my laptop has integrated Intel graphics, I’m using dual screens.

    2 - output from sudo pxp_switch_catalyst amd:

    Switching xorg.conf ...
    /etc/X11/xorg.conf.cat linked to /etc/X11/xorg.conf
    Running aticonfig --px-dgpu ...
    PowerXpress info: Diagnostic output from /usr/lib64/fglrx/switchlibglx:
    Switch to AMD
    PowerXpress info: Diagnostic output from /usr/lib64/fglrx/switchlibGL:
    Switch to AMD
    PowerXpress: Discrete GPU is selected (High-Performance mode), please restart Xserver(s) for changes to take effect!
    Running /usr/lib/fglrx/switchlibGL amd ...
    Switch to AMD
    Running /usr/lib/fglrx/switchlibglx amd ...
    Switch to AMD
    Checking /etc/modules-load.d/catalyst.conf for fglrx ...
    Switched to Catalyst

    3 - when I run startx:

    [  1608.532] (EE) fglrx(0): The graphics processor is already set to console mode, set X mode fail. Cannot start X.
    [  1608.532] (EE) fglrx(0): PreInit failed
    [  1608.532] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
    [  1608.532] (II) fglrx(1): === [xdl_xs117_atiddxPreInit] === begin
    [  1608.532] (II) fglrx(1): FB driver is not enabled
    [  1608.533] (WW) fglrx(1): Quitting screen -- more screens specified than supported by current Adaptor.
    [  1608.533] (II) fglrx(1): === [xdl_xs117_atiddxPreInit] === end
    [  1608.533] (II) UnloadModule: "fglrx"
    [  1608.533] (II) UnloadSubModule: "fglrxdrm"
    [  1608.533] (II) Unloading fglrxdrm
    [  1608.533] (II) UnloadSubModule: "fglrxdrm"
    [  1608.533] (II) UnloadModule: "fglrx"
    [  1608.533] (II) UnloadSubModule: "fglrxdrm"
    [  1608.533] (EE) Screen(s) found, but none have a usable configuration.
    [  1608.533] (EE) 
    Fatal server error:
    [  1608.533] (EE) no screens found(EE)


  • Hi,

    I do not own an AMD card (or a intel+amd combo like yours), but I hope this helps you:



  • @karasu Solved. Thank you!

  • @aosmurasame , will you please share the way you solved it? For future reference to help others with the same problem…

amd36 xorg29 catalyst8 Posts 4Views 1224
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.