• Like 0

    Wireless is disabled by hardware switch error


    Hi everyone, i’d really appreciate some help. That is my problem: i do not have access to the internet after i install Antergos.
    -When i play the live usb i have no problem whatsoever with the wifi
    -The first time that i use Antergos, the wifi works, when i shut down and then restart, I get this problem and it’s permanent.

  • Like 0

    Can’t understand it. Every time you enable Wi-Fi with the hardware switch it is disabled again upon Antergos shutdown? Never heard about something similar.

  • Like 0

    @just
    I don’t think i was clear enough. Upon finishing the installation, the live usb ask you to restart the system to take you to the OS. Here’s the point, when i enter into the OS for the first time ever, the wifi works, but it stops forever after the first time that i turn off the pc and turn it back on. Once i turn off the computer once, the wifi is forever disabled. i can restart the system how many times i want, but the wifi won’t work.

    When i hover over the connection icon, i read: “Wireless is disabled by hardware switch”. At that point i can’t do anything. Pressing the turn on/off button does nothing.

  • Like 0

    Ok, that was and is clear. I’m asking about another thing. When you boot Antergos the 2nd, 3rd, Nth time and enable Wi-Fi with the hardware switch (in the topic’s title), is Wi-Fi disabled again upon the shutdown? So you must re-enable it again on the next boot?

  • Like 0

    @just
    No, i don’t do anything. I presume that with hardware switch you mean the Fn+f3 buttons (at least for my pc).
    In any case i do don’t anything. i can never turn it on: when i boot antergos for the Nth time, i never have access to the internet; my wifi never works (it works perfectly fine with windows 10 though, i have dual boot now), even though i press the Fn+f3 button to turn it on, but it stays disabled.

  • Like 0

    @Agitecr
    Well… i didn’t expect this: now that i have dual boot (i literally just managed to have them both) i restarted the computer and the wifi is still on… either the computer is messing with me, or i don’t know what to think. Earlier before i tried to install mint, but that time i had no wifi even in the live usb. I bet that as soon as i delete windows 10 the problem will come back.

  • Like 0

    @Agitecr said in Wireless is disabled by hardware switch error:

    …even though i press the Fn+f3 button to turn it on, but it stays disabled.

    Assuming you’re doing it in Antergos, I have no idea what happens. Fn+F3 should enable Wi-Fi inside Antergos.

    What network card do you have? Is it Broadcom, known for its bad behaviour in Linux?

  • Like 0

    @just
    Yeah i did that inside antergos.

    I’m not sure, but i think it is from Realtek.

    Just for your information, my CPU is AMD A8, if it helps.

  • Like 0

    @Agitecr
    I have to correct myself. Now after a couple of reboots, the wifi stopped working.

  • Like 0

    I had a similar issue.

    On my laptop I had to download the correct driver (broadcom-wl) to get 5ghz, then 'modprobe, wl to get wi-fi up. Once I commented out the unused driver in blacklist-broadcom.conf, wifi would be retained after a reboot.

  • Like 0

    Hi, I had the same problem with my laptop. I may be able to help you. On mine I have to set a module parameter or it says it is disabled by hardware switch. I also have an Elantech touchpad I see in another post you are having trouble with. Let me know the make and model of your laptop and your desktop environment and i’ll see if I can help.

    Antergos x86_64 running Gnome
    Intel i7-6500U Skylake 8GB DDR 3L
    Nvidia 940M Graphics.
    500GB Samsung EVO SSD
    Asus K501UB

  • Like 0

    @Paul-Mac
    Thank you, i’d really appreciate some help.
    The Notebook is an Acer Aspire ES1 521; I’m running Xfce

  • Like 0

    According to Acer Aspire ES1-521 Manual ,sometimes your Wi-Fi configuration profile might be corrupted, and that can cause Problem with wireless adapter or access point and many other errors to appear. To fix this issue, users are suggesting to use the option to forget the network, or to delete the wireless profile. To delete the wireless profile, read guidelines from manual.

  • Like 0

    may device get “Soft blocked” this can be resolved with:

    sudo rfkill list
    

    give you a numbered list of devices [0-x]

    sudo rfkill unblock [n]
    

    n = number from list above

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

wireless20 error129 disabled2 switch7 Posts 14Views 622
Log in to reply