• Problem with installation


    Ok, i’m gonna start by saying that i do not know much about programming and stuff… actually i know nothing!
    Anyway, i’m here because i’m unhappy with windows 10, so i thought i’d give Antergos (Archlinux) a try (DUAL BOOT). I followed the guide to install it and after a LOT of time i thought i managed to install it. But i don’t get the chance to choose the OS on startup.

    Sorry for the few info… apparently there is a limit on this site. Ask anything and i will answer!

  • Now, i’m not a complete newcomer, i used Ubuntu on and off for quite some time; i had NO problem whatsoever installing it (on 2 machines) BUT i am having a LOT of problems installing Antergos. I downloaded the ISO, burned it on my USB, restarted my computer (yeah, i already disabled the fast startup) entered the bios and… i couldn’t disable the secure boot… whatever, after a couple of hours trying to find a solution, i decided to change the UEFI (which i have no idea what it is) to Legacy (No idea either) and i kinda made it to change the boot priority.

  • Long story short…i can’t pick my OS on startup!

    1. What machine is it? If it is dual boot you might want to change it back from Legacy and changing the boot order should not make a difference on the dual boot.

    2. What OS is started now - Antergos or Windows.

    3. What did you do when it came to choosing the hard drive and partitioning during installing?

    Your problem should not be too difficult to solve if we understand the detail

  • @simonsaysthis

    1. It’s an Acer. Currently i only have installed Windows 10. I switched the Secure boot from UEFI to Legacy just to install Antergos, otherwise my computer said: SECURE BOOT ERROR.
      Now i switched it back to UEFI and basically i restored all the default settings.
      I changed the boot order only for the purpose of starting the USB before Windows.
  • Can you give me the exact model of the laptop. On Acer there should be an F12 boot menu. So when it starts up try keeping F12 pressed to enter this menu. If you see Antergos in this menu then it is installed correctly. This is separate from the dual boot menu which Linux installs (Grub). Like I asked earlier what option did you chose for the hard disk when you installed Antergos?

  • @simonsaysthis

    1. Right now i’m using Windows as i can’t get to Antergos

    2. Well, i have a 1Tb HDD, so, before i ran the USB, i split my HDD in 2.
      Then when it came the part of chosing where to install, i selected the partitioned disc:
      -Used 20Gb for the Root (/)
      -Used 4Gb as Swap (no idea what that is, i just followed the guide) as i have 8Gb RAM
      -Used the remaining 4550 rough Gb as Directory (/Home)

  • @simonsaysthis

    Acer ES1 521 834C

    Anyway, i already enabled the F12 option, but with the UEFI on, it always tells me the same thing: “Secure boot error”.
    As for your last question, i replied above: i have to wait 300 secs before replies.

    Anyway, i checked the partitons and Windows says they are empty. Now i erased them and put the disc back together.

  • So secure boot needs to be disabled. I have UEFI on normal and I can access the F12 menu with no problem…and you need to make sure that you tell Antergos where to install the bootloaded.

    So you need to also select the EFI partition and it needs to be mounted as /boot/efi

    my guess is it wasnt installed properly. It is more common that Windows doesnt boot anymore than the other way round. If Linux is still completely new to you, Ubuntu does everything for you and usually sets the dual boot up correctly by default. I really recommend trying Ubuntu or Mint first and then once you comfortable you come back to Antergos which is much nicer :)

  • I was at the same place as you - new laptop but hated Windows 10 and was tired of the old Windows 7. I now only have linux on my laptop and there is nothing I am missing. Well Linux now even has a new Skype version which is almost in final stage. Libreoffice is brilliant for Home use so I couldn’t be happier.

  • @simonsaysthis

    Oh, my bad, i did mount the efi partition, like the guide said. I am familiar with Ubuntu, i have been using it on and off for a while now (mostly off, it didn’t run very well with my last machine). And it all went smoothly with ubuntu, all the times i installed it.
    Maybe i got rusty or maybe i don’t know, but i feel like formatting and installing Antergos will be the only choice if i really want it…

  • I agree. I got so tired of dual boot issues so I made a “life choice” so to say

  • wine is also a great option if you missing some windows apps.

  • Well, i have win 10 and Antergos in dual boot, and both worked fine (Debian ruined my dual boot when i installed it, reinstalling Antergos fixed everything and now i have win 10, Antegos and Debian. I never had to change UEFI sets. One problem i saw is that i had to install Antergos on pendrive using the program “Rufus”, it downloaded some missing file for the proper pendrive’s boot.
    I Allways test distros on virtual box first (win10).
    I also hated win 10 and decided to migrate to Gnu/Linux hehehe.
    I cannot use ubuntu nor ubuntu based distros, they doens’t work on AMD drivers well, only changing the graphics to nomodeset, but then its impossible to change monitor resolution (forcing resolution doens’t work too). Anyway i’m very happy that in my tests i encoutered Antergos :p

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

nochoicestartup1 probleminstall1 Posts 14Views 823
Log in to reply