• Cnchi TESTING {the Antergos Graphical Installer}


    That’s probably caused by dbus crashing which can only be solved by a reboot.

  • All the issues I had were from a ‘bad’ download. I burned a new iso and everything worked! Great job everyone!

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • All the issues I had were from a ‘bad’ download.

    Nice everything worked out.

    Cheers!

  • ok apparently my drives are fucked up according to cnchi?

    first it talks about a check on sda so i searched my windows install but i could not find any scheduled checks?

      
    Volume is scheduled for check.  
    Please boot into Windows TWICE, or use the 'force' option.  
    NOTE: If you had not scheduled check and last time accessed this volume  
    using ntfsmount and shutdown system properly, then init scripts in your  
    distribution are broken. Please report to your distribution developers  
    (NOT to us!) that init scripts kill ntfsmount or mount.ntfs-fuse during  
    shutdown instead of proper umount.  
    [2014-03-07 12:20:31] [used\_space.py] ERROR: Can't detect used space of NTFS partition /dev/sda1  
    [2014-03-07 12:20:31] [used\_space.py] ERROR: Command '['ntfsinfo', '-m', '/dev/sda1']' returned non-zero exit status 1  
    
    

    it was on a different drive so after that i try to partiton my sdb drive but i get

      
    [2014-03-07 12:22:48] [advanced.py] DEBUG: Creating a primary partition  
    [2014-03-07 12:23:07] [advanced.py] DEBUG: Creating a primary partition  
    [2014-03-07 12:24:06] [advanced.py] DEBUG: In get\_changes(), added to changelist: path[/dev/sdb1] createme[Yes] relabel[No] fmt[Yes] mnt[/boot]  
    [2014-03-07 12:24:06] [advanced.py] DEBUG: In get\_changes(), added to changelist: path[/dev/sdb2] createme[Yes] relabel[No] fmt[Yes] mnt[/]  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/cnchi.py", line 333, in on\_forward\_button\_clicked  
    stored = self.current\_page.store\_values()  
    File "/usr/share/cnchi/src/installation/advanced.py", line 1681, in store\_values  
    self.create\_staged\_partitions()  
    File "/usr/share/cnchi/src/installation/advanced.py", line 1711, in create\_staged\_partitions  
    pm.finalize\_changes(disk)  
    File "/usr/share/cnchi/src/canonical/misc.py", line 163, in helper  
    return func(\*args, \*\*kwargs)  
    File "/usr/share/cnchi/src/parted3/partition\_module.py", line 333, in finalize\_changes  
    diskob.commit()  
    File "/usr/lib/python3.3/site-packages/parted/decorators.py", line 41, in new  
    ret = fn(\*args, \*\*kwds)  
    File "/usr/lib/python3.3/site-packages/parted/disk.py", line 218, in commit  
    return self.\_\_disk.commit()  
    \_ped.IOException: Partition(s) 2 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.  
    
    

    after that cnchi stopped and i rebooted to windows to check again. i even turned of regular maintenance
    but now i get

      
    [2014-03-07 12:59:08] [partition\_module.py] WARNING: Unrecognised disk label in device /dev/sdb.  
      
    i tried to partition sdb here  
    [2014-03-07 12:59:08] [fs\_module.py] WARNING: Command '['blkid', '-o', 'value', '-s', 'TYPE', '/dev/sdb1']' returned non-zero exit status 2  
    
    

    i will look for errors from windows but i thought i just put this here just in case.

  • Well, sure seems like you had one hell of a night (or day)
    Let’s see… where to begin… where… to… begin…

    @“Fpsgamer101”:3aqo2abr said:

    first it talks about a check on sda so i searched my windows install but i could not find any scheduled checks?[/quote:3aqo2abr]Try running scandisk on that drive in Windows to see if it finds any errors. Are you using the latest ISO? It’s possible this is a kernel bug so it can’t hurt to update the live system:

    sudo pacman -Syyu
    

    @“Fpsgamer101”:3aqo2abr said:

    it was on a different drive so after that i try to partition my sdb drive but i get[/quote:3aqo2abr]This isn’t anything to worry about (its a known issue in the linux kernel that is solved solved by a reboot–which doesn’t help on a livecd obviously) Try using GParted to partition /dev/sdb before restarting Cnchi. If it fails, post the output of:

    sudo fdisk -l
    

    Hang in there

  • well this does not look good…

    first i did the update.(no problems YET)

    but when i openn up gparted or when i try to create a new partition table on sdb i get

      
    The backup GPT table is corrupt, but the primary appears OK, so that will be used.  
      
    
    

    EDIT: well i went and used gdisk on my windows drive which gave an error about the protective mbr to be oversized and that it would auto fix it so i wrote the changes to disk and now the error is gone(i will verify if cnchi calmed down to later)
    EDIT2:
    yep issue was on my side. atleast its not another bug for you guys to worry about

  • install using March 16 testing cnchi 5.22 64bit went fine- up and running on my 6510b compaq laptop
    lightdm- where is the button to change desktop? I installed gdm to use gnome’s lock screen. Is there a way to make the installer use gdm?

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • Is there a way to make the installer use gdm?

    Hi,

    No, there isn’t one. We want to use just one login manager for all desktops, so we setup lightDM.

    We could add an advanced feature to allow this, but it’s not in our TODO list atm.

    Cheers!

  • Got a new laptop which needs to use UEFI, trying latest testing release and tried last nights updated cnchi “testing.sh”. I have to use “nomodeset” parameter to get the greeter otherwise its just a black screen.

    After the script downloaded everything it ended with “starting cnchi…” but nothing happened. Just exits to command prompt.

    I started cnchi manually from activities drop down, version shows 0.5.24 on screen. Used the CLI installer. The status window for downloading packages was messed up with text spilling outside the window borders and not scrolling properly. There really was no scrolling, it was just placing text on top of previous text in a somewhat random way. It appears to be mainly “sucess” and “verification” messages… but …

    Ended up with a “Package Installation Failed” with just an OK button. Clicking that repeats the process. This seems to be all it does. Had to manually kill cnchi, the script did not provide a way to exit out gracefully.

    In addition, I can’t reboot using Antergos USB. it errors out on booting with /run/archiso/bootmnt/arch/aitab file does not exist error message.

    I have to manually removed the failed install partition on the HDD before I can boot from the USB stick again.

  • Hi,

    The CLI installer is not actually a part of Cnchi. It was used before Cnchi existed and we’ve kept it available for those who like to use it. However, it’s code development does not follow Cnchi’s testing branch. It follows the master branch (official releases) so it should not be used from the testing iso. This is an issue we had not considered so I appreciate you bringing it to our attention. We will discuss how to make this more obvious (or likely disable the CLI on testing iso).

    @“reefland”:ofinn9uw said:

    After the script downloaded everything it ended with “starting cnchi…” but nothing happened. Just exits to command prompt.[/quote:ofinn9uw]Did you launch the script without any extra arguments? (For example, it should not be launch with -dv or any other option for that matter)

    @“reefland”:ofinn9uw said:

    In addition, I can’t reboot using Antergos USB. it errors out on booting with /run/archiso/bootmnt/arch/aitab file does not exist error message.[/quote:ofinn9uw]What method did you use to create the USB? Check our wiki for the recommended methods.

    Sorry you had all that trouble because of the CLI installer. Give the real Cnchi a try and I’m sure it will go smoothly. Let us know if you run into any issues.

    Best Regards,

  • @“lots.0.logs”:thgmit55 said:

    The CLI installer is not actually a part of Cnchi. It was used before Cnchi existed and we’ve kept it available for those who like to use it. However, it’s code development does not follow Cnchi’s testing branch. It follows the master branch (official releases) so it should not be used from the testing iso. This is an issue we had not considered so I appreciate you bringing it to our attention. We will discuss how to make this more obvious (or likely disable the CLI on testing iso).
    [/quote:thgmit55]
    Oh good to know. I read that you have to use the CLI for UEFI support. I guess I miss understood the purpose of this thread, I assume this threads means the graphical installer now supports UEFI. I’ll try that next.

    @“lots.0.logs”:thgmit55 said:

    Did you launch the script without any extra arguments? (For example, it should not be launch with -dv or any other option for that matter)[/quote:thgmit55]
    No. I didn’t see any extra arguments in the instructions. Only used “sudo -E ./testing.sh”.

    @“lots.0.logs”:thgmit55 said:

    What method did you use to create the USB? Check our wiki for the recommended methods.[/quote:thgmit55]
    I used dd to create the USB.

    @“lots.0.logs”:thgmit55 said:

    Sorry you had all that trouble because of the CLI installer. Give the real Cnchi a try and I’m sure it will go smoothly. Let us know if you run into any issues.[/quote:thgmit55].
    Will do… I’ll purge out the existing install to be able to boot the USB. I’ll grab the latest testing script and this time use the graphical installation. Thanks.

  • Just finished again… smooth installation. However, on reboot, it is not listed in the preexisting GRUB 2 menu. I have an existing GRUB 2.02 menu that Ubuntu installed and it correctly loads Ubuntu 14.04 and Windows 8.1 (both using UEFI). I didn’t notice anything in the updated cnchi that it detected UEFI.

    Even when I goto the UEFI boot options menu (nvram?) it lists ubuntu, Windows 8.1, SATA HDD, Network Boot.

    I created the USB (based on March 16th testing) with dd and the USB is not listed on boot screen unless I enable Legacy support. I created ubuntu USB using dd and it shows up on UEFI boot screen (without legacy enabled), should the Antergos USB do the same?

    Anyway, here are the steps I did:

    1. Boot USB.
    2. Close cnchi (0.5.22)
    3. In terminal, get new testing.sh.
    4. Ran testing.sh with no additional parameters.
    5. At end of script cnchi does not start automatically. It ends at a command prompt after:

    “Switched to a new brach ‘testing’.
    Starting Cnchi…”

    1. I manually start Cnchi from Activities, now shows 0.5.24.
    2. Graphical installer, select Cinnamon and select all featured selections.
    3. Select Advanced Install type and use the following partitions:

    /dev/sda2 as /boot (UEFI location) - FYI - ubuntu references this as /boot/uefi.
    /dev/sda8 as /swap
    /dev/sda10 as / (420GB partition) - select option to format it.

    1. Click “Install Now!”, comfirmed partition layout, wait a few minutes for files to download.
    2. Installation completed message appears. Click “Yes” to restart.

    Does not show up on existing GRUB 2.02 menu.

    Before I try to manually add the installtion via GRUB repair tools, anything you want me to try first? I can access the partition from the ubuntu side and get any log files if it would be helpful.

  • Hi,

    Thanks for testing. I corrected the issue with the script not launching cnchi. Could you attach the install log. You can find it at “/var/log/cnchi.log”. (You will need to compress it in order to attach it here). Did the partion screen indicate that “EFI (/boot)” was required? If not then you may not be in UEFI mode. If it did then it seems that the loader is not being recognized. Can you check /boot/EFI/ and see if the directory /antergos_grub exists? Thanks.

    Cheers!

  • @“lots.0.logs”:31wb2h1z said:

    Hi,

    Thanks for testing. I corrected the issue with the script not launching cnchi. Could you attach the install log. You can find it at “/var/log/cnchi.log”. (You will need to compress it in order to attach it here). Did the partion screen indicate that “EFI (/boot)” was required? If not then you may not be in UEFI mode. If it did then it seems that the loader is not being recognized. Can you check /boot/EFI/ and see if the directory /antergos_grub exists? Thanks.[/quote:31wb2h1z]

    I agree, I don’t think its in UEFI mode. I shouldn’t have to enable Legacy Support, but I do otherwise it does not see the USB key (again, I did not have to do that for the ubuntu USB). I did not get a message that EFI was required. I got a message that “/” was required. I defined that first and did not get any additional messages. I manually selected swap and EFI partition.

    As to the directory, it does have something but not with todays date and not with the name you suggested. Antergos is the only Arch I use. Looks like it was created yesterday when I was trying testing. This is as seen by the ubuntu:

    [email protected]:/boot/efi/EFI$ ls -l  
    > total 16  
    > drwxr-xr-x 2 root root 4096 Mar 17 12:27 arch\_grub  
    > drwxr-xr-x 2 root root 4096 Mar 17 12:27 Boot  
    > drwxr-xr-x 3 root root 4096 Jan 15 02:37 Microsoft  
    > drwxr-xr-x 2 root root 4096 Mar 17 09:11 ubuntu
    
  • Yeah you weren’t in UEFI mode (legacy=BIOS mode). Try formatting your USB drive before using dd to write the image. Also dont use partition numbers when you use dd (should be sdb not sdb1). I dont have any UEFI systems to test locally but the USB works on my VM with UEFI enabled (although it’s not really the same thing) Thanks for the troubleshooting!

    Best Regards,
    Dustin

  • @“lots.0.logs”:2x98q87x said:

    Yeah you weren’t in UEFI mode (legacy=BIOS mode). Try formatting your USB drive before using dd to write the image. Also dont use partition numbers when you use dd (should be sdb not sdb1). I dont have any UEFI systems to test locally but the USB works on my VM with UEFI enabled (although it’s not really the same thing) Thanks for the troubleshooting!
    [/quote:2x98q87x]
    Sure I can try this tonight. I’ll reformat the USB to FAT32, then use dd to create the new USB. This is the command from my history that I used to create the USB:

    sudo dd if=antergos-2014.03.16-x86\_64.iso of=/dev/sdd
    

    I’ll use the same source. I’ll disable legacy boot support and see if the USB key shows up on the UEFI boot menu. If it doesn’t I assume there is no use going further as I won’t be in UEFI mode.

    Let me know if you need me to try something different.

  • reefland: I’m at exactly same point as you. My Lenovo Y580 doesn’t show up usb key on the UEFI boot menu (only legacy mode). Is there any special method to create EFI live usb? It is really easy to made UEFI WIN7 usb but in linux it’s tricky

  • @“matt_max”:3pg5v9di said:

    reefland: I’m at exactly same point as you. My Lenovo Y580 doesn’t show up usb key on the UEFI boot menu (only legacy mode). Is there any special method to create EFI live usb? It is really easy to made UEFI WIN7 usb but in linux it’s tricky
    As far as I can tell there is nothing special. Even the Arch Wiki shows one “dd” command being used to make a USB that will work with UEFI or Legacy. The only thing I didn’t do was format the drive prior to using “dd” which Dustin and the Arch Wiki recommend doing. My USB had a previous image on it. I’ll try that tonight. I hope it is that simple – if that doesn’t work then I hope Dustin has some more ideas.

    I’m testing on a Lenovo Y510P a model with Dual 2GB GeForce 755M in SLI and Intel HD graphics. I thought this Optimus configuration would be the hard part, not the UEFI. I’m sure we’ll get it all working. I have great confidence in the guys behind Antergos.

  • @“lots.0.logs”:3ovlj52o said:

    Yeah you weren’t in UEFI mode (legacy=BIOS mode). Try formatting your USB drive before using dd to write the image. Also dont use partition numbers when you use dd (should be sdb not sdb1). I dont have any UEFI systems to test locally but the USB works on my VM with UEFI enabled (although it’s not really the same thing) Thanks for the troubleshooting!
    [/quote:3ovlj52o]
    No good. Went to BIOS Setup, Confirmed that Boot Mode: UEFI, USB Boot: Enabled, Secure Boot: Disabled.

    No Legacy enabled.

    Using Gparted (I assume this OK to use).

    USB Test #1: Created partition table: msdos, Created partition and formatted to FAT32. Used dd method to create USB. – Does not show up on UEFI boot menu.

    USB Test #2: Created partition table: gpt. Created partition and formatted to FAT32. Used dd method to create USB. – Does not show up on UEFI boot menu.

  • I don’t know what makes a USB show up in the UEFI menu, but I’m thinking it has to be something inside the ISO.

    Just for kicks I downloaded Sabayon_Linux_14.01 and Ubuntu 13.10 ISO images. Burned both of them to the same USB stick using dd mehtod and both of them show up as “EFI USB Device”. Does that not imply something is missing from the “antergos-2014.03.16-x86_64.iso” image?

Posts 60Views 13502
Log in to reply