• lspci is hanging even on a fresh installation


    Hey!

    So I’m not sure what the deal is here, but I did a fresh installation of Antergos intending to try out one of the other environments (one of the lightweight ones, I forget which) and the system couldn’t successfully get into a session in that DE. I got to the login manager and would log in and it would change to have the environment’s background (which was like a blue-lime green gradient) and had a bar at the top, but the system would just hang.

    So I reinstalled into Gnome which has behaved the best on my server’s integrated graphics so far. I started to follow the guide for GPU passthrough I’m learning from and it didn’t take long for me to find that lspci -nnk hangs. It gives me a cursor on the next line and I can type, but nothing actually responds in terminal from that point on. Not even Ctrl + C will end the process. I tried going into system manager and ending the process and that wouldn’t do it either.

    So, I reinstalled again using KDE (which is my preferred environment, but it’s a little choppy) just to see if something fishy was going on with the environment. I tried running just lspci (without -nnk) and again it’s hanging in the same fashion…

    Any idea what’s going on? I tried doing some independent searching but all of the results seemed catered towards Ubuntu and whatnot and I wasn’t sure if they’d apply. One suggested that disabling nouveau would fix the issue but I don’t know what that is or if it’s a good idea.

  • I unplugged everything, opened up my case, and checked the connection (and power connections, etc) of my PCI devices. After restarting the computer with none of the peripherals connected (HDMI to video cards and USB devices to USB card), we’re able to run lspci (and lspci -nnk)…

    I’m about to try connecting everything back, then running lspci, then restarting and trying one more time. Maybe I just suck at (re)building computers!

  • Okay, so I can run lspci (and -nnk) if I don’t start the computer with any monitors connected to the power supply.

    I have noticed that looking at the results, the GTX 750 Ti and GTX 780 I have are being grabbed by nouveau. I’m going to progress with this guide a little bit, which should cause the GPUs to be grabbed by pci-stub instead and I’ll be able to see if that’s what’s causing the problem!

  • I don’t understand it, but switching over to pci-stub lets me boot the computer with monitors connected to the GPUs and still run lspci -nnk.

    Can anyone shed some light on that?

installation205 fresh21 hanging3 lspci1 Posts 4Views 950
Log in to reply