• Error: Failed to commit transaction - delta patch failed


    Greetings, I have a pretty huge problem. So, I’ve been away from my computer for a while and updates accumulated (over 400 mb). So, I didn’t want to download all of those updates at one time so I downloaded the smaller updates in numbers and decided the bigger ones like Opera and Libre I’d do later. That worked out well, only had 45 left. However, those 45 can’t be downloaded because now I receive an error which honestly gives me no sort of understanding to what the problem is.

    Essentially, I cannot update the rest of my packages and I’ve surfed around… nothing on it, which is a first. The screenshot below is what I get once the updates are finished downloading. It effectively cancels everything. Can someone help? Something tells me I should have just downloaded all of them together.

    0_1473732207676_Spectacle.TJ6057.png

    UPDATE:

    Certain packages (most left) are affected by this error - their download size does not display while the packages unaffected by the error do display their download size. As soon as I tried to download the marked packages in the 1st screenshot (below) the error immediately pops up. So I decided to uncheck them and download the Chrome update which worked. So, my guess is Libre and Opera will update while the rest can’t because of this “delta patch” failing.
    0_1473733959129_Screenshot_20160912_221832.png
    0_1473733970756_Screenshot_20160912_222216.png

  • Please, could you share the full output of

    sudo pacman -Syyu
    
  • @just It actually installed the updates successfully with that command.

    :: Synchronizing package databases...
     pantheon                                                     20.8 KiB   149K/s 00:00 [##################################################] 100%
     antergos                                                    127.4 KiB   607K/s 00:00 [##################################################] 100%
     core                                                        119.4 KiB   746K/s 00:00 [##################################################] 100%
     extra                                                      1760.0 KiB   784K/s 00:02 [##################################################] 100%
     community                                                     3.6 MiB   784K/s 00:05 [##################################################] 100%
     multilib                                                    172.7 KiB   796K/s 00:00 [##################################################] 100%
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...                                                                                                            
    
    Packages (49) boost-libs-1.61.0-2  btrfs-progs-4.7.2-1  cmake-3.6.2-1  dolphin-16.08.1-1  freetype2-2.7-2  gawk-4.1.4-1
                  gcc-libs-multilib-6.2.1-1  gcc-multilib-6.2.1-1  gnutls-3.4.15-1  goocanvas-2.0.2-1  graphviz-2.38.0-13  gtk2-2.24.31-1
                  gtksourceview3-3.20.4-1  gts-0.7.6-3  gwenview-16.08.1-1  hdf5-1.10.0_patch1-1  imagemagick-6.9.5.9-1  kate-16.08.1-1
                  kdebase-runtime-16.08.1-1  kdegraphics-okular-16.08.1-1  kdelibs-4.14.24-2  kdenetwork-kopete-16.08.1-1  khelpcenter-16.08.1-1
                  kio-5.25.0-2  lapack-3.6.1-2  lib32-gcc-libs-6.2.1-1  lib32-mesa-12.0.2-1  libcurl-compat-7.50.2-1  libgda-5.2.4-3
                  libgsignon-glib-2.4.0-1  libreoffice-fresh-5.2.1-2  lvm2-2.02.165-1  mesa-12.0.2-1  mesa-vdpau-12.0.2-1
                  networkmanager-1.4.1dev+33+gc87b89b-1  noise-player-0.4-1  npm-3.10.7-1  numix-icon-theme-0.1887-1
                  opera-developer-41.0.2349.0-1  pacman-mirrorlist-20160913-1  pantheon-backgrounds-bzr-r53-1  q4wine-1.3.2-1  quodlibet-3.7.0-1
                  rhythmbox-3.4.1-1  samba-4.5.0-2  smbclient-4.5.0-2  spectacle-16.08.1-1  util-linux-2.28.2-1  webkit2gtk-2.12.5-1
    
    Total Download Size:    213.90 MiB
    Total Installed Size:  1621.49 MiB
    Net Upgrade Size:       105.10 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     libgsignon-glib-2.4.0-1-x86_64                               57.2 KiB   204K/s 00:00 [##################################################] 100%
     pantheon-backgrounds-bzr-r53-1-any                           18.5 MiB   412K/s 00:46 [##################################################] 100%
     opera-developer-41.0.2349.0-1-x86_64                         91.0 MiB   766K/s 02:02 [##################################################] 100%
     btrfs-progs-4.7.2-1-x86_64                                  585.4 KiB   763K/s 00:01 [##################################################] 100%
     pacman-mirrorlist-20160913-1-any                              5.4 KiB   908K/s 00:00 [##################################################] 100%
     libreoffice-fresh-5.2.1-2-x86_64                             86.7 MiB   782K/s 01:53 [##################################################] 100%
     gtksourceview3-3.20.4-1-x86_64                              835.6 KiB   791K/s 00:01 [##################################################] 100%
     gts-0.7.6-3-x86_64                                          177.1 KiB   805K/s 00:00 [##################################################] 100%
     graphviz-2.38.0-13-x86_64                                     5.9 MiB   782K/s 00:08 [##################################################] 100%
     libgda-5.2.4-3-x86_64                                         9.0 MiB   784K/s 00:12 [##################################################] 100%
     libcurl-compat-7.50.2-1-x86_64                              187.9 KiB   734K/s 00:00 [##################################################] 100%
     goocanvas-2.0.2-1-x86_64                                    214.7 KiB   786K/s 00:00 [##################################################] 100%
     noise-player-0.4-1-x86_64                                   718.7 KiB   799K/s 00:01 [##################################################] 100%
    (49/49) checking keys in keyring                                                      [##################################################] 100%
    (49/49) checking package integrity                                                    [##################################################] 100%
    (49/49) loading package files                                                         [##################################################] 100%
    (49/49) checking for file conflicts                                                   [##################################################] 100%
    (49/49) checking available disk space                                                 [##################################################] 100%
    :: Processing package changes...
    ( 1/49) upgrading lib32-gcc-libs                                                      [##################################################] 100%
    ( 2/49) upgrading gcc-libs-multilib                                                   [##################################################] 100%
    ( 3/49) upgrading boost-libs                                                          [##################################################] 100%
    ( 4/49) upgrading btrfs-progs                                                         [##################################################] 100%
    ( 5/49) upgrading cmake                                                               [##################################################] 100%
    ( 6/49) upgrading freetype2                                                           [##################################################] 100%
      The Arch-specific FT2_SUBPIXEL_HINTING has been removed.
      Subpixel hinting is now configured in /etc/profile.d/freetype2.sh .
    ( 7/49) upgrading util-linux                                                          [##################################################] 100%
    ( 8/49) upgrading mesa                                                                [##################################################] 100%
    ( 9/49) upgrading gnutls                                                              [##################################################] 100%
    (10/49) upgrading kio                                                                 [##################################################] 100%
    (11/49) upgrading hdf5                                                                [##################################################] 100%
    (12/49) upgrading smbclient                                                           [##################################################] 100%
    (13/49) upgrading dolphin                                                             [##################################################] 100%
    (14/49) upgrading gawk                                                                [##################################################] 100%
    (15/49) upgrading gcc-multilib                                                        [##################################################] 100%
    (16/49) upgrading gtk2                                                                [##################################################] 100%
    (17/49) upgrading gwenview                                                            [##################################################] 100%
    (18/49) upgrading imagemagick                                                         [##################################################] 100%
    (19/49) upgrading kate                                                                [##################################################] 100%
    (20/49) upgrading kdelibs                                                             [##################################################] 100%
    (21/49) upgrading kdebase-runtime                                                     [##################################################] 100%
    (22/49) upgrading kdegraphics-okular                                                  [##################################################] 100%
    (23/49) upgrading kdenetwork-kopete                                                   [##################################################] 100%
    (24/49) upgrading khelpcenter                                                         [##################################################] 100%
    (25/49) upgrading lapack                                                              [##################################################] 100%
    (26/49) upgrading lib32-mesa                                                          [##################################################] 100%
    (27/49) upgrading libcurl-compat                                                      [##################################################] 100%
    (28/49) upgrading libreoffice-fresh                                                   [##################################################] 100%
    (29/49) upgrading lvm2                                                                [##################################################] 100%
    (30/49) upgrading mesa-vdpau                                                          [##################################################] 100%
    (31/49) upgrading networkmanager                                                      [##################################################] 100%
    (32/49) installing gtksourceview3                                                     [##################################################] 100%
    (33/49) installing gts                                                                [##################################################] 100%
    (34/49) installing graphviz                                                           [##################################################] 100%
    Optional dependencies for graphviz
        mono: sharp bindings
        guile: guile bindings [installed]
        lua51: lua bindings
        ocaml: ocaml bindings
        perl: perl bindings [installed]
        python2: python bindings [installed]
        r: r bindings
        tcl: tcl bindings [installed]
        qt4: gvedit [installed]
        gtk2: gtk output plugin [installed]
        xterm: vimdot [installed]
    (35/49) installing goocanvas                                                          [##################################################] 100%
    (36/49) installing libgda                                                             [##################################################] 100%
    Optional dependencies for libgda
        libgda-firebird: provider for Firebird
        libgda-jdbc: provider for JDBC
        libgda-mysql: provider for MySQL
        libgda-postgres: provider for PostgreSQL
    (37/49) installing libgsignon-glib                                                    [##################################################] 100%
    (38/49) upgrading noise-player                                                        [##################################################] 100%
    (39/49) upgrading npm                                                                 [##################################################] 100%
    (40/49) upgrading numix-icon-theme                                                    [##################################################] 100%
    (41/49) upgrading opera-developer                                                     [##################################################] 100%
    (42/49) upgrading pacman-mirrorlist                                                   [##################################################] 100%
    warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
    (43/49) upgrading pantheon-backgrounds-bzr                                            [##################################################] 100%
    (44/49) upgrading q4wine                                                              [##################################################] 100%
    (45/49) upgrading quodlibet                                                           [##################################################] 100%
    (46/49) upgrading rhythmbox                                                           [##################################################] 100%
    (47/49) upgrading samba                                                               [##################################################] 100%
    (48/49) upgrading spectacle                                                           [##################################################] 100%
    (49/49) upgrading webkit2gtk                                                          [##################################################] 100%
    :: Running post-transaction hooks...
    (1/6) Compiling GSettings XML schema files...
    (2/6) Probing GTK2 input method modules...
    (3/6) Updating icon theme caches...
    (4/6) Updating the info directory file...
    (5/6) Updating the desktop file MIME type cache...
    (6/6) Updating the MIME type database...
    Unknown media type in type 'all/all'
    Unknown media type in type 'all/allfiles'
    
    
  • @aricley said in Error: Failed to commit transaction - delta patch failed:

    @just It actually installed the updates successfully with that command.

    So it could be a good time to mark the topic as [Solved], couldn’t it :) ?

    Hint: at all costs avoid doing a partial upgrades. Wait until it will be possible to do a regular, full upgrade.

transaction8 commit5 delta1 error196 Posts 4Views 523
Log in to reply