• Slow wake up from sleep [Laptop] [KDE]


    I recently bought a new laptop, with a clean SSD (No OS pre-installed), and decided to install Antergos.
    I used the minimal installer and chose the KDE desktop environment.

    I have not installed much on it yet, only notable program is TLP.
    And I have one issue: I’ve noticed that after closing the laptop (Sleep), and opening it again, it takes several seconds (6-12 ish)
    for it to wake back up and let me login. After some testing it seems to me that the amount of seconds it takes to wake up,
    scales with the amount of system RAM in use. [Not confirmed]

    I’m quite the newb when it comes to linux and hardware, where do I begin, and what do I do if I want to speed up the wake up time?

  • I am having this issue as well. Also using KDE.

  • @eivind.furuberg

    1. How much RAM do you have?
    2. Are you sure you’re using sleep instead of hibernate? Given that the amount of seconds it takes to wake up scales with the amount of RAM in use, this would make a lot of sense.
    3. What does dmesg say?
  • @Tamius-Han

    Sorry for the slow answer!

    1. System specs: (The important ones)
      • Intel Core™ i5-6200U-prosessor (Skylake)
      • 8GB DDR3L 1600MHz SO-DIMM RAM
      • GeForce 940MX 2GB
    1. Yes, I’m using sleep/suspend. I have another option that is hibernate. But the peculiar thing is that when running KRunner, it dosn’t find anything for hibernation, but I get two different suspend commands; Suspend to Disk and Suspend to RAM. And the icons for Suspend to RAM and the Sleep/Suspend option is the same, aswell for the Suspend to Disk and Hibernation icons. So My guess is that the default Suspend, is suspend to RAM.

    2. Not sure if you wanted something specific from “dmesg”, so I just got all of it: http://pastebin.com/Y0XTaFxu
      PS: I did a test for just using “Lock Screen” when closing lid. And the same problem was present. It took several seconds before the screen turned on and I got to the splash screen. It could be that the problem is not specifically related to “sleep”.

    EDIT: Since the file upload didn’t seem to work; i got a pastbin link instead.

wakeup2 sleep8 kde115 laptop35 Posts 4Views 757
Log in to reply