• Steam not launching


    Hi, i’m trying to launch steam but it didn’t work. I already tried to follow some guides to install catalyst but can’t install it too (it seems is catalyst that prevent steam from launching according to other guides).

    Well i have and AMD A4-7300 with Radeon.
    when i try to launch through terminal i got this errors:

    /home/fernando/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
    /home/fernando/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
    Running Steam on antergos 64-bit
    /home/fernando/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    libGL error: unable to load driver: r600_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: r600
    libGL error: unable to load driver: r600_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: r600
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

    Can someone guide me step by step to make steam work?
    Well, any help is apreciated.
    Thanks guys and sorry for my bad english, i’m from Brazil.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Well i don’t know exactly how it was fixed i followed so many guides (i tried another things some days ago that could help with the today solution).

    Today:
    first, i followed the steps of this guide:

    https://manerosss.wordpress.com/2016/05/16/how-to-fix-steam-not-running-with-open-source-drivers-on-arch-linux/

    then this guides:

    http://www.gearsongallium.com/?p=3234

    https://bbs.archlinux.org/viewtopic.php?id=183659 (just for renaming the files below)

    https://bbs.archlinux.org/viewtopic.php?id=197956 (just for renaming the files below)

    renamed:
    libgcc_s.so.1 to libgcc_s.so.1.bak
    and libstdc++.so.6 to libstdc++.so.6.bak

    i can open steam now using:
    STEAM_RUNTIME=0 steam

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

steam55 launching2 Posts 2Views 543
Log in to reply