• Doesn't fall asleep and can't wake up


    Up to date Antergos on Gnome here. My Toshiba R700 does not lock screen after 30 sec as I’ve set it up in the settings. And when I close the lid, the screen turns black and I have to power off the machine for a restart. LightDM issue? Should I install GDM?

  • I would argue that changing over to another login mgr has anything to do with it. Login Greeters are just that: Greeters
    You say you’ve looked inside your Power Savings section and there is joy after setting things properly there. Ok, so then the next step to do if your Power settings are not to your liking or are not working after testing them out a couple of times are to head over to the Arch Wiki, which is a fabulous resource of which I would recommend anyone using Antergos to Bookmark in thier browser.
    link text

    Most especially this: link text

    Have you checked out systemctl suspend or systemctl hibernate by chance? check and see.
    If none of that works, try pm-utils

    I hope some of this has helped.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc Thanks for the reply! I ran xscreensaver, but its some Tk app I think? I don’t like this solution since I prefer my computer to fall asleep by itself rather than launching an app… There is something installed called Light Locker. Maybe I installed it when looking for a solution (or is it default?). I opened it and it seems its options were to never lock screen by default. I changed the settings and now the lock screen is fine. Maybe there are overlaps between programs that do the settings…

    Running command systemctl suspend brings the system to sleep, but again the screen can’t recover. While hibernate, good news, is fully functional. I have found a power tab in gnome-tweak-tool where I can set Hibernate instead of Suspend. Reboot. Unfortunately, just like my lock problem, it has no effect at all. I tried to select Nothing. Still suspending. But, hey, recovering after.

    So its solved. Weirdly.

  • HI.
    Ok, so if it’s resolved, (wierdly, I guess) there is the off chance that your initramfs may play a part. I’m totally no expert but it only just occured to me. In /etc/mkinitcpio.conf there are some hooks. The word “resume” should be after “udev”. If it isn’t there, you can add it. If you have added it, make absolutely sure that you mkinitcpio -p linux
    As a matter of fact, any time that you change that file, you have to do that command. Otherwise, no changes take place.

    All in all, don’t forget to mark your thread as "solved"
    Happy hunting. :)

    EDIT: I forgot to ask, what file system are you using? LVM or EXT3/4

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • The problem with Light Locker settings is that they are reset to “never” at each the computer wakes up. I read here that this is a bug. The proposed solution was to install and enable GDM, like this.

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    

    The solution seems to work now.

asleep1 wake4 fall1 Posts 5Views 750
Log in to reply