• Firefox dropdown and dialog box issues


    Hi, guys

    I have a brand new install of Antergos, using MATE desktop. I just came from Arch using MATE, and Firefox was fine. However, with this installation, the dropdown menus or dialog boxes don’t populate correctly, and there is no visible text in the URL bar. If anyone has any suggestions, let me know. I’ve uploaded photos demonstrating all three issues.
    ]0_1473119274550_Screenshot at 2016-09-05 19-38-49.png image url)

    0_1473119383501_Screenshot at 2016-09-05 18-52-59.png

  • @neon_squirrel Like Jeannie suggested, try to install Firefox GTK2 version, or install Mate GTK3, which works perfect for me.

    Try to change your system theme. Or use an other Firefox theme like Metal Lion Australis. This way you can confirm if it is indeed a Firefox, or a system theme problem.

    Never to old to learn.

  • Hi,
    Same issue for me.
    Actually after install firefox gtk2 version still happend.
    Mate 1.16.0 are installed but i dont know if gtk3 version
    How can i install mate gtk3??

    thank you
    0_1474998679239_Pantallazo-2016-09-27 19-32-46.png
    0_1474998688460_Pantallazo-2016-09-27 19-34-09.png

  • Hey, guys. I just wanted to let you know that even after installing mate-gtk3, the issue persisted. I tried IceCat instead of Firefox, and the exact issue persists in the other browser.

  • Did changing your DE theme change anything? Or, otherwise, have you tried to use a different FF theme. Some DE themes, especially dark themes, do not work well with the default FF theme.
    Another idea is to remove/rename your FF profile in /home/.Mozilla/profile . FF will create a new profile when started the next time. Be aware that you will lose all date in that profile.

    Never to old to learn.

  • @axioma

    changing mate theme or firefox theme nothing happends.
    i tried removing /home/(user)/.mozilla/ but it doesnt work either.
    i think there is some kind of issue with fonts

  • mate (GTK3) gives the same problem here, also with Thunderbird email (which does shows icons but not (e.g.) inbox contents. Clicking on message list shows actual message OK)

    Installed chromium, which works fine. Tried several themes with no joy (mate & Mozilla).

    Also installed Openbox DM, both FF & TB ok with that.

  • I had the same problem, but just solved it. I changed Application Font to Serif Regular and now the text shows up. I even changed the font back to to Sans Regular, put on a dark theme, and it’s still good.

  • @guppy May i ask, where does one change Application Font? If within Firefox itself, how to do so when Preferences, etc are not visible?
    I wanted to check out MATE and recently installed it. After overcoming the initial blank taskbar issue and setting thing up the way i like it seems pretty cool. But i have the Firefox issue referenced here and elsewhere. Firefox just upgraded to 50.x with no change. I have tried all system themes with no success.

  • @guppy Sorry, i did find it under System-Preferences-Look and Feel-Appearance. Fonts is a tab alongside Themes and others. I changed Application font as you said, Firefox is magically fixed. Changed the font back to original and FF still works fine. You must be a true genius to have come up with this fix! Mark mine Solved and many thanks!!

  • @billwx If finding the preference setting in FF is a problem, you can find it under the three bars icon in the right side top of FF, or press alt and you see the Menu-bar. Preferences is under Edit. The font settings are located under the Content tab.

    Never to old to learn.

  • Thank you @guppy for the solution, i’ve found the real explanation:

    I’ve installed AGOS yesterday and i’ve found the mate application font “Sans Regular” was set to 0 size !
    Set this to 10 solve the problem with firefox, enjoy and thanks !

  • @Guest said in Firefox dropdown and dialog box issues:

    Thank you @guppy for the solution, i’ve found the real explanation:

    I’ve installed AGOS yesterday and i’ve found the mate application font “Sans Regular” was set to 0 size !
    Set this to 10 solve the problem with firefox, enjoy and thanks !

    Thanks that was the problem.

dialog5 dropdown1 issues40 firefox23 Posts 13Views 1961
Log in to reply