• System not booting sometimes


    Hello,

    my system sometimes can not boot.

    I have done dmesg of correct boot and dmesg of fail boot.

    Fail boot -> [url:2ja2f43e]http://pastebin.com/UdWv6dFH[/url:2ja2f43e]
    Normal boot -> [url:2ja2f43e]http://pastebin.com/zbNx2L7R[/url:2ja2f43e]

    I did diff and the problem is here ( I guess) … but why it is not happening always?

    [ 16.208708] BUG: unable to handle kernel NULL pointer dereference at 0000000000000200

    I have radeon graphic and integrated intel graphic. Since I do not need the dedicated radeon I am turning it off by this “echo OFF > /sys/kernel/debug/vgaswitcheroo/switch”. ( Starting as service on boot - systemd )

    Can someone help me?

    Thank you

  • Hello,

    my system sometimes can not boot.

    I have done dmesg of correct boot and dmesg of fail boot.

    Fail boot -> [url:2ja2f43e]http://pastebin.com/UdWv6dFH[/url:2ja2f43e]
    Normal boot -> [url:2ja2f43e]http://pastebin.com/zbNx2L7R[/url:2ja2f43e]

    I did diff and the problem is here ( I guess) … but why it is not happening always?

    [ 16.208708] BUG: unable to handle kernel NULL pointer dereference at 0000000000000200

    I have radeon graphic and integrated intel graphic. Since I do not need the dedicated radeon I am turning it off by this “echo OFF > /sys/kernel/debug/vgaswitcheroo/switch”. ( Starting as service on boot - systemd )

    Can someone help me?

    Thank you

  • Hi,

    It’s probably a bug in the kernel There is a soon to be released kernel update in testing repo you could try: [https://www.archlinux.org/packages/testing/x86_64/linux][0]">[https://www.archlinux.org/packages/testing/x86_64/linux][1] It won’t be very long before it’s released into Core tho (24-48hrs). Another option is to use the LTS kernel which is on the 3.10 branch (still a very recent kernel, more so than a lot of other distros) You can install it with:

    sudo pacman -S linux-lts
    

    If you want to upgrade to the kernel in testing you will need to enable the testing repo in /etc/pacman.conf then do

    sudo pacman -Sy linux
    

    Hope that helps.

    Cheers!

    [0]: <a href=
    [1]: https://www.archlinux.org/packages/testing/x86_64/linux

Posts 3Views 902
Log in to reply