• New installation finishes but system doesn't boot


    pardon me if this is a duplicate of previous question, but haven’t seen in previous posts what the fix is for this issue. In my case am trying to install on SSD, currently on SATA port 1, sda1 is 500 mb EFI System Partition, sda2 Antergos Linux and sda3 4gb Linux Swap. Disk is formatted GPT. Compatibility on computer bios set to UEFI first but I’m hesitant to put as UEFI only, so have kept the Legacy option still there.
    First time booted to USB and installed everything very quick. Upon reboot, however, booted only to say that partition not found, and every subsequent boot only gets:
    GRUB

    or just blinking cursor.
    Didn’t see any messages during install about Grub2 failing to load/install. Tried booting to various live distros. The Antergos USB and later burned DVD only boot to initial Antergos selection. No matter what chosen, now just boots to white screen or sometimes a long list of errors that I’m unfamiliar with.
    blk_update_request: I/0 error, dev sr0, sector

    Would be my understanding that sr0 would be the cd/dvd drive so am going to try and swap that out with another.
    But what is the issue with the Grub not installing. Now trying to boot to any other disk or linux distro that I have installed is getting similar error or just blinking cursor.

    Tried running boot-repair from Ubuntu live CD, bootloader restore utility from Parted Magic and then manually trying to mount EFI and chroot then install grub but it does not install. Boot-repair gives message to "enable GRub-efi-amd64 pkg from Antergos repos? Manual install of grub from live CD and chroot are complaining about an i386 file missing from GRUB. Tried installing rEFI program but other than an entry in bios and some new entries in a grub menu. Can only access any grub menu by using the Super Grub disk and then only when selecting an option similar to: grub-efix86_amd64 but selecting the Antergos, Ubuntu or Mint entries on grub boot menu just boot to blinking cursor or “GRUB”.

    What am I doing wrong here? A bit frustrating and disapointing as was referred to Antergos by a friend because he said “everything just works” and I’m fed up with Ubuntu Studio and Linux Mint both having alsa audio issues that disable selection of my sound card.

  • Hi, do you still need help with this issue? If so, could you tell me whether or not you configured your existing EFI partition to be mounted as /boot/efi and grub to be installed on sda?

  • @lots.0.logs. Think I got the white screen issue fixed by adding nomodset to boot cmd. Problems continue with installing Grub-EFi. For some reason can’t get it to install, getting various errors ranging from “partition locked” to the errors such as “Discarding improperly nested partition” when trying to install or update grub. Even though it says it installs in that case, on reboot I keep booting to just error or “no active partition” error messages. I can manually boot using Super Grub disk, but even when booted and then trying to install Grub (as opposed to from a Live CD) it is not seeming to install it. boots right back to error or no active partition or rarely now just “grub”. Problems are affecting my Ubuntu and Mint partitions as well. Now getting same errors about improperly nested partition. Even in those cases when I have been able to get into a grub or grub rescue I’m getting unrecognized file system errors on my fat32 esp partition. It’s formatted correctly and uses the correct coding and does show up as EFI System Partition. So pretty confused as to what is happening. May just stop trying to mess with EFI and take everything back to good old MBR format.

  • @ericb7799 and yes am mounting it to boot/efi. Most of the time it is showing as sda but when I boot to USB for example it makes the USB drive sda for some reason.

installation212 system73 finishes1 boot176 Posts 4Views 1156
Log in to reply