• Dbus error during login


    Hello, everybody. I’m fairly new to using Antergos, so I’m sorry, if I ask something stupid.
    The thing is, after yesterday’s update I can’t login into graphical environment. All I get is an error: “Failed to connect to socket /tmp/dbus-fRh79c3J04: connection refused.” I’m using xfce4, if that’s important.
    Thanks a lot in advance!

    Edit: As I just found out, if I press Ctrl+Alt+F2, login in console version and manually run startx, this error doesn’t occur, and all starts seemingly as it should.

  • Try running echo "export NO_AT_BRIDGE=1" >> $HOME/.xprofile and see if this works. Also, what dm are you using? And do you see the login screen (I assume yes, since you can use tty)? If adding that to xprofile does not work, and you are seeing the login screen with lightdm, running echo "\nexport NO_AT_BRIDGE=1" | sudo tee -a /etc/lightdm/Xsession may help.

  • None of these worked.
    I am using lightdm and I can see login screen, but can’t log in with it.

  • Can you run startx &> ~/.Xoutput and post the contents in ~/.Xoutput ? I would want to look into the log so I would be able to diagnose the problem. I am now pretty confused. I want to know if this is a problem with X or systemd or dbus or just because of the startup scripts.

  • I’m sorry, that I disappeared like that. Here’s the output of what you told me to do:
    http://pastebin.com/nNuh2fZW
    I also decided to just get rid of lightdm and installed sddm instead. For a few days it worked just fine, but today, after the update, it began producing the same errors! I have no clue what to do now.

  • @Cromachy I am not sure what’s happening. I’d try to run yaourt -Syyu for an update and see if things work out. I want to know what you updated on the update that broke your system. You can try downgrading the packages and blocking them from upgrading themselves.

  • I had the same issue and here’s what I did.

    cd /var/cache/pacman/pkg
    as root user
    pacman -U dbus-1.10.8-1-x86_64.pkg.tar.xz libdbus-1.10.8-1-x86_64.pkg.tar.xz

error177 dbus2 xfce418 Posts 7Views 714
Log in to reply