• Dell XPS 13 9359 (2016) no Wifi

    Hello there,

    ive got the Dell XPS 13 9359 as a workmashine with Win10.
    For my Schoolpartition I like to run Linux. With Ubunutu as a test I had no Problems whith my Hardware at all.
    With Antegros I cant bring my WiFi to work.
    I read in the Arch forum, that there where some Problems before Kernel 4.4 but we are some version over it by time.
    The forum also sad, there shouldnt be any Problems with the Wifi card.

    It uses a DW1820A what should be a Broadcom BCM4350.

    Does someone had the same Issue and found a workaround?

    Thanks for help

  • Try running lspci | grep Network and see if the results it returned is the same hardware as your computer’s. This may be a driver issue. Also, according to info on the dell website, the 13 inch xps comes with DW1820A. So I’m not sure why you’ve put BCM4350 in your question. But I have heard that broadcom is not working well with its drivers, though.

  • @tydlwav

    $ lspci | grep Network
    3a:00.0 Network controller: Broadcom Corporation BCM4350 802.11ac Wireless Network Adapter (rev 08)

    There are sometimes Issues with Broadcom cards thats true. But with Ubuntu for example it works like a charm.
    And if it runs with Ubuntu there must be a Way to make it work in Arch too? ^^

  • @chztph Not an answer to your question, but today I replaced the broadcom adapter with an intel 7265 in my 9350, and it works very good. More info on it: http://oli.me.uk/2015/11/06/installing-arch-linux-on-a-dell-xps-13-9350/

  • @chztph This can be a driver issue. Plese run lspci -v and paste results here. Sometimes your system is not using the proper driver. It’s not that much of a fuss if it’s a driver problem.

  • @chztph Also, there’s an upgrade on the network manager that solves problems for other broadcom models. Make sure you updated your system through sudo pacman -Syu and reboot. Ubuntu is using dated software, so it may be the new bug arising from the network manager that is affecting you. Now with the upgrade, the bug is fixed.

  • This is really annoying, everything was working yesterday, and then stopped working after updates. I’m now unable to connect my laptop to the internet to update again because the Dell XPS doesn’t have an Ethernet port. I’ll have to buy an adaptor tomorrow to fix it.

    Why is it that drivers are so problematic even nowadays after so many iterations of fixes?

  • @juliohm Don’t think you have to. There’s a way to downgrade to lower versions of your network manager. cd /var/cache/pacman/pkg/ && ls | grep networkmanager, then find the version you want to downgrade to, and then (in this case) type pacman -U networkmanager-1.2.5<and some thing after that>. It should downgrade your network manager to the previous version. Reboot and then run pacman -Syu to update to the newest version of network manager.

  • Thank you @tydlwav , downgrading networkmanager solved it, upgrading again made the issue come back. So, we will need to wait for fixes.

  • @juliohm I will post here as soon as I see a new version of network manager.

  • @chztph
    Could you attempt the following via terminal
    Do the following in the order I’ve prescribed:
    ifconfig to bring your wireless up.
    There will be no feedback.
    Then do:
    iwlist wlan0 scan to scan for your wireless.
    You will see output.
    Prepare to configure your network. Do the following:
    iwconfig wlan0 essid YOUR-NETWORK-ID key YOUR-WIRELESS-KEY
    Notice the word “key” in between. Ensure you input EXACTLY that in between.
    Prepare to get an IP.
    Do the following:
    dhclient wlan0
    There should be no output. If there are, then there are errors. This then is bad.
    If no errors, then prepare the above commands a script to run.
    Do the following:

    #! /bin/bash
    ifconfig wlan0
    iwconfig wlan0 essid YOUR-NETWORK-ID key YOUR-WIRELESS-KEY
    dhclient wlan0

    Now save this script with a name something like this: chztph-wireless-config.sh
    Now make it an executable file.
    Do the following:
    chmod u+x chztph-wireless-config.sh
    Prepare to make this script/command a global command.
    Do the following:
    Place it inside the directory: /usr/local/bin.
    Now run the command chztph-wireless-config.sh anywhere within your directories to enable wireless.

    enjoy :)

  • @juliohm Heard that there’s a new version coming out. Try running sudo pacman -Syyu. If this does not solve the problem, please report the bug to gnome developers.

  • @juliohm the newest version is 1.4.1dev+15. So to make sure everything is right, you can run sudo pacman -Syy && sudo pacman -Si networkmanager to check first. Then, you can update with sudo pacman -Syu, instead of just running sudo pacman -Syyu.

  • @tydlwav thank you, I can confirm that the update solved the issue. Thank you for your attention, your comments were really helpful.


  • Hello there, thanks in advanced for the hints you guys had for me.
    I found the time today after work for troubleshoot my problem.
    Cause i runned Ubuntu on my Partition I had to reinstall Antegros.
    After the Installation i noticed, that Antegros didnt installed the default Gnome desktop with Dash to dock and the Numix icons.
    BUT! my WiFi worked out of the Box…
    So I decided to install Dash to dock and some other stuff and now my system is up to date and works fine so far.

    Strange but ok


    The connection breaks down often after restart. I have to switch the WiFi on/of a few times till it works again.

  • Hi @tydlwav,

    I powered my laptop today and the issue is still there. I downgraded to networkmanager-1.4.1dev+15+g0d23ffd-1-x86_64.pkg.tar.xz in order to get connection. I will try file a bug report, do you have the link for the last bug report users have opened?

    Thank you.

  • I have the same issue with OP on my XPS 15. Does a simple drive update solve the problem? P.S some times you need to unlock xps password if you just forgot it.

wifi151 dell30 broadcom22 dell xps 133 Posts 18Views 4889
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.