• Gnome is starting very slowly


    I’ve been using antergos under both gnome and cinnamon. I have found that cinnamon starts up very quickly from lightdm, but gnome would take about 15 to 30 seconds to start. It would show me a blank screen for a long time before the desktop jump out.

    I’ve also used pure arch with gnome. What I’ve experienced from that is that gnome starts very fast from gdm, as I used gdm. I also tried manjaro with gnome. It’s not as fast as arch, but certainly faster than antergos. I’m very confused now.

    I don’t understand what’s happening. I love gnome and want to switch back from cinnamon, but I have to find a way to avoid this long and agonizing wait.

    Or else, I’d be forced to build my own arch if I have time. But I most definitely love antergos.

  • @tydlwav , hi
    If you have noticed that under gdm Gnome is faster, why not try it out?
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo reboot
    and see it for yourself. You can always switch back to lightdm if not satisfied by disabling the one and enabling the other…
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Right. I’ll try it the next time I use gnome on antergos.

    One more thing: I find my gnome settings does not have ‘close lid’ options. I’m wondering what may cause that problem and what can I do to set close lid action to suspend? It seems to just turn the screen off by default.

  • @tydlwav Check the Tweak Tool program and then go to Power section. There is an option there for lid setting.

  • @Makaveli Thanks, I’ll try that next time I use gnome.

  • @anarch Let’s mark this as solved. I have no questions left.

  • @tydlwav , ok. Just to know how to do it yourself, the options are ii the TOPIC TOOLS on the bottom RH corner of the page.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Yeah, thanks. Got it.

  • Now I am using gnome with my antergos installation that defaults to cinnamon. I am using lightdm and there is no apparent lag between login and my gnome desktop. I don’t know why the default gnome installation does not work well. The only thing I changed is my greeter in lightdm to gtk greeter.

cinnamon gnome3 lightdm96 gnome 38 Posts 9Views 829
Log in to reply