• Cannot start mysqld.service after fresh antergos installation


    Hi,

    I’ve just installed Antergos. I am new on Arch but i was using Ubuntu for years. I’ve not make any installation or configuration yet, LAMP was my first job after installation.

    I’ve followed this guide : http://www.tecmint.com/install-lamp-in-arch-linux/
    From this topic : https://forum.antergos.com/topic/4156/how-can-i-install-lamp-on-antergos

    This is my “systemctl start mysqld” output:

    Job for mariadb.service failed because the control process exited with error code.
    See "systemctl status mariadb.service" and "journalctl -xe" for details.
    

    Output for : “systemctl status mariadb.service”

    ● mariadb.service - MariaDB database server
       Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Cts 2016-08-27 21:44:09 EEST; 55s ago
      Process: 14234 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE)
      Process: 14180 ExecStartPre=/bin/sh -c VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ] &&   systemctl set-environment _WSREP_START_POSITION=$VAR || exi
      Process: 14177 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
     Main PID: 14234 (code=exited, status=1/FAILURE)
       Status: "MariaDB server is down"
    
    Ağu 27 21:44:09 raynaud09 systemd[1]: Starting MariaDB database server...
    Ağu 27 21:44:09 raynaud09 mysqld[14234]: 2016-08-27 21:44:09 140673549388992 [Note] /usr/sbin/mysqld (mysqld 10.1.16-MariaDB) starting as process 14234 
    Ağu 27 21:44:09 raynaud09 mysqld[14234]: 2016-08-27 21:44:09 140673549388992 [Warning] Can't create test file /var/lib/mysql/raynaud09.lower-test
    Ağu 27 21:44:09 raynaud09 mysqld[14234]: [90B blob data]
    Ağu 27 21:44:09 raynaud09 systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
    Ağu 27 21:44:09 raynaud09 systemd[1]: Failed to start MariaDB database server.
    Ağu 27 21:44:09 raynaud09 systemd[1]: mariadb.service: Unit entered failed state.
    Ağu 27 21:44:09 raynaud09 systemd[1]: mariadb.service: Failed with result 'exit-code'.
    

    And output for “journalctl -xe”

    Ağu 27 21:48:41 raynaud09 dbus-daemon[405]: Successfully activated service 'org.gnome.Documents'
    Ağu 27 21:48:41 raynaud09 org.gnome.Shell.desktop[752]: Gjs-Message: JS LOG: pidgin-im-gs: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.Service
    Ağu 27 21:48:41 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/lens-correct.so' modülü yükleme hatası: liblensfun.so.1: 
    Ağu 27 21:48:41 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/exr-load.so' modülü yükleme hatası: libIlmImf-2_2.so.22: 
    Ağu 27 21:48:41 raynaud09 org.gnome.Documents[405]: (org.gnome.Documents:14263): Gtk-WARNING **: Theme parsing error: gtk.css:3779:29: The style propert
    Ağu 27 21:48:41 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/exr-save.so' modülü yükleme hatası: libIlmImf-2_2.so.22: 
    Ağu 27 21:48:41 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/matting-levin.so' modülü yükleme hatası: libumfpack.so.5:
    Ağu 27 21:48:41 raynaud09 org.gnome.Documents[405]: Gjs-Message: JS LOG: Can't find a valid getting started PDF document
    Ağu 27 21:48:41 raynaud09 org.gnome.Photos[405]: (gnome-photos:14266): Gtk-WARNING **: Theme parsing error: gtk-dark.css:3772:29: The style property Gtk
    Ağu 27 21:48:42 raynaud09 dbus-daemon[405]: Activating service name='com.intel.dleyna-renderer'
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: dLeyna core version 0.5.0
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: dleyna-renderer-service version 0.5.0
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Type[0] Level[0x13] Mask[0x4C] Flags[0x4F]
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Load file [/home/raynaud09/.config/dleyna-renderer-service.conf]
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: [General settings]
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Never Quit: F
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Connector Name: dbus
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Port: 0
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Push host port: 0
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: [Logging settings]
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Log Type : 0
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Log Level: 0x13
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: [Network filtering settings]
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Enabled : F
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Entries: (null)
    Ağu 27 21:48:42 raynaud09 dbus-daemon[405]: Successfully activated service 'com.intel.dleyna-renderer'
    Ağu 27 21:48:42 raynaud09 dbus-daemon[405]: Activating service name='org.gnome.Photos'
    Ağu 27 21:48:42 raynaud09 org.gnome.Shell.desktop[752]: Gjs-Message: JS LOG: pidgin-im-gs: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.Service
    Ağu 27 21:48:42 raynaud09 dbus-daemon[405]: Successfully activated service 'org.gnome.Photos'
    Ağu 27 21:48:42 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/lens-correct.so' modülü yükleme hatası: liblensfun.so.1: 
    Ağu 27 21:48:42 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/exr-load.so' modülü yükleme hatası: libIlmImf-2_2.so.22: 
    Ağu 27 21:48:42 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/exr-save.so' modülü yükleme hatası: libIlmImf-2_2.so.22: 
    Ağu 27 21:48:42 raynaud09 org.gnome.Photos[405]: GEGL-geglmodule.c-Message: '/usr/lib/gegl-0.3/matting-levin.so' modülü yükleme hatası: libumfpack.so.5:
    Ağu 27 21:48:42 raynaud09 org.gnome.Photos[405]: (gnome-photos:14373): Gtk-WARNING **: Theme parsing error: gtk-dark.css:3772:29: The style property Gtk
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Calling GetRenderers method
    Ağu 27 21:48:42 raynaud09 dleyna-renderer-service[14367]: Client :1.180 lost
    Ağu 27 21:48:43 raynaud09 dleyna-renderer-service[14367]: dLeyna: Exit
    Ağu 27 21:49:06 raynaud09 dbus[322]: [system] Failed to activate service 'org.bluez': timed out
    

    And there is no output for “netstat -ln | grep mysqld”

    Thank you in advance.

  • @raynaud09 , thanks for sharing your solution.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

mysql1 Posts 3Views 819
Log in to reply