• Unable to mount ZFS after reboot


    I just rebooted my laptop and I am presented with the same error as is described in this thread kernel 4.5-1 issues with ZFS after update today.

    error: resume: no device specified for hibernation
    ash: 1: unknown operand
    the ZFS modules are not loaded
    try running /sbin/modprobe zfs as root to load them.

    and i have a prompt of [rootfs ] #

    Anyone knows anything that can help?

  • Hi,

    Using zfs as root can be hard because zfs modules must be loaded before even being able to access your root partition. As I’ve said many times, when you update your system you always have to check that the zfs modules are build correctly, if not, you’ll have problems in the next boot.

    OK, let’s try this:

    1. Boot with the livecd (or usb) of Antergos (when the installer pops up just click on “try it”)
    2. Open gnome-terminal
    3. Load zfs module: sudo modprobe zfs
    4. This is a bit tricky. Before being able to chroot to your root you must Import your zfs pool first: zpool import -R /mnt -f zroot (change zroot to the name of your pool)
    5. Now you can croot to your root: arch-chroot /mnt

    Now you should be able to run pacman again, and check its output:
    sudo pacman -Syu
    sudo pacman -S zfs

    Tell us how it goes.

  • @karasu I’m having this same issue after upgrading linux and rebooting… I’ve tried your steps and have successfully chrooted…
    Doing sudo pacman -Syu … everything up to date.
    Doing sudo pacman -S zfs … zfs is up to date

    I tried reinstalling zfs and got some errors; here is output:
    0_1475085145812_asdf.png

  • Hi,

    Do you have the linux-headers installed?
    Can you post here the results of ls -l /usr/lib/modules ?

  • Yes, linux-headers-4.7.5-1 installed.

    Here is result of ls -l /usr/lib/modules:

    [[email protected] /]# ls -l /usr/lib/modules
    total 33
    drwxr-xr-x 5 root root 17 Sep 28 13:41 4.7.5-1-ARCH
    drwxr-xr-x 2 root root  7 Sep 28 08:43 extramodules-4.7-ARCH
    

    Thanks for your help.

  • Hi,

    What I see is that zfs is searching for /usr/lib/modules/4.7.5.0-1-ARCH but you have /usr/lib/modules/4.7.5-1-ARCH (but I do not know why).

    Try creating a symlink:

    cd /usr/lib/modules
    sudo ln -s 4.7.5-1-ARCH 4.7.5.0-1-ARCH
    

    Then try installing zfs again.

    I hope this helps.

unable35 reboot10 mount11 zfs27 Posts 6Views 1091
Log in to reply