• Does the Login Manager not work?


    Hey Antergos folks!

    I’ll start off by saying I’m super new to Linux. This is probably something embarrassingly simple.

    I’ve tried setting up Antergos on a new “server” computer I’m building a few times now and can’t seem to get any of the GUI versions to work. On both the machine I’m trying to get up and running as well as a Virtual Machine on my current desktop, no matter which GUI/desktop environment/window manager I choose to install, I end up at this Welcome! screen and can’t do anything but turn off my computer or expand/collapse the current time. Also, I know this is probably a result of being in a virtual machine or running on a server’s integrated graphics, but the environment is very choppy and unresponsive.

    If I install Antergos without any desktop environment, the operating system appears to work fine. I’ve tried a few of the different options and they all seem to bring me to the same welcome screen without any option for putting in my username and password.

    Thanks in advance for helping. I’ve seen a few posts talking about changing the login manager using terminal and I’m going to play with that in the meantime but I assume I have to be doing something wrong for the very first screen of Antergos to “not be working.”

    EDIT: I realized I might have left out a lot of useful information. The .iso file I’m using is fairly recent, probably less than a week old. It’s named antergos-2016.07.19-x86_64.iso.

  • When I was trying to change from LightDM to GDM (or KDE), I tried Ctrl + Alt + F2, Alt + F2, etc. Nothing. Ctrl + Alt + F1 brings me to a screen that reads:

    Starting version 231
    AntergosBoot: recovering journal
    AntergosBoot: clean, 171886/928416 files, 1072874/3708672 blocks
    [  8.619353] piix4_smbus 000:00:07.0: SMBus base address unitialized - upgrade BIOS or use force_addr-0xaddr
    [  11.602737] intel_rapl: no valid rapl domains found in package 0
    [  11.628841] intel_rapl: no valid rapl domains found in package 0
    _
    

    And the cursor is blinking, though I don’t get any visual feedback when I try typing. No combination of Ctrl, Alt, and F-keys seems to do anything unless I restart the VM and end up at the welcome screen again.

  • Hi!

    You have to click on the time. Then you user should show (so you click on it) and then you can enter the password.

    Is not working for you?

  • @karasu No, no matter how I install Antergos I do not get any users when I click on the time.

    The time (choppily) collapses and I have a little arrow button to bring it back down but there’s no menu items that appear when the time hides from clicking it.

  • That’s odd.

    OK, as a quick fix, you can change the lightdm greeter.

    1. Install lightdm-gtk-greeter
      sudo pacman -S lightdm-gtk-greeter
    2. Then edit /etc/lightdm/lightdm.conf :
      sudo nano /etc/lightdm/lightdm.conf
      Search for greeter-session=lightdm-webkit2-greeter and change it to greeter-session=lightdm-gtk-greeter
    3. Restart lightdm:
      sudo systemctl restart lightdm

    Tell us how it goes.

    EDIT: If you can’t get to a console with CTRL+ALT+F3 then you must boot with the livecd (or usb) and chroot to your root partition. Then make any changes you want (change lightdm with gdm or change lightdm greeter).

    https://wiki.archlinux.org/index.php/change_root

  • Ctrl + Alt + F3 got me to a console and I either can’t remember my user/password or none of the ones I set up are working.

    I’m trying to reinstall Antergos one more time (the same way I installed it here) and making sure I take note of my login credentials.

    Something I thought that could possibly be part of the problem is I know that sometimes (I don’t think every time) I set up my username as admin. Could that cause issues?

    Edit: It looks like that was the cause of my problems.

  • I set up my username as admin. Could that cause issues?
    Edit: It looks like that was the cause of my problems.

    That’s odd. Good to know, though. I know you can’t name root or any other system account to your account, of course. But there is no “admin” account that I know of. Strange.

    Well, glad you solved it.

    Cheers!

    P.S. If you want, you can open an issue in Github (the instaler). https://github.com/Antergos/Cnchi/issues

  • root! I was using root as my username, not admin. I was trying to avoid having to sudo and put a password in every time I wanted to do stuff.

  • @scapegoatwax using sudo is the better practice. A root user can easily break the system. It is not recommended to use root as your everyday user. The slightly better way is to open a terminal specifically for the administration task and run sudo su so that you will be the root user in the terminal. But do NOT run other things that you don’t understand with root. That is most definitely dangerous.

  • @tydlwav I understand that it’s best practice to use sudo to help avoid making stupid mistakes. I like that about Linux and appreciate it, but I’m not using Linux in a serious enough capacity (right now) to be worried about making those stupid mistakes. If I end up breaking an installation of Linux, it’ll ultimately just be a lesson learned and I imagine the consequences (frustration) would help the lesson stick. :)

    But believe me, in any configuration with significance or importance, I would definitely lean towards using sudo for administrative actions.

  • @scapegoatwax Right. If you really want to learn about linux, try working with pure arch. It’s much better since you need to build your system ground up. You also get to configure a lot of things on the way.

  • root! I was using root as my username, not admin.

    Oh, now that makes sense. Yes, the installer asks you for your user account, you can’t name it root.

    I was trying to avoid having to sudo and put a password in every time I wanted to do stuff.

    You can add NOPASSWD: to your sudoers file (/etc/sudoers.d/10-installer), but I wouldn’t recommend that.

    Cheers!

login68 manager41 Posts 12Views 1051
Log in to reply