• How to change display manager


    This post is deleted!
  • Available on the Wiki -
    (Akismet blocks my link as spam)

    Display Managers are provided for a login screen, which protects your desktop from unauthorized users.  Display Managers all provide their own styles, and different types of skin support. Their system resource requirements vary.
    Note:  This installation guide is assuming you are already using the default Lightdm Display Manager.
    Remove LightDM
    
    Before installing a different Display Manager, you must first remove LightDm with the following command.
    sudo pacman -Rcns lightdm
    Now that Lightdm is removed, do not logout or restart till you installed your desired manager.
    Display Manager Options
    
    SDDM (Recommended for KDE):
    
    sudo pacman -S sddm-kcm
    sudo systemctl -f enable sddm
    GDM (Recommended for GNOME):
    
    sudo pacman -S gdm
    sudo systemctl -f enable gdm
     
    Reboot Your System
    
    After installing and enabling a display manager, reboot your login system. You should now see the newly installed display manager's login screen. If you have any trouble or want to know how to install a display manager that isn't listed on this page, post a new question on the Antergos Forum.
    
  • @lmdz Thanks, I’ll give that a go.

  • @benisawesome192 , I would recomend keeping lightDM in case something goes wrong. If I were you, I d simply perform
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo reboot

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @lmdz Unfortunately, that didn’t work.
    Now when I startup my PC it just takes me into the command line.

  • @benisawesome192 said i

    @lmdz Unfortunately, that didn’t work.

    What exactly didn t work? Can please you be more specific as to what exactly you did?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Well basically I did what lmdz to do (because I saw that answer first) and now I’m left with a command line.

  • @benisawesome192 Command line is good.
    The OS is booting, maybe a problem with Graphics drivers, or the Display manager.
    Try to pull some logs to understand where the problem is

  • @benisawesome192 said

    Well basically I did what lmdz to do

    So I guess, but would you please mind posting EXACTLY what you did? It might be a helpful beginning…:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch OK right, I did this

    sudo pacman -Rcns lightdm

    sudo pacman -S gdm
    sudo systemctl -f enable gdm

  • @lmdz OK I had a look at systemctl and gdm.service is masked which might mean that it won’t enable but I’m not too sure.
    Also when I try to unmask gdm.service it just masks again :/

  • Did you disable lightdm first? You can’t enable gdm if you don’t disable lightdm before that.

    sudo systemctl disable lightdm

  • @karasu I deleted lightdm.

  • @benisawesome192 If you removed lightdm and are sure you installed Gdm you should be able to activate it with:

    sudo systemctl enable gdm -f
    

    or

    sudo systemctl enable gdm-service
    

    With or without -f (force).
    You should get a confirmation that it was successful. After that: reboot.

    Never to old to learn.

  • @axioma It keeps saying that gdm.service is masked even when I try to unmask it

  • @lmdz Ok right so what you’re saying is that i can’t unmask it and have to reinstall lightdm

display31 manager46 Posts 17Views 1604
Log in to reply