• Can't start Antergos after installation


    Hi,

    I’ve just bought a new laptop (ASUS X556UB) and decided to erase Windows 10 from it and install Antergos, for this I made the Live USB as the Antergos page says and installed it on my laptop. Everything was allright until the installation finished, it sent me to restart an I did, but since that moment I can’t run the system. The next message appears everytime I turn my computer on:

    starting version 231
    ERROR: resume: no device specified for hibernation
    AntergosRoot: clean, 211224/60530688 files 5644027/242115072 blocks
    [10.345105] tpm_crb MSFT0101:00: can´t request region for resource [mem 0xfed40040-0xfed4103f]
    

    This happens for a few seconds and then the screen turns black with a white cursor blinking on the left upper corner.

    Hope you can help me. Thank you!

  • I had a similar issue (of black screen with blinking cursor), although it did not show your hibernation error/warning.

    It was caused by LightDM & replacing it with SDDM helps, if you are able to access TTY (Ctrl + Alt + F1)
    Alternately you can do a fresh install & not choose ‘Auto Login’ if you had the first time.

    Also try without installing additional video drivers.

    Another option is to try booting with nomodeset as a kernel parameter

  • Firstly, I’m no expert.

    Secondly, Have you tried doing a quick re-install? Try that and tell us (meaning the experienced and/or experts) what happens.
    I’d suggest maybe starting from scratch as far as your Live USB is concerned as well, using SUSE Image Writer (on a Linux Installation OR even Live USB [i.e. If you have multiple USBs]). I find that Rufus on Windows does not play well with Arch-based Distros, as I have tried out Rufus with Antergos, Manjaro & Apricity. SUSE Image Writer just works properly all the time.

  • @creativapartheid I’ve tried re-installing, and the first time everything went right until the moment the system sent me to restart (as in the originall instalation), I did not installed any additional things and the same problem as in the original installation appeared. Then I tried to re-install for a 2nd time and I can’t, with or without the usb in, the problem shows.

  • @toledogarcia.eduardo
    Are you using the UEFI-boot or normal boot?

  • @toledogarcia-eduardo
    Grub is basically telling you that it (i.e. Grub2) is attempting to find a partition from which it is wanting to restore from a hibernation. In other words, it want’s to find a partition from which it can hibernate from.
    You probably don’t have hibernation going since you didn’t even get to boot your OS to do that in the 1st place.
    Hence, no device specified for hibernation

    Before you begin the below instruction, you will need to familiar yourself with what chrooting is and how to go about it.
    Go to the Arch Wiki and read this first:

    https://wiki.archlinux.org/index.php/change_root#Partition.28s.29_mount
    After you have familiarized yourself with the process, you can begin.

    1. You already have Antergos installed. Keep it.
      No need to reinstall.
    2. Boot up Antergos Live CD.
    3. access your terminal with sudo su so that you can gain access to your installed Antergos partion.
      Don’t forget to also mount your /boot partition with all of this.
      In other words, you will have to mount your /boot , swap, and your /dev/sdaX partition – your /dev/sdaX partition is where your Antergos OS is installed…
    4. After you have mounted your installed partitions releveant to your prior installation, you will have to then cd to /etc/default/grub
      ( YOUR INSTALLED ANTERGOS PARTITION. NOT YOUR LIVE CD PARTITION)
      and change
      GRUB_CMDLINE_LINUX_DEFAULT="quiet
      to
      GRUB_CMDLINE_LINUX_DEFAULT="quiet /dev/sdaX
      where /dev/sdaX corresponds to your swap partion number. You can find out what your swap partition number is by starting up gparted in the Live CD environment and having a look at what your Swap partition number is.
    5. Save and close your file that you just opened.
    6. Run to update your Grub2 with sudo mkconfig -o /boot/grub/grub2
    7. While still in your chroot environment, also you will need to do
      mkinitcpio -p linux
    8. At the very end of this process, don’t forget to sudo umount /mnt/Arch
    9. Reboot.
    10. Adjust your hibernation from within your actual installed system if you need / want to.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @toledogarcia.eduardo

    Ok. So @Modisc probably has your solution (i.e. the solution that does not require a reinstall). However, I still would like to know two things about your boot choice:

    1a). Are you going to use your machine to dual-boot Windows?
    1b). If yes, what is your reason for using UEFI (other than the fact that it is the new standard)?

    2a). Did you install a swap partition?
    2b). Do you need a swap partition?
    2c). For hibernation or speed?

    I ask you these questions because I have an 8Gb RAM laptop with 2Gb dedicated graphic memory and have no need for hibernation so I did not format/install a swap partition. I now tri-boot Windows 10 with Linux Distros on an MBR/DOS partition table. You can read my story here:
    https://forum.antergos.com/topic/4945/possible-fix-antergos-uefi-boot-installation-failure/1

    Though my post is largely centred around UEFI vs MBR, I ran into several errors during and after installation that have been popping up for a year now. My problem was fixed by using normal boot instead of UEFI boot. I hope @Modisc 's solution or mine allows you to run Antergos after today.

installation212 Posts 8Views 2664
Log in to reply