• The Dreaded "White Screen" with live USB


    Hello there,
    Looking to make the transition from Windows to Linux as my primary os and Antergos caught my attention.
    However, I seem to snagged at the live USB stage of the process wherein the USB will boot (kinda), take me to a boot selection, and then immediately after a selection I am slapped with dreaded white screen.
    Now, I have done a few hours of research and troubleshooting, but to no avail.

    My set up is this:
    AMD FX-8320
    Sapphire Radeon r9 390
    16GB ram
    Windows 7 Operating system

    I have three hard drives:
    One to keep windows on,
    One for data,
    and one fresh one waiting for Antergos.

    Admittedly, I am unsure what else I need to supply to troubleshoot, but any assistance would be immeasurably appreciated.
    Thanks.

  • @Deadgar64 Have you tried changing the video options at the Live USB screen to "No KMS?"
    This has helped a few virtualbox issues as well just in case you need it.

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @n_mag Don’t see that option. The only screen I get it the one that asks how I want to boot, unfortunately.

  • @Deadgar64 So, you don’t even get options to choose “Boot from hard disk” “Boot from Live CD” etc. ?

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @n_mag MY only options are:
    Antergos x86_64
    Antergos x86_64 (non-graphical fallback)
    Antergos x86_64 (Nvidia Fallback)
    UEFI Shell x86_64 v1
    UEFI Shell x86_64 v2
    EFI Default Loader
    Reboot into Firmware Interface

    By the way, thank you for lending a hand.
    Most appreciated.

  • @Deadgar64 hmmm, and I assume you’ve tried every option? I’ve usually only seen those options if I’m intentionally trying to use UEFI, otherwise when you’re choosing the USB stick before booting it up, there should be two different options. Basically one uses BIOS and the other is fancier with UEFI options as you see. Like I said, you get the list of boot items like your hard drive, disk, etc, and there’s two options for the antergos usb stick. This is what I get anyways, so let me know :)

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @Deadgar64 Have you tried using “nomodeset” ?

  • @Deadgar64 Give this a try:
    When you are at the boot selections, open the video settings - If I remember correctly: F3 - and change it to Default. (At the bottom of the screen) I had the same problem yesterday. Somehow, the installer chooses the screen size automatically, but will not boot in it. Changing the settings to default worked for me. Otherwise, try some of the other suggestions too. They are all listed in the video settings.

    Never to old to learn.

  • @n_mag I think I get it now; You’re talking about the machine’s boot menu not the USB drive, right?
    Heh, my mistake. I will give another look as soon as i get home today.

  • @lmdz said in The Dreaded "White Screen" with live USB:

    nomodeset

    I have not. I’m unfamiliar with it but I shall look it up.

  • @Deadgar64 did you ever figure out how to boot using uefi?

windows 73 installation194 white screen3 live usb9 Posts 11Views 1173
Log in to reply