• Gnome Won't Boot


    Strange issue here. I logged into Gnome. I had 12 updates. I began to type my root password. The phone rings. 15 minutes later, my screensaver is showing but Antergos will not start. No choice but to reboot. At the reboot, the system indicates it is recovering my Journal.

    I assume Gnome will start, but it doesn’t. I have a black screen. Reboot again and try Fallback Mode. Same issue. I really don’t have a clue what is going on. By the way I replaced Lightdm with GDM.

    Any ideas would be appreciated. I don’t want to reinstall.

    Thanks.

  • @parkslope said in Gnome Won't Boot:

    I began to type my root password. The phone rings.

    So, did you make the update or just entered the password an left? Anyway, try updating via the tty screen (Ctrl+F1 in GDM) , update the system and reboot to see if it helped.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    In the middle of typing the password the phone rang and then it was kinda over.

    By the way, I never get to GDM as all I get is a blank screen.

  • Ok…cleas enough. Do the above update I ve mentioned to see if it can get recovered.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Can you clarify this if I can’t get to GDM?

    Also would the Live USB stick help?

    Thanks

  • @parkslope said

    Can you clarify this if I can’t get to GDM?

    Sure. Turn on your pc and when it boots into the black screen press CTRL+F3. This will get you in a tty screen. (a black screen where you can execute commands). Type in your username when prompted, next type in your password and then you re ready to update your system as ussually with
    sudo pacman -Syu
    or even better (if you also have installed AUP) type in
    yaourt -Syua
    When the proccess is over, reboot typing the comand
    `sudo rebottq
    and let s hope this is enough!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @parkslope said

    By the way I replaced Lightdm with GDM

    Also, did you replace DMs before or after the problem? If you did it afterwards can you please mention the way you did it? Chances are that you haven t enabled it.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • GDM was installed a week ago and it never caused a problem or so I thought. You would know more.

    CTRL+F3 does not bring me a tty screen. I should have mentioned I tried this - sorry about that. Just a black screen.

  • @parkslope said in Gnome Won't Boot:

    CTRL+F3 does not bring me a tty screen

    Try with CTRL+(other) F keys. Someone will get you to a tty screen.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Just tried them all with no luck. Something tells me my system is hosed.

  • @parkslope Do you ever see any text when booting, and if you do, does it look like your screen LED lights are on but the screen is just blank?

    It kinda sounds like a graphics driver issue. If you want to save your system you can always use arch-chroot and repair the system through that way.

    What gpu and gpu-drivers are you using; do you know?

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • The LED lights are on with a blank screI am using the nvidia drivers as the nouveau drivers are buggy at best.
    How do i use arch-chroot to repair my system?

    I am somewhat out of of my league on this one. Also, I think Antergos should look into using the live USB Disk to diagnose and fix issues.

    Edit: Obviously Arch Live Image can be used to repair the system. Using the tutorial link text. I move along following the instructions. I get to the Using Chroot section with the instruction to cd /mnt/arch. Unfortunately, I get an error message saying file or directory does not exist.

    Not sure what I’m doing wrong here. Thanks if someone can help.

  • @parkslope You may try CTRL+ALT+F1 or other Fnumber
    Maybe your graphics started but there is a problem. If graphics started CTRL+Fx wont work. and do what #anarch suggested already. To enforce GDM you can try:

    sudo systemctl enable gdm.service -f
    

    Anyway did you removed lightdm.service before replacing it?

  • @louis_1
    Thanks for replying. I’m confused. How can I run any command with nothing but a blank screen? I assume you don’t mean with the Live USB stick.

    As for lightdm, I followed the instructions on another post and it worked flawlessly.

    By the way, I think you are correct the graphics card did start. As the monitor indicates it is on (a blue light).

    Also, I don’t use nouveau drivers due to a complete freeze on a regular basis. That goes for any OS I install. Nvidia drivers work perfectly. I even have the Antergos Live USB stick freeze on my system.

    Also I used the following command to replace lightdm ‘sudo systemctl disable lightdm && sudo systemctl enable gdm’.

  • Making progress. Ctrtl+Alt+F2 gives me tty!

    Bad news, there is a conflict as Lightdm is trying to update. I don’t understand why as I have been using GDM. I think I just need the command to remove the Lightdm update and the update can proceed. I’m not sure if this will correct the black screen issue, but things seem to be looking up.

  • @parkslope , my bad, sorry. To switch to a tty screen the correct key combination is Ctrl+Alt+F(3, 4,5,etc)
    NOT
    Ctrl+F(xxx) as I mistakenly mentioned.
    In GDM F1 is used for switching users and F2 to get back to your session. Sorry

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    I’ll give it a try. No worries, if it works great.

  • @anarch
    As I suspected, forcing the system service for GDM F2 did not work. Ctrl+Alt+F3 gets me a tty screen but trying to upgrade still gives me the error message regarding file conflicts (lightdm update)? What do you think?

  • What s the command & what s the error msg you re getting back? Could you post it, please?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hey,

    Ctrl+Alt+F3 gives me tty.

    yaourt -Syua gives me a list of seven updates including an update for lightdm. When trying to install a conflict with dependencies is noted and no updates were applied.

    sudo systemctl enable gdm.service -f works in the sense that it just brings me to another prompt. I’m not sure why or if there is something to do after that. Pressing F2 or F1 after that command does not bring up GDM.

    If GDM is installed, should I be getting an update for Lightdm?

    At least I got a tty prompt. :)

gnome219 boot159 Posts 27Views 2983
Log in to reply