• Display too large for screen


    This is a fresh install of Antergos on a Panasonic Toughbook CF-19 Mk3. Everything seems to work out-of-the-box except the display is sized for a much larger screen. I’ve tried to resize the display/screen via “settings” and “tweak tools” to no effect.

    The native display is 1024x768 but

    xrandr output:
    Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 32767 x 32767
    LVDS1 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    1280x1024 59.68*+
    1280x960 60.00
    1024x768 60.00
    800x600 60.32 56.25
    640x512 60.00
    640x480 59.94
    DP1 disconnected (normal left inverted right x axis y axis)
    VGA1 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)

    UPDATE: Debian based distros detect the display perfectly but Arch based distros don’t

  • @gmmatooten Sorry just trying to make sure I understand what you’re saying because I see the resolution you need in the output.
    Your display’s native resolution= 1024x768, but the settings will not resize it correctly to the resolution even though you changed it to that?

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • “Your display’s native resolution= 1024x768, but the settings will not resize it correctly to the resolution even though you changed it to that?” Yes, correct.

    I have installed several debian based distros to troubleshoot (Debian, Ubuntu & Kali linux) each of these detected the display without issue but I experience the same problem when I install a base Arch system or Antergos. I’m also unable to adjust the Aspect Ratio from 5:4 to 4:3.

    I can see the menu options: Settings–>Display Settings–>Built in Display–>Resolution: 1024x768 (4:3)
    but toggling these options distort the resolution even more.

    I’ve had a basic Arch install with gnome running flawlessly for a few months but updating yesterday created
    this issue. If it hadn’t been for this issue I probably would never have discovered Antergos!

  • UPDATE:

    I have tried KDE / XFCE both suffered the same issues but a liveUSB of Antergos works perfectly without display/resolution issues.

  • Hey @gmmatooten

    I have quickly checked the spec of the Toughbook 19 and it looks like its using an Intel graphics card
    ftp://ftp.panasonic.com/computer/toughbook19/toughbook-19_specsheet.pdf

    Make sure the Intel driver is installed

    sudo pacman -S  xf86-video-intel --needed
    
  • Hello everybody…! I’m new here, congratulations for your work!

    I’d like to implement Antergos on my “ancient” Sony VAIO*, however I have the same trouble than @gmmatooten :

    “Big Screen edges and bad horizontal cut off” (I think that’s it)

    The strange thing is that in the live start of Antergos, the screen looks like perfect, but after the installation and reboot, the problems with the screen start…

    THIS IS MY PC
    (*)https://docs.sony.com/release//specs/VGNCR440F_mksp.pdf

    [email protected]:~> xrandr
    Screen 0: minimum 8 x 8, current 1280 x 800, maximum 32767 x 32767
    LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    1280x800 60.00*+
    1024x768 60.00
    800x600 60.32 56.25
    640x480 59.94
    640x400 60.00
    TV1 disconnected (normal left inverted right x axis y axis)
    VGA1 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)

    In other distros I don’t have any problem… I tried by installing Manjaro Linux, Ubuntu, Open SUSE, and I don’t have inconveniences with my screen…

    Any help will be appreciated, thank you very much!

    Richy

  • [SOLVED]

    The recent kernel update is the issue here. I fixed my problem by downgrading all packages. Not sure if this works exactly the same on Antergos as it does on a “pure Arch” installation but the process is super-simple:

    1. Restore all packages to a specific date (note: I used 2016/08/01)

    To restore all packages to their version at a specific date, let’s say 01 August 2016, you have to direct pacman to this date, by editing your /etc/pacman.conf and use the following server directive:

    [core]
    SigLevel = PackageRequired
    Server=https://archive.archlinux.org/repos/2014/03/30/$repo/os/$arch

    [extra]
    SigLevel = PackageRequired
    Server=https://archive.archlinux.org/repos/2014/03/30/$repo/os/$arch

    [community]
    SigLevel = PackageRequired
    Server=https://archive.archlinux.org/repos/2014/03/30/$repo/os/$arch

    (comment out --place a # infront of-- whatever is listed beneath core, extra, community)

    2. Then update the database and force downgrade:

    pacman -Syyuu

    Here’s a link to the official documentation: [https://wiki.archlinux.org/index.php/Arch_Linux_Archive](link url)

  • @gmmatooten , why not give the lts kernel a try? If it is a kernel update issue as you suggest, the lts kernel could possibly save you time and effort…
    @superichy , the same goes for you, too…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hello! Thank you for your reply!

    I have already tried the LTS Kernel and, the same thing…
    Now, I printed out your instructions, and I’ll gonna try a new (and fresh) install on the VAIO I commented, after that, I’m comming back here to tell you the results… Thanks and very thanks!

    PS: Is there any way to solve this question in a new Antergos release?
    2, With all packages to specific to a specific date, what’s happen with the updates? wich is the diference?

  • @superichy If you’re experiencing what I am you need to downgrade your kernel. Arch runs fantastically on all my “legacy machines” and this is the first real issue I’ve had but it’s only a 2 part fix once you know what you need to do. I posted the steps I used below. Good luck!

  • @gmmatooten
    We are writing at the same time…! :-)

    Yes, that’s the idea. I want this distro for my “ancient” PC because something what I loved… Is the possibility to select some software at the installation time. Great! Keep in touch, best regards…

    Richy

  • Yup arch or antergos are really great to use - especially for legacy hardware! I discovered Antergos after this problem manifested itself. I’m pretty much a DYI kinda person and with the bloom of hardware available on the open market it’s almost crazy to not atleast consider used hardware (laptops, etc.). Also the above suggestion of installing linux-lts is great advice - could be a better route to go. I went with downgrading so I could learn more. Cheers!

  • @anarch thank you for recommending linux-lts. Now that I’ve learned how to downgrade I’ll play around with lts. I’m loving this journey though - problems always lead to solutions! Thank you for helping keeping the knowledge flowing. It is greatly appreciated!

  • Yes, this open our minds for other’s life ambits, too!
    There is my VAIO, in Antegos installing proccess… Looking like perfect in live with GNOME environment.

    I selected CINNAMON as deffault desktop, then I’ll try boot both Kernels again and see…
    Finally, I’ll will try to edit the settings that our friend @gmmatooten gave for us, have a good day! See you!

  • Hello all! It’s me again… :-)

    What’s @anarch says… IS CORRECT:
    By selecting LTS Kernel for booting, the screen / display problem disappear… And everything works perfect.

    If you are booting with deffault Kernel, you will have the troubles we spoke yesterday…
    I didn’t try @Gmmatooten’s tricks yet. Then I’ll tell you.

    Look at some screenshots and, a photo I took with my phone :

    Here you can see… It seems the screen “reflects”
    alt text

    And here, a screenshot from Antergos Desktop with deffault Kernel
    alt text

  • @superichy , glad you made it! But you dibn t really nee to re-install. You could simply add the lts kernel to your existing installation.
    sudo pacman -S linux-lts
    and regenerate your grub with:
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    I didn t mention it because you said you had already tried the lts kernel unsuccessfully…
    Cheers

    PS: Thank you both for your kind words:blush:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

display30 Posts 16Views 1203
Log in to reply