• Messed up switching lightDM & GDM - black screen

    Messed up switching lightDM & GDM - black screen after boot (no login screen)

    Hola! Apologies if my post doesn’t abide by any of the forum rules (it’s my first time!)
    Total newbie here, used only Ubuntu previously, played around with Fedora for a few months - I’m really just more of a user type of guy ^^. Using the OS as a virtual music recording studio.
    However, I managed to screw my installation as described in the subject - even though I followed this guide - trying to switch to GDM - the last point in the guide.
    Now when booting there’s a line indicating i did something wrong - it says something along the lines as - two files files are pointing to the display manager service…
    I get a black screen after the boot, anyone can guide me through how to boot through a LiveUSB and fix? Again, I’m a total noob when it comes to commands…
    I’ve tried to search for some guidance on how to fix this, but to no avail.

    Thank’s a bunch in advance!

    LightDM log:
    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.18.2, UID=0 PID=482
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.00s] DEBUG: Registered seat module xlocal
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.00s] DEBUG: Monitoring logind for seats
    [+0.00s] DEBUG: New seat added from logind: seat0
    [+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.00s] DEBUG: Seat seat0: Starting
    [+0.00s] DEBUG: Seat seat0: Creating greeter session
    [+0.00s] DEBUG: Seat seat0: Failed to find session configuration lightdm-gtk-greeter
    [+0.00s] DEBUG: Seat seat0: Failed to create greeter session
    [+0.00s] DEBUG: Failed to start seat: seat0

  • Assuming GDM is installed, open a tty screen with Ctrl+Alt+F2
    Type your user name when prompted
    Your password and afterwords
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo reboot
    If GDM is not installed, you ll have to install it using
    sudo pacman -S gdm

  • Thank you for the quick reply!

    my login and pass didn’t work - got a message that my login or password is incorrect. I just put in “root” and i could move forward. (You can tell I’m not very familiar with this by now, right? :))
    this is what i got after following your instructions:
    Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is symlink to /usr/lib/systemd/system/lightdm-plymouth.service.

    I sense the next step is something very simple, thanks again for the help! :)

  • Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is symlink to /usr/lib/systemd/system/lightdm-plymouth.service

    Have you also installed plymouth ? I could be wrong but this might be the case. Once i d done it myself and could not switch DMs…

  • I would like to add that if ```

    sudo systemctl enable gdm

    does not work for you, you might try to force the DM by adding: -f

    sudo systemctl enable -f gdm
  • Hi guys, tried both, tried removing GDM and reinstalling&re-enabling LightDM, nothing worked. When booting there was a message that the LightDM service is has duplicate symlinks.

    I’ve sorted it out by reinstalling Antergos, as I had split my volumes to / & /home, so just had to reinstall the apps I’m using on top.

    Thanks again for the effort! :)

  • you have removed the lightdm-webkit2-greeter however it calls ?

    Lightdm seems not find it, so it search for lightdm-gtk-greeter standard.

    i think thats the issue?

    lightdm-gtk-greeter is a standard greeter, but if you remove the webkit-greeter but reinstall lightdm back without reinstall the greeter then it get dark?

  • Could be, possibly. I wasn’t able to find a workaround/fix, and needed to use the machine so I chose to reinstall quickly. Currently working on a clonezilla backup for the system just in case ⚡

lightdm137 gdm49 switching14 messed7 Posts 8Views 3572
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.